summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2007-07-06 16:36:56 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2007-07-06 16:36:56 +0000
commitff0abca02f02201a297338a71a00667040358c7d (patch)
treed8fb25317b5a50f1e0716ed52a5bcc0f49ea3625 /media-sound/seq24
parentAdd revdep-rebuild instructions to pkg_postinst() (diff)
downloadgentoo-2-ff0abca02f02201a297338a71a00667040358c7d.tar.gz
gentoo-2-ff0abca02f02201a297338a71a00667040358c7d.tar.bz2
gentoo-2-ff0abca02f02201a297338a71a00667040358c7d.zip
Add a pkg_setup check for the midi USE flag in alsa-lib; disable the ALSA test, we expect it to be present.
(Portage version: 2.1.3_rc6)
Diffstat (limited to 'media-sound/seq24')
-rw-r--r--media-sound/seq24/ChangeLog6
-rw-r--r--media-sound/seq24/seq24-0.8.7.ebuild18
2 files changed, 20 insertions, 4 deletions
diff --git a/media-sound/seq24/ChangeLog b/media-sound/seq24/ChangeLog
index 7250fe7d7717..343be0b533e6 100644
--- a/media-sound/seq24/ChangeLog
+++ b/media-sound/seq24/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-sound/seq24
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/seq24/ChangeLog,v 1.26 2007/07/02 15:19:24 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/seq24/ChangeLog,v 1.27 2007/07/06 16:36:56 flameeyes Exp $
+
+ 06 Jul 2007; Diego Pettenò <flameeyes@gentoo.org> seq24-0.8.7.ebuild:
+ Add a pkg_setup check for the midi USE flag in alsa-lib; disable the ALSA
+ test, we expect it to be present.
02 Jul 2007; Diego Pettenò <flameeyes@gentoo.org> metadata.xml:
Hand to newly-born proaudio herd.
diff --git a/media-sound/seq24/seq24-0.8.7.ebuild b/media-sound/seq24/seq24-0.8.7.ebuild
index 95e5c1b86fdb..cf1e5b0c4baf 100644
--- a/media-sound/seq24/seq24-0.8.7.ebuild
+++ b/media-sound/seq24/seq24-0.8.7.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/seq24/seq24-0.8.7.ebuild,v 1.1 2006/09/11 04:07:32 metalgod Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/seq24/seq24-0.8.7.ebuild,v 1.2 2007/07/06 16:36:56 flameeyes Exp $
+
+inherit eutils
IUSE="jack lash"
DESCRIPTION="Seq24 is a loop based MIDI sequencer with focus on live performances."
@@ -16,15 +18,25 @@ DEPEND=">=media-libs/alsa-lib-0.9.0
jack? ( >=media-sound/jack-audio-connection-kit-0.90.0 )
lash? ( >=media-sound/lash-0.5.0 )"
+pkg_setup() {
+ if ! built_with_use --missing true media-libs/alsa-lib midi; then
+ eerror ""
+ eerror "To be able to build ${CATEGORY}/${PN} with ALSA support you"
+ eerror "need to have built media-libs/alsa-lib with midi USE flag."
+ die "Missing midi USE flag on media-libs/alsa-lib"
+ fi
+}
+
src_compile() {
econf \
$(use_enable jack jack-support) \
$(use_enable lash) \
+ --disable-alsatest \
|| die
emake || die
}
src_install() {
- make DESTDIR="${D}" install || die
+ emake DESTDIR="${D}" install || die
dodoc AUTHORS ChangeLog README RTC SEQ24
}