summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2008-12-19 11:50:38 +0000
committerAlexis Ballier <aballier@gentoo.org>2008-12-19 11:50:38 +0000
commit2e38fafe4855236f7f31ced4b119cf38308afa98 (patch)
tree955c2ad12d4f549da30e2cf66c59f680f2495e7c /media-sound/sidplay
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-2e38fafe4855236f7f31ced4b119cf38308afa98.tar.gz
gentoo-2-2e38fafe4855236f7f31ced4b119cf38308afa98.tar.bz2
gentoo-2-2e38fafe4855236f7f31ced4b119cf38308afa98.zip
Fix build with gcc 4.3 by fixing configure checks; autreconfing it requires to rewrite many parts of the build system if we want it to work with eg libtool 2... closes bug #251251
(Portage version: 2.2_rc17/cvs/Linux 2.6.27.8 x86_64)
Diffstat (limited to 'media-sound/sidplay')
-rw-r--r--media-sound/sidplay/ChangeLog10
-rw-r--r--media-sound/sidplay/files/sidplay-2.0.9-gcc43.patch48
-rw-r--r--media-sound/sidplay/sidplay-2.0.9.ebuild12
3 files changed, 66 insertions, 4 deletions
diff --git a/media-sound/sidplay/ChangeLog b/media-sound/sidplay/ChangeLog
index 2792eb2f0967..dedb34461eb8 100644
--- a/media-sound/sidplay/ChangeLog
+++ b/media-sound/sidplay/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/sidplay
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/sidplay/ChangeLog,v 1.15 2007/07/02 15:22:38 drac Exp $
+# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/sidplay/ChangeLog,v 1.16 2008/12/19 11:50:38 aballier Exp $
+
+ 19 Dec 2008; Alexis Ballier <aballier@gentoo.org>
+ +files/sidplay-2.0.9-gcc43.patch, sidplay-2.0.9.ebuild:
+ Fix build with gcc 4.3 by fixing configure checks; autreconfing it
+ requires to rewrite many parts of the build system if we want it to work
+ with eg libtool 2... closes bug #251251
02 Jul 2007; Samuli Suominen <drac@gentoo.org> sidplay-2.0.9.ebuild:
Remove RESTRICT as it's not required. Old policy for not mirroring files
diff --git a/media-sound/sidplay/files/sidplay-2.0.9-gcc43.patch b/media-sound/sidplay/files/sidplay-2.0.9-gcc43.patch
new file mode 100644
index 000000000000..b1a24e59b9a7
--- /dev/null
+++ b/media-sound/sidplay/files/sidplay-2.0.9-gcc43.patch
@@ -0,0 +1,48 @@
+Index: sidplay-2.0.9/configure
+===================================================================
+--- sidplay-2.0.9.orig/configure
++++ sidplay-2.0.9/configure
+@@ -19985,11 +19985,11 @@ _ACEOF
+ cat confdefs.h >>conftest.$ac_ext
+ cat >>conftest.$ac_ext <<_ACEOF
+ /* end confdefs.h. */
+-#include <new.h>
++#include <new>
+ int
+ main ()
+ {
+-char* buf = new(nothrow) char[1024];
++char* buf = new(std::nothrow) char[1024];
+ ;
+ return 0;
+ }
+@@ -20052,11 +20052,11 @@ _ACEOF
+ cat confdefs.h >>conftest.$ac_ext
+ cat >>conftest.$ac_ext <<_ACEOF
+ /* end confdefs.h. */
+-#include <fstream.h>
++#include <fstream>
+ int
+ main ()
+ {
+-ifstream myTest(ios::in|ios::binary);
++std::ifstream myTest("test.txt", std::ios::in|std::ios::binary);
+ ;
+ return 0;
+ }
+@@ -20118,12 +20118,12 @@ _ACEOF
+ cat confdefs.h >>conftest.$ac_ext
+ cat >>conftest.$ac_ext <<_ACEOF
+ /* end confdefs.h. */
+-#include <fstream.h>
+- #include <iomanip.h>
++#include <fstream>
++ #include <iomanip>
+ int
+ main ()
+ {
+-ios::openmode myTest = ios::in;
++std::ios::openmode myTest = std::ios::in;
+ ;
+ return 0;
+ }
diff --git a/media-sound/sidplay/sidplay-2.0.9.ebuild b/media-sound/sidplay/sidplay-2.0.9.ebuild
index 6d4fde29cf72..bcccac1f5e20 100644
--- a/media-sound/sidplay/sidplay-2.0.9.ebuild
+++ b/media-sound/sidplay/sidplay-2.0.9.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/sidplay/sidplay-2.0.9.ebuild,v 1.7 2007/07/02 15:22:38 drac Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/sidplay/sidplay-2.0.9.ebuild,v 1.8 2008/12/19 11:50:38 aballier Exp $
+
+inherit eutils
DESCRIPTION="C64 SID player"
HOMEPAGE="http://sidplay2.sourceforge.net/"
@@ -15,6 +17,12 @@ RDEPEND=">=media-libs/libsidplay-2.1.0"
DEPEND="${RDEPEND}
dev-util/pkgconfig"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-gcc43.patch"
+}
+
src_install () {
emake DESTDIR=${D} install || die "emake install failed."
dodoc TODO AUTHORS ChangeLog