summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2007-05-07 01:37:52 +0000
committerRyan Hill <dirtyepic@gentoo.org>2007-05-07 01:37:52 +0000
commitd94a562b9e6a40d10b88cfcf5c7037bd39b945bc (patch)
tree956b8b537e6c53b29869ebafdcc71fa95e92cf40 /media-sound/sooperlooper
parentFix GCC 4 compile error (bug #150823), wxGTK usage, and general Makefile (diff)
downloadgentoo-2-d94a562b9e6a40d10b88cfcf5c7037bd39b945bc.tar.gz
gentoo-2-d94a562b9e6a40d10b88cfcf5c7037bd39b945bc.tar.bz2
gentoo-2-d94a562b9e6a40d10b88cfcf5c7037bd39b945bc.zip
Add patch for build failure on amd64 (bug #176751).
(Portage version: 2.1.2.6)
Diffstat (limited to 'media-sound/sooperlooper')
-rw-r--r--media-sound/sooperlooper/ChangeLog7
-rw-r--r--media-sound/sooperlooper/files/sooperlooper-1.1.0-amd64.patch21
-rw-r--r--media-sound/sooperlooper/sooperlooper-1.0.8c.ebuild7
-rw-r--r--media-sound/sooperlooper/sooperlooper-1.1.0.ebuild7
4 files changed, 37 insertions, 5 deletions
diff --git a/media-sound/sooperlooper/ChangeLog b/media-sound/sooperlooper/ChangeLog
index 75be6fa7de6e..3352efbc7e08 100644
--- a/media-sound/sooperlooper/ChangeLog
+++ b/media-sound/sooperlooper/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/sooperlooper
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/sooperlooper/ChangeLog,v 1.5 2007/04/30 02:24:19 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/sooperlooper/ChangeLog,v 1.6 2007/05/07 01:37:52 dirtyepic Exp $
+
+ 07 May 2007; Ryan Hill <dirtyepic@gentoo.org>
+ +files/sooperlooper-1.1.0-amd64.patch, sooperlooper-1.0.8c.ebuild,
+ sooperlooper-1.1.0.ebuild:
+ Add patch for build failure on amd64 (bug #176751).
*sooperlooper-1.1.0 (30 Apr 2007)
diff --git a/media-sound/sooperlooper/files/sooperlooper-1.1.0-amd64.patch b/media-sound/sooperlooper/files/sooperlooper-1.1.0-amd64.patch
new file mode 100644
index 000000000000..5acfc65c66ee
--- /dev/null
+++ b/media-sound/sooperlooper/files/sooperlooper-1.1.0-amd64.patch
@@ -0,0 +1,21 @@
+diff -Naur sooperlooper-1.1.0-orig/src/gui/midi_bind_panel.cpp sooperlooper-1.1.0/src/gui/midi_bind_panel.cpp
+--- sooperlooper-1.1.0-orig/src/gui/midi_bind_panel.cpp 2007-04-14 21:12:31.000000000 -0600
++++ sooperlooper-1.1.0/src/gui/midi_bind_panel.cpp 2007-05-06 19:20:55.000000000 -0600
+@@ -465,7 +465,7 @@
+ itemid++;
+ }
+
+- _listctrl->SortItems (list_sort_callback, (unsigned) _listctrl);
++ _listctrl->SortItems (list_sort_callback, (unsigned long) _listctrl);
+
+ for (long i=0; i < _listctrl->GetItemCount(); ++i) {
+ item.SetId(i);
+@@ -582,7 +582,7 @@
+ _currinfo.channel = _chan_spin->GetValue() - 1;
+
+ if (_loopnum_combo->GetSelection() >= 0) {
+- _currinfo.instance = (int) _loopnum_combo->GetClientData(_loopnum_combo->GetSelection()) - 1;
++ _currinfo.instance = (unsigned long) _loopnum_combo->GetClientData(_loopnum_combo->GetSelection()) - 1;
+ }
+ else {
+ _currinfo.instance = -1;
diff --git a/media-sound/sooperlooper/sooperlooper-1.0.8c.ebuild b/media-sound/sooperlooper/sooperlooper-1.0.8c.ebuild
index 506e940d1295..87a40b50a165 100644
--- a/media-sound/sooperlooper/sooperlooper-1.0.8c.ebuild
+++ b/media-sound/sooperlooper/sooperlooper-1.0.8c.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/sooperlooper/sooperlooper-1.0.8c.ebuild,v 1.2 2007/04/30 02:24:19 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/sooperlooper/sooperlooper-1.0.8c.ebuild,v 1.3 2007/05/07 01:37:52 dirtyepic Exp $
-inherit wxwidgets
+inherit eutils wxwidgets
DESCRIPTION="Live looping sampler with immediate loop recording"
HOMEPAGE="http://essej.net/sooperlooper/index.html"
@@ -23,6 +23,9 @@ DEPEND=">=media-sound/jack-audio-connection-kit-0.80.0
dev-libs/libxml2"
src_compile() {
+ # Bug #176751
+ epatch "${FILESDIR}"/${PN}-1.1.0-amd64.patch
+
WX_GTK_VER="2.6"
need-wxwidgets gtk2
diff --git a/media-sound/sooperlooper/sooperlooper-1.1.0.ebuild b/media-sound/sooperlooper/sooperlooper-1.1.0.ebuild
index dcde2c45d813..d3721266002f 100644
--- a/media-sound/sooperlooper/sooperlooper-1.1.0.ebuild
+++ b/media-sound/sooperlooper/sooperlooper-1.1.0.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/sooperlooper/sooperlooper-1.1.0.ebuild,v 1.1 2007/04/30 02:24:19 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/sooperlooper/sooperlooper-1.1.0.ebuild,v 1.2 2007/05/07 01:37:52 dirtyepic Exp $
-inherit wxwidgets
+inherit eutils wxwidgets
DESCRIPTION="Live looping sampler with immediate loop recording"
HOMEPAGE="http://essej.net/sooperlooper/index.html"
@@ -23,6 +23,9 @@ DEPEND=">=media-sound/jack-audio-connection-kit-0.80.0
dev-libs/libxml2"
src_compile() {
+ # Bug #176751
+ epatch "${FILESDIR}"/${P}-amd64.patch
+
WX_GTK_VER="2.6"
need-wxwidgets gtk2