summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2002-05-19 19:36:48 +0000
committerAron Griffis <agriffis@gentoo.org>2002-05-19 19:36:48 +0000
commitb4287c16879745ae9ea79d55b28a980dc314ed72 (patch)
treead53f09229adca4f41c305dfca795ea84b57ba3f /media-sound/timidity-eawpatches
parentpart-way through the xemacs overhaul (diff)
downloadgentoo-2-b4287c16879745ae9ea79d55b28a980dc314ed72.tar.gz
gentoo-2-b4287c16879745ae9ea79d55b28a980dc314ed72.tar.bz2
gentoo-2-b4287c16879745ae9ea79d55b28a980dc314ed72.zip
Added eawpatches for Timidity++
Diffstat (limited to 'media-sound/timidity-eawpatches')
-rw-r--r--media-sound/timidity-eawpatches/ChangeLog9
-rw-r--r--media-sound/timidity-eawpatches/files/digest-timidity-eawpatches-121
-rw-r--r--media-sound/timidity-eawpatches/files/timidity-eawpatches-12-gentoo.diff20
-rw-r--r--media-sound/timidity-eawpatches/timidity-eawpatches-12.ebuild35
4 files changed, 65 insertions, 0 deletions
diff --git a/media-sound/timidity-eawpatches/ChangeLog b/media-sound/timidity-eawpatches/ChangeLog
new file mode 100644
index 000000000000..d8cff24e8f88
--- /dev/null
+++ b/media-sound/timidity-eawpatches/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for media-sound/timidity-eawpatches
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/media-sound/timidity-eawpatches/ChangeLog,v 1.1 2002/05/19 19:36:48 agriffis Exp $
+
+*timidity-eawpatches-12 (19 May 2002)
+
+ 19 May 2002; Aron Griffis <agriffis@gentoo.org> timidity-eawpatches-12:
+
+ Set of patches for use with timidity++.
diff --git a/media-sound/timidity-eawpatches/files/digest-timidity-eawpatches-12 b/media-sound/timidity-eawpatches/files/digest-timidity-eawpatches-12
new file mode 100644
index 000000000000..e21b59465f77
--- /dev/null
+++ b/media-sound/timidity-eawpatches/files/digest-timidity-eawpatches-12
@@ -0,0 +1 @@
+MD5 1f49190da4b1b4bdf999e0351edda8f2 eawpats12_full.rar 24444187
diff --git a/media-sound/timidity-eawpatches/files/timidity-eawpatches-12-gentoo.diff b/media-sound/timidity-eawpatches/files/timidity-eawpatches-12-gentoo.diff
new file mode 100644
index 000000000000..ab52cdf94dd3
--- /dev/null
+++ b/media-sound/timidity-eawpatches/files/timidity-eawpatches-12-gentoo.diff
@@ -0,0 +1,20 @@
+--- timidity.cfg.old 1999-12-14 10:13:04.000000000 -0500
++++ timidity.cfg 2002-05-19 15:25:51.000000000 -0400
+@@ -27,7 +27,7 @@
+ # If you've moved things around since compiling, uncomment and edit this to
+ # point to the library directory:
+ #
+-dir c:\timidity
++dir /usr/share/timidity
+ #
+
+ ##############################################################################
+@@ -58,7 +58,7 @@
+ # If you have the GUS General MIDI patch set, uncomment the following lines
+ # and edit the "dir" statement to point to your GUS patch directory.
+ #
+-dir c:\eawpats
++dir /usr/share/timidity/eawpatches
+ source gravis.cfg
+ source gsdrums.cfg
+ source gssfx.cfg
diff --git a/media-sound/timidity-eawpatches/timidity-eawpatches-12.ebuild b/media-sound/timidity-eawpatches/timidity-eawpatches-12.ebuild
new file mode 100644
index 000000000000..c870d73adac2
--- /dev/null
+++ b/media-sound/timidity-eawpatches/timidity-eawpatches-12.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Aron Griffis <agriffis@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/media-sound/timidity-eawpatches/timidity-eawpatches-12.ebuild,v 1.1 2002/05/19 19:36:48 agriffis Exp $
+
+S=${WORKDIR}
+DESCRIPTION="Eric Welsh's GUS patches for TiMidity"
+SRC_URI="http://www.stardate.bc.ca/eawpatches/eawpats${PV}_full.rar"
+HOMEPAGE="http://www.stardate.bc.ca/eawpatches/html/default.htm"
+
+DEPEND="media-sound/timidity++
+ app-arch/unrar"
+
+src_unpack() {
+ mkdir eawpatches
+ cd eawpatches
+ unrar x "${DISTDIR}/${A}" || die "error unpacking ${DISTDIR}/${A}"
+
+ # Patch the default configuration so the patches can be found
+ patch -p0 < "${FILESDIR}/${PF}-gentoo.diff"
+}
+
+src_install () {
+ instdir="${D}/usr/share/timidity"
+ mkdir -p "${instdir}"
+ mv eawpatches "${instdir}"
+
+ # Make sure ownership and perms are sane
+ cd "${instdir}"
+ chown -R root.root eawpatches
+ chmod -R a+rX,go-w eawpatches
+
+ # Install timidity.cfg where timidity can find it
+ mv eawpatches/timidity.cfg .
+}