summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2011-04-07 12:12:45 +0000
committerAlexis Ballier <aballier@gentoo.org>2011-04-07 12:12:45 +0000
commita7482606c427bbc689ca7e015a936d5fd0d565b1 (patch)
tree89985dd3f3e17cd80ecad9d6ea16f0bfaeeb2324 /media-sound/twolame
parentFirst release (diff)
downloadgentoo-2-a7482606c427bbc689ca7e015a936d5fd0d565b1.tar.gz
gentoo-2-a7482606c427bbc689ca7e015a936d5fd0d565b1.tar.bz2
gentoo-2-a7482606c427bbc689ca7e015a936d5fd0d565b1.zip
version bump
(Portage version: 2.2.0_alpha29/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/twolame')
-rw-r--r--media-sound/twolame/ChangeLog7
-rw-r--r--media-sound/twolame/twolame-0.3.13.ebuild46
2 files changed, 52 insertions, 1 deletions
diff --git a/media-sound/twolame/ChangeLog b/media-sound/twolame/ChangeLog
index f9061f0926e1..dbb3e6823033 100644
--- a/media-sound/twolame/ChangeLog
+++ b/media-sound/twolame/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/twolame
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/twolame/ChangeLog,v 1.41 2011/03/20 11:15:49 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/twolame/ChangeLog,v 1.42 2011/04/07 12:12:45 aballier Exp $
+
+*twolame-0.3.13 (07 Apr 2011)
+
+ 07 Apr 2011; Alexis Ballier <aballier@gentoo.org> +twolame-0.3.13.ebuild:
+ version bump
20 Mar 2011; Raúl Porcel <armin76@gentoo.org> twolame-0.3.12.ebuild:
arm stable
diff --git a/media-sound/twolame/twolame-0.3.13.ebuild b/media-sound/twolame/twolame-0.3.13.ebuild
new file mode 100644
index 000000000000..efd162102d71
--- /dev/null
+++ b/media-sound/twolame/twolame-0.3.13.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/twolame/twolame-0.3.13.ebuild,v 1.1 2011/04/07 12:12:45 aballier Exp $
+
+EAPI=3
+inherit libtool
+
+DESCRIPTION="TwoLAME is an optimised MPEG Audio Layer 2 (MP2) encoder"
+HOMEPAGE="http://www.twolame.org"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="static-libs"
+
+RDEPEND=">=media-libs/libsndfile-1"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_prepare() {
+ sed -i -e '/CFLAGS/s:-O3::' configure || die
+
+ if [[ ${CHOST} == *solaris* ]]; then
+ # libsndfile doesn't like -std=c99 on Solaris
+ sed -i -e '/CFLAGS/s:-std=c99::' configure || die
+ fi
+
+ elibtoolize
+}
+
+src_configure() {
+ econf \
+ --disable-dependency-tracking \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ emake DESTDIR="${D}" pkgdocdir="${EPREFIX}/usr/share/doc/${PF}" \
+ install || die
+
+ dodoc AUTHORS ChangeLog README TODO
+ prepalldocs
+
+ find "${ED}" -name '*.la' -exec rm -f '{}' +
+}