summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2004-04-08 09:40:50 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2004-04-08 09:40:50 +0000
commit4dcd26bfdf6a33576e461f26bbb28d9e2f28754e (patch)
treef99faa31bd16fc6f72f805afb02aa23362555e80 /media-sound/umix/umix-1.0.2.ebuild
parentAdded a patch to allow glibc-1.2.10-r5 compile under gcc-3.4.x. Closes Bug #... (diff)
downloadgentoo-2-4dcd26bfdf6a33576e461f26bbb28d9e2f28754e.tar.gz
gentoo-2-4dcd26bfdf6a33576e461f26bbb28d9e2f28754e.tar.bz2
gentoo-2-4dcd26bfdf6a33576e461f26bbb28d9e2f28754e.zip
Version bump. Removed explicit S=. RESTRICT="nomirror"
Diffstat (limited to 'media-sound/umix/umix-1.0.2.ebuild')
-rw-r--r--media-sound/umix/umix-1.0.2.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/media-sound/umix/umix-1.0.2.ebuild b/media-sound/umix/umix-1.0.2.ebuild
new file mode 100644
index 000000000000..67bf7ac3f2ae
--- /dev/null
+++ b/media-sound/umix/umix-1.0.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/umix/umix-1.0.2.ebuild,v 1.1 2004/04/08 09:40:50 eradicator Exp $
+
+DESCRIPTION="Program for adjusting soundcard volumes"
+HOMEPAGE="http://umix.sf.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+RESTRICT="nomirror"
+
+SLOT="0"
+KEYWORDS="~x86 ~sparc"
+LICENSE="GPL-2"
+IUSE="ncurses oss"
+
+DEPEND="ncurses? ( >=sys-libs/ncurses-5.2 )"
+
+src_compile() {
+ local myconf
+ use ncurses || myconf="--disable-ncurses"
+ use oss || myconf="${myconf} --disable-oss"
+ econf ${myconf} || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install
+ dodoc AUTHORS ChangeLog NEWS README TODO
+}