summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-06-19 10:57:37 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-06-19 10:57:37 +0000
commitff0be14f11d8d8bb94435755b4d0d46d4feb314d (patch)
tree63ee6597d9b4f1aa539df6a0df17d8bd231a3a7b /media-sound/wavegain/wavegain-1.2.8.ebuild
parentrespect ldflags (diff)
downloadgentoo-2-ff0be14f11d8d8bb94435755b4d0d46d4feb314d.tar.gz
gentoo-2-ff0be14f11d8d8bb94435755b4d0d46d4feb314d.tar.bz2
gentoo-2-ff0be14f11d8d8bb94435755b4d0d46d4feb314d.zip
Version bump.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/wavegain/wavegain-1.2.8.ebuild')
-rw-r--r--media-sound/wavegain/wavegain-1.2.8.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/media-sound/wavegain/wavegain-1.2.8.ebuild b/media-sound/wavegain/wavegain-1.2.8.ebuild
new file mode 100644
index 000000000000..b41434413c56
--- /dev/null
+++ b/media-sound/wavegain/wavegain-1.2.8.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/wavegain/wavegain-1.2.8.ebuild,v 1.1 2009/06/19 10:57:37 ssuominen Exp $
+
+inherit toolchain-funcs
+
+DESCRIPTION="ReplayGain for WAVE audio files"
+HOMEPAGE="http://www.rarewares.org/files/others"
+SRC_URI="http://www.rarewares.org/files/others/${P}srcs.zip"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="media-libs/libsndfile"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S=${WORKDIR}/${P/wavegain/WaveGain}
+
+src_compile(){
+ $(tc-getCC) ${LDFLAGS} ${CFLAGS} *.c -o ${PN} \
+ -DHAVE_CONFIG_H -lm -lsndfile || die "build failed"
+}
+
+src_install(){
+ dobin ${PN} || die "dobin failed"
+}