summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn J. Ellis <jje@gentoo.org>2003-09-20 11:51:10 +0000
committerJohn J. Ellis <jje@gentoo.org>2003-09-20 11:51:10 +0000
commit01e428978789112eda11c2889e2d73612945d16f (patch)
treea020781d50c4863b05b555ffe2747e3c4a7bb73f /media-sound
parentAdded patch for 48khz files. Closes #28039. (diff)
downloadgentoo-2-01e428978789112eda11c2889e2d73612945d16f.tar.gz
gentoo-2-01e428978789112eda11c2889e2d73612945d16f.tar.bz2
gentoo-2-01e428978789112eda11c2889e2d73612945d16f.zip
Added patch for 48khz files. Closes #28039.
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/vorbisgain/ChangeLog10
-rw-r--r--media-sound/vorbisgain/Manifest6
-rw-r--r--media-sound/vorbisgain/files/digest-vorbisgain-0.32-r11
-rw-r--r--media-sound/vorbisgain/files/vorbisgain-0.32-48k.patch11
-rw-r--r--media-sound/vorbisgain/vorbisgain-0.32-r1.ebuild41
5 files changed, 65 insertions, 4 deletions
diff --git a/media-sound/vorbisgain/ChangeLog b/media-sound/vorbisgain/ChangeLog
index 1d549b650e46..ac8dc14259c5 100644
--- a/media-sound/vorbisgain/ChangeLog
+++ b/media-sound/vorbisgain/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for media-sound/vorbisgain
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/vorbisgain/ChangeLog,v 1.1 2003/03/02 07:05:28 jje Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/vorbisgain/ChangeLog,v 1.2 2003/09/20 11:51:06 jje Exp $
+
+*vorbisgain-0.32-r1 (20 Sep 2003)
+
+ 20 Sep 2003; jje <jje@gentoo.org> vorbisgain-0.32-r1.ebuild,
+ files/vorbisgain-0.32-48k.patch:
+ Added patch to fix 48khz files.
+
+ Submitted by: Sebastian Dröge <sebastian.droege@gmx.de>
*vorbisgain-0.32 (02 Mar 2003)
diff --git a/media-sound/vorbisgain/Manifest b/media-sound/vorbisgain/Manifest
index ff8f3ae16cc3..c4ce2a45f51c 100644
--- a/media-sound/vorbisgain/Manifest
+++ b/media-sound/vorbisgain/Manifest
@@ -1,6 +1,6 @@
MD5 48896561059b037c4f7179c89fafd49b vorbisgain-0.32.ebuild 984
-MD5 539317ea1b8b27e5afcc00093d7e6679 ChangeLog 373
-MD5 6000225eafd6d74de03f10606262f9b1 vorbisgain-0.32-r1.ebuild 1020
+MD5 fe2c4e971acb58667746dfe3a4300303 ChangeLog 603
+MD5 c732ec3d777a4717f43c382e7764cf8e vorbisgain-0.32-r1.ebuild 1050
MD5 51222418c1cb37080f305b280ce98bc9 files/digest-vorbisgain-0.32 64
-MD5 6309832f36831b1908999dea9e3b63cc files/vorbisgain-0.32-48k.patch 765
+MD5 3eeb609cc8129544b6bfbfe90d43de15 files/vorbisgain-0.32-48k.patch 740
MD5 51222418c1cb37080f305b280ce98bc9 files/digest-vorbisgain-0.32-r1 64
diff --git a/media-sound/vorbisgain/files/digest-vorbisgain-0.32-r1 b/media-sound/vorbisgain/files/digest-vorbisgain-0.32-r1
new file mode 100644
index 000000000000..aa06d9d0b856
--- /dev/null
+++ b/media-sound/vorbisgain/files/digest-vorbisgain-0.32-r1
@@ -0,0 +1 @@
+MD5 9bd34aff8540961ab2b2ef873caeabb1 vorbisgain-0.32.zip 140475
diff --git a/media-sound/vorbisgain/files/vorbisgain-0.32-48k.patch b/media-sound/vorbisgain/files/vorbisgain-0.32-48k.patch
new file mode 100644
index 000000000000..cbc83e46806e
--- /dev/null
+++ b/media-sound/vorbisgain/files/vorbisgain-0.32-48k.patch
@@ -0,0 +1,11 @@
+--- gain_analysis.c.orig 2003-09-20 20:46:06.000000000 +0900
++++ gain_analysis.c 2003-09-20 20:46:30.000000000 +0900
+@@ -108,7 +108,7 @@
+ #define MAX_dB 120. /* Table entries for 0...MAX_dB (normal max. values are 70...80 dB) */
+
+ #define MAX_ORDER (BUTTER_ORDER > YULE_ORDER ? BUTTER_ORDER : YULE_ORDER)
+-#define MAX_SAMPLES_PER_WINDOW (size_t) (MAX_SAMP_FREQ * RMS_WINDOW_TIME) /* max. Samples per Time slice */
++#define MAX_SAMPLES_PER_WINDOW (size_t) (MAX_SAMP_FREQ * RMS_WINDOW_TIME + 1) /* max. Samples per Time slice */
+ #define PINK_REF 64.82 /* 298640883795 */ /* calibration value */
+
+ Float_t linprebuf [MAX_ORDER * 2];
diff --git a/media-sound/vorbisgain/vorbisgain-0.32-r1.ebuild b/media-sound/vorbisgain/vorbisgain-0.32-r1.ebuild
new file mode 100644
index 000000000000..886d10e51c52
--- /dev/null
+++ b/media-sound/vorbisgain/vorbisgain-0.32-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/vorbisgain/vorbisgain-0.32-r1.ebuild,v 1.1 2003/09/20 11:51:06 jje Exp $
+
+DESCRIPTION="vorbisgain calculates a percieved sound level of an Ogg Vorbis file using the ReplayGain algorithm and stores it in the file header"
+HOMEPAGE="http://sjeng.sourceforge.net/ftp/vorbis/"
+SRC_URI="http://sjeng.sourceforge.net/ftp/vorbis/${P}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+KEYWORDS="~x86"
+
+DEPEND=">=media-libs/libvorbis-1.0_beta4
+ app-arch/unzip"
+
+S="${WORKDIR}/${P}"
+
+src_unpack() {
+ unpack ${P}.zip
+ cd ${S}
+
+ cp Makefile.am Makefile.am~
+ sed -e s\/"mandir = @MANDIR@"\/"mandir = @mandir@"/ Makefile.am~ > Makefile.am
+
+ cp Makefile.in Makefile.in~
+ sed -e s\/"mandir = @MANDIR@"\/"mandir = @mandir@"/ Makefile.in~ > Makefile.in
+
+ # patch to fix for 48khz files
+ epatch ${FILESDIR}/${P}-48k.patch
+}
+
+src_compile() {
+ econf || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+}
+