summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn J. Ellis <jje@gentoo.org>2003-05-17 07:19:06 +0000
committerJohn J. Ellis <jje@gentoo.org>2003-05-17 07:19:06 +0000
commit0439fa3ca5a8ebb03cf008f571fe00b3cb6dd3d6 (patch)
tree86873a39d0b36fe8255cc0f4b7c9f76ffdc33850 /media-sound
parentVersion bump and doc USE (~x86 masked) (diff)
downloadgentoo-2-0439fa3ca5a8ebb03cf008f571fe00b3cb6dd3d6.tar.gz
gentoo-2-0439fa3ca5a8ebb03cf008f571fe00b3cb6dd3d6.tar.bz2
gentoo-2-0439fa3ca5a8ebb03cf008f571fe00b3cb6dd3d6.zip
Version bump and doc USE (~x86 masked)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/lilypond/ChangeLog9
-rw-r--r--media-sound/lilypond/Manifest4
-rw-r--r--media-sound/lilypond/files/digest-lilypond-1.6.91
-rw-r--r--media-sound/lilypond/lilypond-1.6.9.ebuild88
4 files changed, 99 insertions, 3 deletions
diff --git a/media-sound/lilypond/ChangeLog b/media-sound/lilypond/ChangeLog
index 65f6cf1191d5..82d2c39b0206 100644
--- a/media-sound/lilypond/ChangeLog
+++ b/media-sound/lilypond/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-sound/lilypond
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/lilypond/ChangeLog,v 1.7 2003/03/09 19:50:01 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/lilypond/ChangeLog,v 1.8 2003/05/17 07:18:38 jje Exp $
+
+*lilypond-1.6.9 (17 May 2003)
+
+ 17 May 2003; jje <jje@gentoo.org> lilypond-1.6.9.ebuild:
+ Simplified src_compile to reflect current compiler usage.
+
+ The web-doc target is also being built.
18 Jan 2003; Aron Griffis <agriffis@gentoo.org> lilypond-1.6.6.ebuild :
Fix bug 13396 by requiring tetex-1.0.7-r12 which should fix the missing
diff --git a/media-sound/lilypond/Manifest b/media-sound/lilypond/Manifest
index 3f586be077f3..ea382225172b 100644
--- a/media-sound/lilypond/Manifest
+++ b/media-sound/lilypond/Manifest
@@ -1,6 +1,6 @@
-MD5 ea919e44e30c68c99cb19a93bc8f4d6c ChangeLog 1745
+MD5 0c3811483cbb9b12a7682fd105969388 ChangeLog 1740
MD5 3ff192bc173c8ccb0d20ac4bf9a41a53 lilypond-1.5.15.ebuild 778
-MD5 77426c96564993e8e9d2a8563b16e218 lilypond-1.6.9.ebuild 2764
+MD5 adcd55b2eafb4a3ac817c5f4231221f7 lilypond-1.6.9.ebuild 2866
MD5 e6eb2f63459d9809c9c749f2bd0cf56f lilypond-1.6.6.ebuild 3062
MD5 598b545eba349fc6f14f888818c1a8f7 files/digest-lilypond-1.5.15 68
MD5 42dc732527fc9a940a950f3a498a8b48 files/digest-lilypond-1.6.6 67
diff --git a/media-sound/lilypond/files/digest-lilypond-1.6.9 b/media-sound/lilypond/files/digest-lilypond-1.6.9
new file mode 100644
index 000000000000..703d01b451bc
--- /dev/null
+++ b/media-sound/lilypond/files/digest-lilypond-1.6.9
@@ -0,0 +1 @@
+MD5 94f1350455c62c4fd85926d019c8d10f lilypond-1.6.9.tar.gz 1599628
diff --git a/media-sound/lilypond/lilypond-1.6.9.ebuild b/media-sound/lilypond/lilypond-1.6.9.ebuild
new file mode 100644
index 000000000000..369ce085afc2
--- /dev/null
+++ b/media-sound/lilypond/lilypond-1.6.9.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/media-sound/lilypond/lilypond-1.6.9.ebuild,v 1.1 2003/05/17 07:18:38 jje Exp $
+
+IUSE="doc"
+
+inherit gcc
+
+MY_PV="v$(echo ${PV} | cut -d. -f1,2)"
+DESCRIPTION="GNU Music Typesetter"
+SRC_URI="http://www.lilypond.org/ftp/${MY_PV}/${P}.tar.gz"
+HOMEPAGE="http://lilypond.org/"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+
+DEPEND=">=dev-lang/python-2.2.1-r2
+ >=dev-lang/perl-5.6.1-r6
+ >=dev-util/guile-1.4-r3
+ >=sys-devel/bison-1.35
+ >=app-text/tetex-1.0.7-r12
+ >=sys-apps/texinfo-4.2-r5
+ >=sys-devel/flex-2.5.4a-r5
+ doc? ( >=app-text/mftrace-1.0.8
+ >=app-text/ghostscript-7.05.5
+ >=media-libs/netpbm-9.12-r2 )"
+
+RDEPEND=">=dev-util/guile-1.4-r3
+ >=app-text/ghostscript-7.05.5
+ >=app-text/tetex-1.0.7-r10
+ >=dev-lang/python-2.2.1-r2"
+
+src_compile() {
+ # See http://lilypond.org/stable/Documentation/topdocs/out-www/INSTALL.html
+ if [ "`gcc-major-version`" -eq "2" ]; then
+ # Verified by agriffis 03 Dec 2002 using
+ # gcc-2.95.3-r7 with flex-2.5.4a-r5
+ # (i.e. Gentoo 1.2)
+ ./configure --build=${CHOST} --prefix=/usr || die "configure failed"
+ emake || die "emake failed"
+ elif [ "`gcc-major-version`" -eq "3" -a "`gcc-minor-version`" -ge "2" ]; then
+ # Verified by agriffis 03 Dec 2002 using
+ # gcc-3.2.1 with flex-2.5.4a and flex-2.5.23
+ ./configure --build=${CHOST} --prefix=/usr || die "configure failed"
+ # Fix std::cerr problem in flex 2.5.4a and 2.5.23
+ make -C lily out/lexer.cc
+ perl -i -pe 's/\scerr\s/ std::cerr /g' lily/out/lexer.cc
+ emake || die "emake failed"
+ else
+ eerror "Unsupported GCC version, 2.95 and 3.2 are supported"
+ die
+ fi
+ use doc && (make prefix=${D}/usr \
+ datadir=${D}/usr/share \
+ lilypond_data=${D}/usr/share/lilypond \
+ local_lilypond_datadir=${D}/usr/share/lilypond/${PV} \
+ topdir=${D}/usr \
+ web-doc || "make web-doc failed")
+}
+
+src_install () {
+ make \
+ prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ datadir=${D}/usr/share \
+ lilypond_datadir=${D}/usr/share/lilypond \
+ local_lilypond_datadir=${D}/usr/share/lilypond/${PV} \
+ install || die "make install failed"
+ dodoc AUTHORS* COPYING ChangeLog DEDICATION NEWS README.txt \
+ ROADMAP THANKS VERSION *.el
+ insinto /usr/share/lilypond/${PV}/buildscripts/out
+ doins buildscripts/out/lilypond-profile \
+ buildscripts/out/lilypond-login \
+ buildscripts/out/clean-fonts
+ use doc && dohtml -A ly,pdf,gz -r Documentation *.html *.png
+}
+
+pkg_postinst () {
+ # Cleaning out old fonts is more appropriate in pkg_prerm, but we
+ # also need to clean up after any lilypond installations which may
+ # not have been installed via portage.
+ . /usr/share/lilypond/${PV}/buildscripts/out/clean-fonts
+}
+
+pkg_prerm () {
+ . /usr/share/lilypond/${PV}/buildscripts/out/clean-fonts
+}