summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-06-18 11:44:23 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-06-18 11:44:23 +0000
commit1101761f83bdb06947a5bc216394d6ca86cf81d9 (patch)
treec96ece0fe7007eb3417471c1daf5872198fa17b3 /media-sound
parentAdd new version with patchset to fix strict aliasing and make wx build withou... (diff)
downloadgentoo-2-1101761f83bdb06947a5bc216394d6ca86cf81d9.tar.gz
gentoo-2-1101761f83bdb06947a5bc216394d6ca86cf81d9.tar.bz2
gentoo-2-1101761f83bdb06947a5bc216394d6ca86cf81d9.zip
Add patch to fix strict-aliasing breakage.
(Portage version: 2.1.1_pre1)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/amarok/ChangeLog8
-rw-r--r--media-sound/amarok/amarok-1.4.0a-r1.ebuild84
-rw-r--r--media-sound/amarok/files/amarok-1.4.0a-strict-aliasing.patch14
-rw-r--r--media-sound/amarok/files/digest-amarok-1.4.0a-r13
4 files changed, 108 insertions, 1 deletions
diff --git a/media-sound/amarok/ChangeLog b/media-sound/amarok/ChangeLog
index b22545510c87..51c858a4b17b 100644
--- a/media-sound/amarok/ChangeLog
+++ b/media-sound/amarok/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/amarok
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/amarok/ChangeLog,v 1.141 2006/06/08 11:52:22 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/amarok/ChangeLog,v 1.142 2006/06/18 11:44:23 flameeyes Exp $
+
+*amarok-1.4.0a-r1 (18 Jun 2006)
+
+ 18 Jun 2006; Diego Pettenò <flameeyes@gentoo.org>
+ +files/amarok-1.4.0a-strict-aliasing.patch, +amarok-1.4.0a-r1.ebuild:
+ Add patch to fix strict-aliasing breakage.
08 Jun 2006; Diego Pettenò <flameeyes@gentoo.org> amarok-1.4.0a.ebuild:
Update description line for 1.4.0a ebuild as now it's Amarok rather than
diff --git a/media-sound/amarok/amarok-1.4.0a-r1.ebuild b/media-sound/amarok/amarok-1.4.0a-r1.ebuild
new file mode 100644
index 000000000000..b37d4af01b78
--- /dev/null
+++ b/media-sound/amarok/amarok-1.4.0a-r1.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/amarok/amarok-1.4.0a-r1.ebuild,v 1.1 2006/06/18 11:44:23 flameeyes Exp $
+
+LANGS="az bg br ca cs cy da de el en_GB es et fi fr ga gl he hi hu is it ja km
+ko lt nb nl nn pa pl pt pt_BR ro ru rw sl sr sr@Latn sv ta tg th tr uk uz
+zh_CN zh_TW"
+LANGS_DOC="da de es et fr it nl pl pt pt_BR ru sv"
+
+USE_KEG_PACKAGING=1
+
+inherit kde eutils flag-o-matic
+
+PKG_SUFFIX=""
+
+MY_PV="${PV/_rc/_RC}"
+MY_PV="${MY_PV/_beta/-beta}${PKG_SUFFIX}"
+MY_S="${PN}-${MY_PV/_RC*/}"
+S="${WORKDIR}/${MY_S/0a/0}"
+
+DESCRIPTION="Advanced audio player based on KDE framework."
+HOMEPAGE="http://amarok.kde.org/"
+
+if [[ ${MY_PV} == ${MY_PV/_RC*/} ]]; then
+ SRC_URI="mirror://sourceforge/amarok/${PN}-${MY_PV}.tar.bz2"
+else
+ RESTRICT="nomirror"
+ SRC_URI="http://rokymotion.pwsp.net/nightly-builds/${MY_PV/_RC*/}/${PN}-${MY_PV}.tar.bz2"
+fi
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="aac exscalibar flac kde mysql noamazon opengl postgres
+xmms visualization musicbrainz ipod ifp real"
+# kde: enables compilation of the konqueror sidebar plugin
+
+DEPEND="kde? ( || ( kde-base/konqueror kde-base/kdebase ) )
+ >=media-libs/xine-lib-1_rc4
+ musicbrainz? ( >=media-libs/tunepimp-0.3 )
+ >=media-libs/taglib-1.4
+ mysql? ( >=dev-db/mysql-4.0.16 )
+ postgres? ( dev-db/postgresql )
+ opengl? ( virtual/opengl )
+ xmms? ( >=media-sound/xmms-1.2 )
+ visualization? ( media-libs/libsdl
+ =media-plugins/libvisual-plugins-0.2* )
+ ipod? ( media-libs/libgpod )
+ aac? ( media-libs/libmp4v2 )
+ exscalibar? ( media-libs/exscalibar )
+ ifp? ( media-libs/libifp )
+ real? ( media-video/realplayer )"
+
+RDEPEND="${DEPEND}
+ dev-lang/ruby"
+
+DEPEND="${DEPEND}
+ >=dev-util/pkgconfig-0.9.0"
+
+need-kde 3.3
+
+PATCHES="${FILESDIR}/${P}-strict-aliasing.patch"
+
+src_compile() {
+ append-flags -fno-inline
+
+ # Extra, unsupported engines are forcefully disabled.
+ local myconf="$(use_enable mysql) $(use_enable postgres postgresql)
+ $(use_with opengl) $(use_with xmms)
+ $(use_with visualization libvisual)
+ $(use_enable !noamazon amazon)
+ $(use_with musicbrainz)
+ $(use_with exscalibar)
+ $(use_with ipod libgpod)
+ $(use_with aac mp4v2)
+ $(use_with ifp)
+ $(use_with real helix)
+ --with-xine
+ --without-mas
+ --without-nmm"
+
+ kde_src_compile
+}
+
diff --git a/media-sound/amarok/files/amarok-1.4.0a-strict-aliasing.patch b/media-sound/amarok/files/amarok-1.4.0a-strict-aliasing.patch
new file mode 100644
index 000000000000..3a39ba957694
--- /dev/null
+++ b/media-sound/amarok/files/amarok-1.4.0a-strict-aliasing.patch
@@ -0,0 +1,14 @@
+Index: amarok-1.4.0/amarok/src/sqlite/Makefile.am
+===================================================================
+--- amarok-1.4.0.orig/amarok/src/sqlite/Makefile.am
++++ amarok-1.4.0/amarok/src/sqlite/Makefile.am
+@@ -7,7 +7,8 @@ KDE_CFLAGS = \
+ libsqlite_la_CFLAGS = \
+ $(all_includes) \
+ -DTHREADSAFE=1 \
+- -DHAVE_USLEEP=1
++ -DHAVE_USLEEP=1 \
++ -fno-strict-aliasing
+
+ libsqlite_la_LDFLAGS = \
+ $(LIBPTHREAD)
diff --git a/media-sound/amarok/files/digest-amarok-1.4.0a-r1 b/media-sound/amarok/files/digest-amarok-1.4.0a-r1
new file mode 100644
index 000000000000..c5817c537dba
--- /dev/null
+++ b/media-sound/amarok/files/digest-amarok-1.4.0a-r1
@@ -0,0 +1,3 @@
+MD5 3ceffe6465290eef618861cdb81b420a amarok-1.4.0a.tar.bz2 13045009
+RMD160 47ae8f9e23aec02f825fe3791eae63520f56394e amarok-1.4.0a.tar.bz2 13045009
+SHA256 46d298226ff855c68b1d179d900441fd3c2329f42a938c3fc842a218ab762344 amarok-1.4.0a.tar.bz2 13045009