summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarijn Schouten <hkbst@gentoo.org>2007-02-14 17:23:52 +0000
committerMarijn Schouten <hkbst@gentoo.org>2007-02-14 17:23:52 +0000
commit133ec7d3d6dc0b31a0bb2bdfcc485a9927d00587 (patch)
tree4a9a77f37a384a3e7784ce888b0ddb1fadb3ab1b /media-sound
parentCleanup, bug #166707 (diff)
downloadgentoo-2-133ec7d3d6dc0b31a0bb2bdfcc485a9927d00587.tar.gz
gentoo-2-133ec7d3d6dc0b31a0bb2bdfcc485a9927d00587.tar.bz2
gentoo-2-133ec7d3d6dc0b31a0bb2bdfcc485a9927d00587.zip
change identifiers with ? to use "is_"
(Portage version: 2.1.2-r9)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/cm/ChangeLog5
-rw-r--r--media-sound/cm/cm-2.10.0.ebuild10
2 files changed, 9 insertions, 6 deletions
diff --git a/media-sound/cm/ChangeLog b/media-sound/cm/ChangeLog
index a9d30555cd2f..2bd93348f91f 100644
--- a/media-sound/cm/ChangeLog
+++ b/media-sound/cm/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for media-sound/cm
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/cm/ChangeLog,v 1.14 2007/02/14 11:29:23 hkbst Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/cm/ChangeLog,v 1.15 2007/02/14 17:23:52 hkbst Exp $
+
+ 14 Feb 2007; Marijn Schouten <hkBst@gentoo.org> cm-2.10.0.ebuild:
+ change identifiers with ? to use "is_"
14 Feb 2007; Marijn Schouten <hkBst@gentoo.org> files/71cm-gentoo.el:
put comment in sitefile
diff --git a/media-sound/cm/cm-2.10.0.ebuild b/media-sound/cm/cm-2.10.0.ebuild
index 4e8173f1b5cf..a1b35383da8a 100644
--- a/media-sound/cm/cm-2.10.0.ebuild
+++ b/media-sound/cm/cm-2.10.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/cm/cm-2.10.0.ebuild,v 1.2 2007/02/13 12:07:26 hkbst Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/cm/cm-2.10.0.ebuild,v 1.3 2007/02/14 17:23:52 hkbst Exp $
inherit elisp-common
@@ -48,7 +48,7 @@ implementation() {
echo ${impl}
}
-lisp?() {
+is_lisp() {
local impl="$(implementation)"
# echo ${impl}
if [[ ${impl} == "guile" || ${impl} == "gauche" ]]; then
@@ -57,7 +57,7 @@ lisp?() {
return $(true)
}
-compiler?() {
+is_compiler() {
local impl="$(implementation)"
# echo ${impl}
if [[ -z $(echo ${COMPILERS} | grep -i ${impl}) ]]; then
@@ -69,9 +69,9 @@ compiler?() {
src_compile() {
use emacs && elisp-comp etc/xemacs/*.el
- einfo "Detected $(compiler? && echo "compiler" || echo "interpreter"): $(implementation)"
+ einfo "Detected $(is_compiler && echo "compiler" || echo "interpreter"): $(implementation)"
- if compiler?; then
+ if is_compiler; then
einfo "Byte-compiling code and generating Lisp code"
echo '(quit)' | eval ${CM}
echo -e "\n"