summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2015-01-03 14:46:28 +0000
committerMichał Górny <mgorny@gentoo.org>2015-01-03 14:46:28 +0000
commit1c49a1e7d98ed0c6ba320ec4a5714d85d89824ef (patch)
tree97e8d6f773bbf00268a810d8c4366213e9aa0b03 /media-sound
parentEAPI 4 (diff)
downloadgentoo-2-1c49a1e7d98ed0c6ba320ec4a5714d85d89824ef.tar.gz
gentoo-2-1c49a1e7d98ed0c6ba320ec4a5714d85d89824ef.tar.bz2
gentoo-2-1c49a1e7d98ed0c6ba320ec4a5714d85d89824ef.zip
Convert to python-single-r1.
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/a2jmidid/ChangeLog9
-rw-r--r--media-sound/a2jmidid/a2jmidid-8-r1.ebuild41
2 files changed, 48 insertions, 2 deletions
diff --git a/media-sound/a2jmidid/ChangeLog b/media-sound/a2jmidid/ChangeLog
index 27f6fb0f9839..4c345e487dd6 100644
--- a/media-sound/a2jmidid/ChangeLog
+++ b/media-sound/a2jmidid/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/a2jmidid
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/a2jmidid/ChangeLog,v 1.12 2014/08/10 21:03:04 slyfox Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/a2jmidid/ChangeLog,v 1.13 2015/01/03 14:46:28 mgorny Exp $
+
+*a2jmidid-8-r1 (03 Jan 2015)
+
+ 03 Jan 2015; Michał Górny <mgorny@gentoo.org> +a2jmidid-8-r1.ebuild:
+ Convert to python-single-r1.
10 Aug 2014; Sergei Trofimovich <slyfox@gentoo.org> a2jmidid-8.ebuild:
QA: drop trailing '.' from DESCRIPTION
diff --git a/media-sound/a2jmidid/a2jmidid-8-r1.ebuild b/media-sound/a2jmidid/a2jmidid-8-r1.ebuild
new file mode 100644
index 000000000000..93c83c9a6ae6
--- /dev/null
+++ b/media-sound/a2jmidid/a2jmidid-8-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/a2jmidid/a2jmidid-8-r1.ebuild,v 1.1 2015/01/03 14:46:28 mgorny Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE='threads(+)'
+NO_WAF_LIBDIR=1
+
+inherit python-single-r1 toolchain-funcs waf-utils
+
+DESCRIPTION="Daemon for exposing legacy ALSA sequencer applications in JACK MIDI system"
+HOMEPAGE="http://home.gna.org/a2jmidid/"
+SRC_URI="http://download.gna.org/a2jmidid/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="dbus"
+
+RDEPEND="media-libs/alsa-lib
+ media-sound/jack-audio-connection-kit
+ dbus? ( sys-apps/dbus )
+ ${PYTHON_DEPS}"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS=(AUTHORS README NEWS internals.txt)
+
+src_configure() {
+ if use dbus ; then
+ waf-utils_src_configure
+ else
+ waf-utils_src_configure --disable-dbus
+ fi
+}
+
+src_install() {
+ waf-utils_src_install
+ python_fix_shebang "${ED}"
+}