summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2007-06-20 14:29:15 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2007-06-20 14:29:15 +0000
commit1cb5a7edab3fd8f86d4fe01f34d1c3c494537d77 (patch)
treec811556c545adbb7712cab3b6a6fa2d53ee9db04 /media-sound
parentRe-add cjk USE flag, thanks to Hannes Wyss, bug #182671 (diff)
downloadgentoo-2-1cb5a7edab3fd8f86d4fe01f34d1c3c494537d77.tar.gz
gentoo-2-1cb5a7edab3fd8f86d4fe01f34d1c3c494537d77.tar.bz2
gentoo-2-1cb5a7edab3fd8f86d4fe01f34d1c3c494537d77.zip
Add patch from bug #154932 reworked a bit, and remove static useflag. Thanks to Alessio Cassiba. Change version to the actual upstream version rather than using a -r1.
(Portage version: 2.1.3_rc4)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/fluidsynth/ChangeLog10
-rw-r--r--media-sound/fluidsynth/files/digest-fluidsynth-1.0.7a3
-rw-r--r--media-sound/fluidsynth/fluidsynth-1.0.7a.ebuild68
3 files changed, 80 insertions, 1 deletions
diff --git a/media-sound/fluidsynth/ChangeLog b/media-sound/fluidsynth/ChangeLog
index ba2290f36d12..7797c7bd9ccc 100644
--- a/media-sound/fluidsynth/ChangeLog
+++ b/media-sound/fluidsynth/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for media-sound/fluidsynth
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/fluidsynth/ChangeLog,v 1.29 2007/02/22 00:58:25 peper Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/fluidsynth/ChangeLog,v 1.30 2007/06/20 14:29:15 flameeyes Exp $
+
+*fluidsynth-1.0.7a (20 Jun 2007)
+
+ 20 Jun 2007; Diego Pettenò <flameeyes@gentoo.org>
+ +fluidsynth-1.0.7a.ebuild:
+ Add patch from bug #154932 reworked a bit, and remove static useflag. Thanks
+ to Alessio Cassiba. Change version to the actual upstream version rather
+ than using a -r1.
22 Feb 2007; Piotr Jaroszyński <peper@gentoo.org> ChangeLog:
Transition to Manifest2.
diff --git a/media-sound/fluidsynth/files/digest-fluidsynth-1.0.7a b/media-sound/fluidsynth/files/digest-fluidsynth-1.0.7a
new file mode 100644
index 000000000000..91cf96969d23
--- /dev/null
+++ b/media-sound/fluidsynth/files/digest-fluidsynth-1.0.7a
@@ -0,0 +1,3 @@
+MD5 0f73d47990d859f19b8e9840bdab5c60 fluidsynth-1.0.7a.tar.gz 1064677
+RMD160 c4d31711443c0dad42937a38a0360d114525d076 fluidsynth-1.0.7a.tar.gz 1064677
+SHA256 337dcc5f0f337c37ee7979c9505589b3a84e6b1e245d31b637ad32996b6e113b fluidsynth-1.0.7a.tar.gz 1064677
diff --git a/media-sound/fluidsynth/fluidsynth-1.0.7a.ebuild b/media-sound/fluidsynth/fluidsynth-1.0.7a.ebuild
new file mode 100644
index 000000000000..cfc319d73f4b
--- /dev/null
+++ b/media-sound/fluidsynth/fluidsynth-1.0.7a.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/fluidsynth/fluidsynth-1.0.7a.ebuild,v 1.1 2007/06/20 14:29:15 flameeyes Exp $
+
+inherit flag-o-matic eutils libtool
+
+IUSE="alsa debug jack ladspa lash oss"
+
+DESCRIPTION="Fluidsynth is a software real-time synthesizer based on the Soundfont 2 specifications."
+HOMEPAGE="http://www.fluidsynth.org/"
+SRC_URI="http://savannah.nongnu.org/download/fluid/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~x86-fbsd"
+
+DEPEND="jack? ( media-sound/jack-audio-connection-kit )
+ ladspa? ( >=media-libs/ladspa-sdk-1.12
+ >=media-libs/ladspa-cmt-1.15 )
+ alsa? ( media-libs/alsa-lib
+ lash? ( >=media-sound/lash-0.5 ) )"
+
+S="${WORKDIR}/${P/7a/7}"
+
+# Alsa is required for lash support in this package.
+pkg_setup() {
+ if use lash && ! use alsa; then
+ ewarn "ALSA support is required for lash support to be enabled."
+ ewarn "Continuing with lash support disabled."
+ fi
+
+ if use alsa && ! built_with_use --missing true media-libs/alsa-lib midi; then
+ eerror ""
+ eerror "To be able to build Fluidsynth with ALSA support you need"
+ eerror "to have built media-libs/alsa-lib with midi USE flag."
+ die "Missing midi USE flag on media-libs/alsa-lib"
+ fi
+}
+
+src_compile() {
+ local myconf
+
+ if use alsa; then
+ myconf="${myconf} $(use_enable lash)"
+ else
+ myconf="--disable-lash"
+ fi
+
+ elibtoolize
+ # ladcca support is deprecated in place of lash
+ econf \
+ --disable-ladcca \
+ --disable-dependency-tracking \
+ $(use_enable ladspa) \
+ $(use_enable jack jack-support) \
+ $(use_enable oss oss-support) \
+ $(use_enable alsa alsa-support) \
+ $(use_enable lash) \
+ $(use_enable debug) \
+ ${myconf} || die "./configure failed"
+
+ emake || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc AUTHORS NEWS README THANKS TODO
+}