summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2007-03-26 21:40:54 +0000
committerAlexis Ballier <aballier@gentoo.org>2007-03-26 21:40:54 +0000
commit1eb03618107a882003b3023951d2a9acffba6e69 (patch)
treecfe2b6208996c1fb08b971547b58d69a313abe77 /media-sound
parentia64 stable wrt bug 166574 (diff)
downloadgentoo-2-1eb03618107a882003b3023951d2a9acffba6e69.tar.gz
gentoo-2-1eb03618107a882003b3023951d2a9acffba6e69.tar.bz2
gentoo-2-1eb03618107a882003b3023951d2a9acffba6e69.zip
Dont test if files are installed as they are not at the time we run src_test
(Portage version: 2.1.2.2)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/beast/ChangeLog6
-rw-r--r--media-sound/beast/beast-0.7.1.ebuild9
-rw-r--r--media-sound/beast/files/beast-0.7.1-noinstalltest.patch16
3 files changed, 28 insertions, 3 deletions
diff --git a/media-sound/beast/ChangeLog b/media-sound/beast/ChangeLog
index ec959c9cc4da..021715b85d0f 100644
--- a/media-sound/beast/ChangeLog
+++ b/media-sound/beast/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-sound/beast
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/beast/ChangeLog,v 1.25 2007/03/25 12:19:37 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/beast/ChangeLog,v 1.26 2007/03/26 21:40:53 aballier Exp $
+
+ 26 Mar 2007; Alexis Ballier <aballier@gentoo.org>
+ +files/beast-0.7.1-noinstalltest.patch, beast-0.7.1.ebuild:
+ Dont test if files are installed as they are not at the time we run src_test
25 Mar 2007; Alexis Ballier <aballier@gentoo.org> beast-0.7.1.ebuild:
Upstream fix to build with guile 1.8
diff --git a/media-sound/beast/beast-0.7.1.ebuild b/media-sound/beast/beast-0.7.1.ebuild
index b17bd08e8e99..aefbcb71f15d 100644
--- a/media-sound/beast/beast-0.7.1.ebuild
+++ b/media-sound/beast/beast-0.7.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/beast/beast-0.7.1.ebuild,v 1.2 2007/03/25 12:19:37 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/beast/beast-0.7.1.ebuild,v 1.3 2007/03/26 21:40:53 aballier Exp $
inherit eutils flag-o-matic fdo-mime
@@ -43,6 +43,7 @@ src_unpack() {
cd "${S}"
epatch "${WORKDIR}/${P}-guile-1.8.diff"
+ epatch "${FILESDIR}/${P}-noinstalltest.patch"
}
src_compile() {
@@ -59,7 +60,11 @@ src_compile() {
src_install() {
emake DESTDIR="${D}" install || die "make install failed"
# dont install new mime files !
- rm -f "${D}/usr/share/mime/"*
+ for i in subclasses XMLnamespaces aliases globs magic mime.cache\
+ audio/x-bsewave.xml audio/x-bse.xml; do
+ rm -f "${D}/usr/share/mime/${i}"
+ done
+
dodoc AUTHORS ChangeLog NEWS README TODO
}
diff --git a/media-sound/beast/files/beast-0.7.1-noinstalltest.patch b/media-sound/beast/files/beast-0.7.1-noinstalltest.patch
new file mode 100644
index 000000000000..7c0f65267dd6
--- /dev/null
+++ b/media-sound/beast/files/beast-0.7.1-noinstalltest.patch
@@ -0,0 +1,16 @@
+Index: beast-0.7.1/shell/Makefile.in
+===================================================================
+--- beast-0.7.1.orig/shell/Makefile.in
++++ beast-0.7.1/shell/Makefile.in
+@@ -859,10 +859,7 @@ check-before: check-installation
+ check-installation:
+ @for p in $(bin_PROGRAMS) ; do \
+ pp="$(DESTDIR)$(bindir)/$$p" ; \
+- echo "TEST: test -x \"$$pp\"" ; \
+- test -x "$$pp" || \
+- { echo "Failed to verify installation of executable: $$pp"; \
+- exit 1 ; } \
++ echo "TEST: test -x \"$$pp\" Test disabled" ; \
+ done
+ # Tell versions [3.59,3.63) of GNU make to not export all variables.
+ # Otherwise a system limit (for SysV at least) may be exceeded.