summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArcady Genkin <agenkin@gentoo.org>2003-03-23 22:55:41 +0000
committerArcady Genkin <agenkin@gentoo.org>2003-03-23 22:55:41 +0000
commit21718c5726098f228f747b0c2aa8448a841db68a (patch)
tree2d537de6ceac5cfc545c72edd640d61b0e4505b4 /media-sound
parentmoved net-wireless/gkrellmwireless to x11-plugins/gkrellmwireless (diff)
downloadgentoo-2-21718c5726098f228f747b0c2aa8448a841db68a.tar.gz
gentoo-2-21718c5726098f228f747b0c2aa8448a841db68a.tar.bz2
gentoo-2-21718c5726098f228f747b0c2aa8448a841db68a.zip
Update to 0.9.2.
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/alsa-driver/ChangeLog7
-rw-r--r--media-sound/alsa-driver/alsa-driver-0.9.2.ebuild93
-rw-r--r--media-sound/alsa-driver/files/digest-alsa-driver-0.9.21
-rw-r--r--media-sound/alsa-utils/ChangeLog7
-rw-r--r--media-sound/alsa-utils/alsa-utils-0.9.2.ebuild32
-rw-r--r--media-sound/alsa-utils/files/digest-alsa-utils-0.9.21
6 files changed, 139 insertions, 2 deletions
diff --git a/media-sound/alsa-driver/ChangeLog b/media-sound/alsa-driver/ChangeLog
index b37fb2f6b802..2a07710ad89d 100644
--- a/media-sound/alsa-driver/ChangeLog
+++ b/media-sound/alsa-driver/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/alsa-driver
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-driver/ChangeLog,v 1.30 2003/03/12 19:16:33 agenkin Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-driver/ChangeLog,v 1.31 2003/03/23 22:54:23 agenkin Exp $
+
+*alsa-driver-0.9.2 (27 Mar 2003)
+
+ 27 Mar 2003; Arcady Genkin <agenkin@gentoo.org> :
+ Version update.
*alsa-driver-0.9.1 (12 Mar 2003)
diff --git a/media-sound/alsa-driver/alsa-driver-0.9.2.ebuild b/media-sound/alsa-driver/alsa-driver-0.9.2.ebuild
new file mode 100644
index 000000000000..9c79df01fa4f
--- /dev/null
+++ b/media-sound/alsa-driver/alsa-driver-0.9.2.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-driver/alsa-driver-0.9.2.ebuild,v 1.1 2003/03/23 22:54:23 agenkin Exp $
+
+DESCRIPTION="Advanced Linux Sound Architecture kernel modules"
+HOMEPAGE="http://www.alsa-project.org/"
+LICENSE="GPL-2 LGPL-2.1"
+
+# By default, drivers for all supported cards will be compiled.
+# If you want to only compile for specific card(s), set ALSA_CARDS
+# environment to a space-separated list of drivers that you want to build.
+# For example:
+#
+# env ALSA_CARDS='emu10k1 intel8x0 ens1370' emerge alsa-driver
+#
+[ x"${ALSA_CARDS}" = x ] && ALSA_CARDS=all
+
+# Need the baselayout 1.7.9 or newer for the init script to work correctly.
+DEPEND="sys-devel/autoconf
+ virtual/glibc
+ >=sys-apps/portage-1.9.10
+ >=sys-apps/baselayout-1.7.9"
+PROVIDE="virtual/alsa"
+
+SLOT="0.9"
+KEYWORDS="~x86 ~ppc"
+
+SRC_URI="ftp://ftp.alsa-project.org/pub/driver/${P}.tar.bz2"
+S=${WORKDIR}/${P}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ # Some *broken* Gentoo packages install stuff in /etc/rc.d/init.d
+ # instead of /etc/init.d. However, this causes alsa's installer
+ # to do the same foolish thing. This *hack* inibits the problem.
+ # I filed a bug report about this with the ALSA people:
+ # http://sourceforge.net/tracker/?func=detail&aid=551668&group_id=27464&atid=390601
+ # Arcady Genkin <agenkin@thpoon.com>
+ sed -e 's:/etc/rc.d/init.d:/etc/init.d:' < Makefile > Makefile.hacked
+ mv Makefile.hacked Makefile
+
+}
+
+
+src_compile() {
+ # Portage should determine the version of the kernel sources
+ check_KV
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --with-kernel="${ROOT}usr/src/linux" \
+ --with-isapnp=yes \
+ --with-sequencer=yes \
+ --with-oss=yes \
+ --with-cards="${ALSA_CARDS}" \
+ || die "./configure failed"
+
+ make || die "Parallel Make Failed"
+}
+
+
+src_install() {
+ dodir /usr/include/sound
+ dodir /etc/init.d
+ make DESTDIR=${D} install || die
+
+ dodoc CARDS-STATUS COPYING FAQ INSTALL README WARNING TODO doc/*
+
+ insinto /etc/modules.d
+ newins ${FILESDIR}/alsa-modules.conf-rc alsa
+ exeinto /etc/init.d
+ doexe ${FILESDIR}/alsasound
+}
+
+pkg_postinst() {
+ if [ "${ROOT}" = / ]
+ then
+ [ -x /usr/sbin/update-modules ] && /usr/sbin/update-modules
+ fi
+
+ einfo
+ einfo "You need to edit file /etc/modules.d/alsa according to your"
+ einfo "hardware configuration."
+ einfo
+ einfo "If you are going to be using the 'alsasound' init script, make sure"
+ einfo "that you add it to the 'boot' runlevel (not 'default')."
+ einfo
+ einfo "Also, remember that all mixer channels will be MUTED by default."
+ einfo "Use 'alsamixer' program to unmute them."
+ einfo
+}
+
diff --git a/media-sound/alsa-driver/files/digest-alsa-driver-0.9.2 b/media-sound/alsa-driver/files/digest-alsa-driver-0.9.2
new file mode 100644
index 000000000000..43b7a3b79896
--- /dev/null
+++ b/media-sound/alsa-driver/files/digest-alsa-driver-0.9.2
@@ -0,0 +1 @@
+MD5 946d1751f585f29192aed73df496c915 alsa-driver-0.9.2.tar.bz2 1635057
diff --git a/media-sound/alsa-utils/ChangeLog b/media-sound/alsa-utils/ChangeLog
index 62385a8610cb..2ea6a5c3dc7a 100644
--- a/media-sound/alsa-utils/ChangeLog
+++ b/media-sound/alsa-utils/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/alsa-utils
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-utils/ChangeLog,v 1.18 2003/03/12 19:27:16 agenkin Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-utils/ChangeLog,v 1.19 2003/03/23 22:55:41 agenkin Exp $
+
+*alsa-utils-0.9.2 (27 Mar 2003)
+
+ 27 Mar 2003; Arcady Genkin <agenkin@gentoo.org> :
+ Version update.
*alsa-utils-0.9.1 (12 Mar 2003)
diff --git a/media-sound/alsa-utils/alsa-utils-0.9.2.ebuild b/media-sound/alsa-utils/alsa-utils-0.9.2.ebuild
new file mode 100644
index 000000000000..942ca50268af
--- /dev/null
+++ b/media-sound/alsa-utils/alsa-utils-0.9.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-utils/alsa-utils-0.9.2.ebuild,v 1.1 2003/03/23 22:55:41 agenkin Exp $
+
+DESCRIPTION="Advanced Linux Sound Architecture Utils (alsactl, alsamixer, etc.)"
+HOMEPAGE="http://www.alsa-project.org/"
+DEPEND=">=sys-libs/ncurses-5.1
+ >=media-libs/alsa-lib-0.9.1"
+
+SLOT="0.9"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc"
+
+SRC_URI="ftp://ftp.alsa-project.org/pub/utils/${P}.tar.bz2"
+S=${WORKDIR}/${P}
+
+src_compile() {
+
+ econf || die "./configure failed"
+ emake || die "Parallel Make Failed"
+}
+
+src_install() {
+ local ALSA_UTILS_DOCS="COPYING ChangeLog README TODO
+ seq/aconnect/README.aconnect
+ seq/aseqnet/README.aseqnet"
+
+ make DESTDIR=${D} install || die "Installation Failed"
+
+ dodoc ${ALSA_UTILS_DOCS}
+ newdoc alsamixer/README README.alsamixer
+}
diff --git a/media-sound/alsa-utils/files/digest-alsa-utils-0.9.2 b/media-sound/alsa-utils/files/digest-alsa-utils-0.9.2
new file mode 100644
index 000000000000..7fd5ee79f8bb
--- /dev/null
+++ b/media-sound/alsa-utils/files/digest-alsa-utils-0.9.2
@@ -0,0 +1 @@
+MD5 0a820bc2d2cf0abb1970c04b99de4e10 alsa-utils-0.9.2.tar.bz2 107558