summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <drac@gentoo.org>2007-07-14 18:39:11 +0000
committerSamuli Suominen <drac@gentoo.org>2007-07-14 18:39:11 +0000
commit2e262480f7f3cc39643bea08a07496e40ae7775d (patch)
treeb8f40f1ecfbaed34149b1d9ed76f0f2f2213c504 /media-sound
parentalpha/x86 stable (diff)
downloadgentoo-2-2e262480f7f3cc39643bea08a07496e40ae7775d.tar.gz
gentoo-2-2e262480f7f3cc39643bea08a07496e40ae7775d.tar.bz2
gentoo-2-2e262480f7f3cc39643bea08a07496e40ae7775d.zip
Fix building with >=flac-1.1.3 on AMD64 systems for bug 181822, thanks to Dominique Michel for patch and aballier at gentoo.org for reporting.
(Portage version: 2.1.3_rc8)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/alsaplayer/ChangeLog8
-rw-r--r--media-sound/alsaplayer/alsaplayer-0.99.80_rc1.ebuild11
-rw-r--r--media-sound/alsaplayer/files/alsaplayer-0.99.80_rc1-amd64-flac-1.1.3.patch62
3 files changed, 73 insertions, 8 deletions
diff --git a/media-sound/alsaplayer/ChangeLog b/media-sound/alsaplayer/ChangeLog
index 0ac9b695c350..593622278d42 100644
--- a/media-sound/alsaplayer/ChangeLog
+++ b/media-sound/alsaplayer/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/alsaplayer
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/alsaplayer/ChangeLog,v 1.61 2007/06/17 02:47:01 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsaplayer/ChangeLog,v 1.62 2007/07/14 18:39:11 drac Exp $
+
+ 14 Jul 2007; Samuli Suominen <drac@gentoo.org>
+ +files/alsaplayer-0.99.80_rc1-amd64-flac-1.1.3.patch,
+ alsaplayer-0.99.80_rc1.ebuild:
+ Fix building with >=flac-1.1.3 on AMD64 systems for bug 181822, thanks to
+ Dominique Michel for patch and aballier at gentoo.org for reporting.
17 Jun 2007; Ryan Hill <dirtyepic@gentoo.org> metadata.xml:
Update metadata.
diff --git a/media-sound/alsaplayer/alsaplayer-0.99.80_rc1.ebuild b/media-sound/alsaplayer/alsaplayer-0.99.80_rc1.ebuild
index 9379be847931..b9eac4963b49 100644
--- a/media-sound/alsaplayer/alsaplayer-0.99.80_rc1.ebuild
+++ b/media-sound/alsaplayer/alsaplayer-0.99.80_rc1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/alsaplayer/alsaplayer-0.99.80_rc1.ebuild,v 1.2 2007/06/16 08:42:08 drac Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsaplayer/alsaplayer-0.99.80_rc1.ebuild,v 1.3 2007/07/14 18:39:11 drac Exp $
inherit eutils autotools versionator
@@ -15,13 +15,12 @@ SLOT="0"
KEYWORDS="~amd64 ~mips ~ppc ~sparc ~x86"
IUSE="alsa audiofile doc esd flac gtk jack mikmod nas ogg opengl oss vorbis xosd"
-RDEPEND="
- media-libs/alsa-lib
+RDEPEND="media-libs/alsa-lib
media-libs/libsndfile
media-libs/libmad
audiofile? ( media-libs/audiofile )
esd? ( media-sound/esound )
- flac? ( media-libs/flac )
+ flac? ( >=media-libs/flac-1.1.3 )
jack? ( >=media-sound/jack-audio-connection-kit-0.80.0 )
mikmod? ( >=media-libs/libmikmod-3.1.10 )
nas? ( media-libs/nas )
@@ -29,7 +28,6 @@ RDEPEND="
opengl? ( virtual/opengl )
vorbis? ( media-libs/libvorbis )
xosd? ( x11-libs/xosd )"
-
DEPEND="${RDEPEND}
>=dev-libs/glib-2.10.1
dev-util/pkgconfig
@@ -42,9 +40,8 @@ S="${WORKDIR}"/${PN}-${MY_PV}
src_unpack() {
unpack ${A}
cd "${S}"
-
epatch "${FILESDIR}"/${PN}-0.99.77-cxxflags.patch
-
+ epatch "${FILESDIR}"/${P}-amd64-flac-1.1.3.patch
eautoreconf
}
diff --git a/media-sound/alsaplayer/files/alsaplayer-0.99.80_rc1-amd64-flac-1.1.3.patch b/media-sound/alsaplayer/files/alsaplayer-0.99.80_rc1-amd64-flac-1.1.3.patch
new file mode 100644
index 000000000000..27e842e19e68
--- /dev/null
+++ b/media-sound/alsaplayer/files/alsaplayer-0.99.80_rc1-amd64-flac-1.1.3.patch
@@ -0,0 +1,62 @@
+--- input/flac/FlacStream.h-dist 2007-04-25 14:44:52.000000000 +0200
++++ input/flac/FlacStream.h 2007-04-25 14:45:11.000000000 +0200
+@@ -191,7 +191,7 @@ class FlacStream
+
+ FLAC__StreamDecoderReadStatus
+ realReadCallBack (FLAC__byte buffer[],
+- unsigned * bytes);
++ size_t * bytes);
+
+
+ protected:
+@@ -233,7 +233,7 @@ class FlacStream
+ static FLAC__StreamDecoderReadStatus
+ readCallBack (const FLAC__StreamDecoder * decoder,
+ FLAC__byte buffer[],
+- unsigned * bytes,
++ size_t * bytes,
+ void * client_data);
+
+ static void errCallBack (const FLAC__StreamDecoder * decoder,
+--- input/flac/FlacStream.cpp-dist 2007-04-25 14:44:10.000000000 +0200
++++ input/flac/FlacStream.cpp 2007-04-25 14:44:49.000000000 +0200
+@@ -321,7 +321,7 @@
+
+
+ FLAC__StreamDecoderReadStatus
+-FlacStream::realReadCallBack (FLAC__byte buffer[], unsigned * bytes)
++FlacStream::realReadCallBack (FLAC__byte buffer[], size_t * bytes)
+ {
+ *bytes = reader_read (buffer, *bytes, _datasource);
+ return *bytes > 0 ? FLAC__STREAM_DECODER_READ_STATUS_CONTINUE :
+@@ -336,7 +336,7 @@
+ FLAC__StreamDecoderReadStatus
+ FlacStream::readCallBack (const FLAC__StreamDecoder *,
+ FLAC__byte buffer[],
+- unsigned * bytes,
++ size_t * bytes,
+ void * client_data)
+ {
+ if (!client_data)
+--- input/flac/FlacSeekableStream.cpp-dist 2007-04-25 14:45:29.000000000 +0200
++++ input/flac/FlacSeekableStream.cpp 2007-04-25 14:45:43.000000000 +0200
+@@ -255,7 +255,7 @@
+ FlacSeekableStream::readCallBack (const FLAC__StreamDecoder * /*decoder*/,
+ #endif
+ FLAC__byte buffer[],
+- unsigned * bytes,
++ size_t * bytes,
+ void * client_data)
+ {
+ if (!client_data)
+--- input/flac/FlacSeekableStream.h-dist 2007-04-25 14:45:32.000000000 +0200
++++ input/flac/FlacSeekableStream.h 2007-04-25 14:45:53.000000000 +0200
+@@ -114,7 +114,7 @@ class FlacSeekableStream : public FlacSt
+ readCallBack (const FLAC__StreamDecoder * decoder,
+ #endif
+ FLAC__byte buffer[],
+- unsigned * bytes,
++ size_t * bytes,
+ void * client_data);
+
+ #ifdef LEGACY_FLAC