summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGregorio Guidi <greg_g@gentoo.org>2005-02-13 22:20:58 +0000
committerGregorio Guidi <greg_g@gentoo.org>2005-02-13 22:20:58 +0000
commit351408f93a85d24c1db76820d14c41e12e6114af (patch)
tree1ae82ea44bf84f760de41bb2f9940159ecb67b60 /media-sound
parent~alpha keyword. (diff)
downloadgentoo-2-351408f93a85d24c1db76820d14c41e12e6114af.tar.gz
gentoo-2-351408f93a85d24c1db76820d14c41e12e6114af.tar.bz2
gentoo-2-351408f93a85d24c1db76820d14c41e12e6114af.zip
Version bump.
(Portage version: 2.0.51-r15)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/amarok/ChangeLog7
-rw-r--r--media-sound/amarok/Manifest2
-rw-r--r--media-sound/amarok/amarok-1.2.ebuild55
-rw-r--r--media-sound/amarok/files/digest-amarok-1.21
4 files changed, 64 insertions, 1 deletions
diff --git a/media-sound/amarok/ChangeLog b/media-sound/amarok/ChangeLog
index 1654fc93dfb9..ece44527700e 100644
--- a/media-sound/amarok/ChangeLog
+++ b/media-sound/amarok/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/amarok
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/amarok/ChangeLog,v 1.46 2005/02/02 10:21:28 greg_g Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/amarok/ChangeLog,v 1.47 2005/02/13 22:20:58 greg_g Exp $
+
+*amarok-1.2 (13 Feb 2005)
+
+ 13 Feb 2005; Gregorio Guidi <greg_g@gentoo.org> +amarok-1.2.ebuild:
+ Version bump.
02 Feb 2005; Gregorio Guidi <greg_g@gentoo.org> -files/amarok-1.0-cjk.diff,
amarok-1.2_beta4.ebuild:
diff --git a/media-sound/amarok/Manifest b/media-sound/amarok/Manifest
index 550f73aa530f..6702c3569427 100644
--- a/media-sound/amarok/Manifest
+++ b/media-sound/amarok/Manifest
@@ -1,9 +1,11 @@
MD5 15a028c1f8fff178682119240f0189be metadata.xml 181
+MD5 86cdd9c949f7aab53e2661a8013abc90 amarok-1.2.ebuild 1687
MD5 8dec94b33db41952f96628c1948fa301 amarok-1.0.2.ebuild 1199
MD5 811e9cf1fb14c5fdccba766e701c8dcb ChangeLog 6900
MD5 8ab1d316a1506fe1ecff05ba7f6cf8cb amarok-1.1.1.ebuild 1578
MD5 e5e0490ed4ab4de173dec6928c098dba amarok-1.2_beta4.ebuild 1747
MD5 33697f318e63c60a1ec8082330eece7f files/digest-amarok-1.1.1 66
MD5 167a3a9a42477903579be25096b8eaab files/digest-amarok-1.0.2 66
+MD5 29fa546c14f7d1c0498727a37e1468c0 files/digest-amarok-1.2 64
MD5 36de41fa399d57fd931b94231fbe1c85 files/digest-amarok-1.2_beta4 70
MD5 8af9e3314d69ebb6341e75b5a1ead176 files/amarok-1.0-cjk-a.diff 1532
diff --git a/media-sound/amarok/amarok-1.2.ebuild b/media-sound/amarok/amarok-1.2.ebuild
new file mode 100644
index 000000000000..10f36036b124
--- /dev/null
+++ b/media-sound/amarok/amarok-1.2.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/amarok/amarok-1.2.ebuild,v 1.1 2005/02/13 22:20:58 greg_g Exp $
+
+inherit kde eutils
+
+DESCRIPTION="amaroK - the audio player for KDE"
+HOMEPAGE="http://amarok.kde.org/"
+SRC_URI="mirror://sourceforge/amarok/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+IUSE="noamazon xmms opengl xine kde arts gstreamer mysql"
+# kde: enables compilation of the konqueror sidebar plugin
+
+KEYWORDS="~amd64 ~ppc -sparc ~x86"
+
+# Not yet released:
+# ">=media-libs/libvisual-0.2.0
+RDEPEND="kde? ( || ( kde-base/konqueror kde-base/kdebase ) )
+ arts? ( kde-base/arts
+ || ( kde-base/kdemultimedia-arts kde-base/kdemultimedia )
+ || ( kde-base/akode kde-base/kdemultimedia ) )
+ opengl? ( virtual/opengl )
+ xmms? ( >=media-sound/xmms-1.2 )
+ xine? ( >=media-libs/xine-lib-1_rc4 )
+ >=media-libs/tunepimp-0.3.0
+ >=media-libs/taglib-1.3.1
+ gstreamer? ( >=media-libs/gst-plugins-0.8.6
+ >=media-plugins/gst-plugins-mad-0.8.6 )
+ mysql? ( >=dev-db/mysql-3 )"
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.9.0"
+
+need-kde 3.2
+
+pkg_setup() {
+ if use !xine && use !arts && use !gstreamer
+ then
+ die "You must enable either aRts or Xine or GStreamer"
+ fi
+}
+
+src_compile() {
+ # amarok does not respect kde coding standards, and makes a lot of
+ # assuptions regarding its installation directory. For this reason,
+ # it must be installed in the KDE install directory.
+ PREFIX="`kde-config --prefix`"
+
+ myconf="$(use_with arts) $(use_with xine) $(use_with gstreamer) $(use_enable mysql) \
+ $(use_with opengl) $(use_enable !noamazon amazon)"
+
+ kde_src_compile
+}
diff --git a/media-sound/amarok/files/digest-amarok-1.2 b/media-sound/amarok/files/digest-amarok-1.2
new file mode 100644
index 000000000000..a9afddf26ff1
--- /dev/null
+++ b/media-sound/amarok/files/digest-amarok-1.2
@@ -0,0 +1 @@
+MD5 8db7d8985152ff29e8fb7377ada74527 amarok-1.2.tar.bz2 5449066