summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Wijsman <tomwij@gentoo.org>2014-05-10 14:03:41 +0000
committerTom Wijsman <tomwij@gentoo.org>2014-05-10 14:03:41 +0000
commit3eabc74d4bee292e35e645b34f3b27aca49d04db (patch)
treeb79e99ed3ca5a79aab712ee79fa1be2f9d2b73d8 /media-sound
parentSpring cleanup (diff)
downloadgentoo-2-3eabc74d4bee292e35e645b34f3b27aca49d04db.tar.gz
gentoo-2-3eabc74d4bee292e35e645b34f3b27aca49d04db.tar.bz2
gentoo-2-3eabc74d4bee292e35e645b34f3b27aca49d04db.zip
Revision bump. EAPI 5. Support --as-needed specification by reordering the linker command; fixes bug #336597, filed by Diego (flameeyes), with help from Samuli (ssuominen).
(Portage version: HEAD/cvs/Linux x86_64, signed Manifest commit with key 6D34E57D)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/dvda-author/ChangeLog12
-rw-r--r--media-sound/dvda-author/dvda-author-10.06-r1.ebuild53
2 files changed, 62 insertions, 3 deletions
diff --git a/media-sound/dvda-author/ChangeLog b/media-sound/dvda-author/ChangeLog
index cc8ff78a2fd5..d6ac4f87d761 100644
--- a/media-sound/dvda-author/ChangeLog
+++ b/media-sound/dvda-author/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-sound/dvda-author
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/dvda-author/ChangeLog,v 1.7 2010/08/30 23:27:06 radhermit Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/dvda-author/ChangeLog,v 1.8 2014/05/10 14:03:41 tomwij Exp $
+
+*dvda-author-10.06-r1 (10 May 2014)
+
+ 10 May 2014; Tom Wijsman <TomWij@gentoo.org> +dvda-author-10.06-r1.ebuild:
+ Revision bump. EAPI 5. Support --as-needed specification by reordering the
+ linker command; fixes bug #336597, filed by Diego (flameeyes), with help from
+ Samuli (ssuominen).
*dvda-author-10.06 (30 Aug 2010)
@@ -33,4 +40,3 @@
+files/dvda-author-20050703-flac113.diff, +metadata.xml,
+dvda-author-20050703.ebuild:
initial commit, using own patch to use system flac-libs >= 1.1.3
-
diff --git a/media-sound/dvda-author/dvda-author-10.06-r1.ebuild b/media-sound/dvda-author/dvda-author-10.06-r1.ebuild
new file mode 100644
index 000000000000..3179387428d4
--- /dev/null
+++ b/media-sound/dvda-author/dvda-author-10.06-r1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/dvda-author/dvda-author-10.06-r1.ebuild,v 1.1 2014/05/10 14:03:41 tomwij Exp $
+
+EAPI="5"
+
+DESCRIPTION="Author a DVD-Audio DVD"
+HOMEPAGE="http://dvd-audio.sourceforge.net"
+SRC_URI="mirror://sourceforge/dvd-audio/${P}-300.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+RDEPEND=">=media-sound/sox-14.1[png]
+ >=media-libs/flac-1.2.1[ogg]"
+DEPEND="${RDEPEND}
+ >=sys-devel/libtool-2"
+
+src_prepare() {
+ # Fix parallel make
+ sed -i -e 's:^\(\tcd ${MAYBE_CDRTOOLS}\):@HAVE_CDRTOOLS_BUILD_TRUE@\1:' \
+ Makefile.in || die "sed failed"
+
+ # Don't pre-strip binaries
+ sed -i -e 's:$LIBS -s:$LIBS:' configure || die "sed failed"
+
+ # Fix up --as-needed.
+ MY_AS_NEEDED_F='$(LINK) \($(dvda_OBJECTS)\)'
+ MY_AS_NEEDED_R='$(CCLD) $(AM_CFLAGS) $(CFLAGS) \1 $(AM_LDFLAGS) $(LDFLAGS) -o $@'
+ sed -i -e "s/${MY_AS_NEEDED_F}/${MY_AS_NEEDED_R}/" src/Makefile.in || die "sed failed"
+}
+
+src_configure() {
+ econf \
+ --disable-dependency-tracking \
+ --with-config=/etc \
+ $(use_with debug debug full)
+}
+
+src_compile() {
+ # make[1]: warning: jobserver unavailable: using -j1.
+ # Add '+' to parent make rule.
+ emake -j1
+}
+
+src_install() {
+ newbin src/dvda ${PN}
+ insinto /etc
+ doins ${PN}.conf
+ dodoc AUTHORS BUGS ChangeLog EXAMPLES HOWTO.conf LIMITATIONS NEWS TODO
+}