summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2008-09-20 11:16:45 +0000
committerAlexis Ballier <aballier@gentoo.org>2008-09-20 11:16:45 +0000
commit41b14c96f3c65295d97265f4234ec4c8e44e949f (patch)
tree5680d07a84e5507ec45dc09296379b6587de0bd6 /media-sound
parentppc stable, bug #231678 (diff)
downloadgentoo-2-41b14c96f3c65295d97265f4234ec4c8e44e949f.tar.gz
gentoo-2-41b14c96f3c65295d97265f4234ec4c8e44e949f.tar.bz2
gentoo-2-41b14c96f3c65295d97265f4234ec4c8e44e949f.zip
Version bump, by Auke Booij <auke.booij@gmail.com>, bug #238135
(Portage version: 2.2_rc8/cvs/Linux 2.6.26.3 x86_64)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/rosegarden/ChangeLog8
-rw-r--r--media-sound/rosegarden/rosegarden-1.7.2.ebuild79
2 files changed, 86 insertions, 1 deletions
diff --git a/media-sound/rosegarden/ChangeLog b/media-sound/rosegarden/ChangeLog
index 02f0755fd3db..b33b669d8de0 100644
--- a/media-sound/rosegarden/ChangeLog
+++ b/media-sound/rosegarden/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/rosegarden
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/rosegarden/ChangeLog,v 1.57 2008/08/07 20:45:09 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/rosegarden/ChangeLog,v 1.58 2008/09/20 11:16:45 aballier Exp $
+
+*rosegarden-1.7.2 (20 Sep 2008)
+
+ 20 Sep 2008; Alexis Ballier <aballier@gentoo.org>
+ +rosegarden-1.7.2.ebuild:
+ Version bump, by Auke Booij <auke.booij@gmail.com>, bug #238135
07 Aug 2008; Alexis Ballier <aballier@gentoo.org>
-files/rosegarden-1.6.1+gcc-4.3.patch,
diff --git a/media-sound/rosegarden/rosegarden-1.7.2.ebuild b/media-sound/rosegarden/rosegarden-1.7.2.ebuild
new file mode 100644
index 000000000000..b49046acfa44
--- /dev/null
+++ b/media-sound/rosegarden/rosegarden-1.7.2.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/rosegarden/rosegarden-1.7.2.ebuild,v 1.1 2008/09/20 11:16:45 aballier Exp $
+
+inherit eutils kde-functions cmake-utils
+
+MY_PV="${PV/_rc*/}"
+#MY_PV="${MY_PV/4./}"
+MY_P="${PN}-${MY_PV}"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="MIDI and audio sequencer and notation editor."
+HOMEPAGE="http://www.rosegardenmusic.com/"
+SRC_URI="mirror://sourceforge/rosegarden/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="alsa debug jack dssi lirc"
+
+RDEPEND="
+ alsa? ( >=media-libs/alsa-lib-1.0
+ jack? ( >=media-sound/jack-audio-connection-kit-0.77 )
+ )
+ >=media-libs/ladspa-sdk-1.0
+ >=media-libs/ladspa-cmt-1.14
+ dssi? ( >=media-libs/dssi-0.4 )
+ lirc? ( >=app-misc/lirc-0.7 )
+ >=media-libs/liblrdf-0.3
+ >=sci-libs/fftw-3.0.0
+ >=media-libs/liblo-0.7"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.15
+ >=dev-util/cmake-2.4.2"
+
+need-kde 3.5
+
+pkg_setup() {
+ if ! use alsa && use jack; then
+ ewarn "If you want JACK support you also need to enable"
+ ewarn "ALSA support, or the whole sound support will be"
+ ewarn "disabled."
+ fi
+
+ if use alsa && ! built_with_use --missing true media-libs/alsa-lib midi; then
+ eerror ""
+ eerror "To be able to build Rose Garden with ALSA support you need"
+ eerror "to have built media-libs/alsa-lib with midi USE flag."
+ die "Missing midi USE flag on media-libs/alsa-lib"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+
+ cd "${S}"
+ epatch "${FILESDIR}/rosegarden-1.6.1-asneeded.patch" \
+ "${FILESDIR}/rosegarden-1.6.1.desktop.diff"
+}
+
+src_compile() {
+ tc-export CC CXX LD
+
+ # cmake is stupid, very very stupid.
+ sed -i -e 's:CMAKE_CXX_FLAGS_\(RELEASE\|RELWITHDEBINFO\|DEBUG\).*".*"):CMAKE_CXX_FLAGS_\1 "'"${CXXFLAGS}"'"):' \
+ CMakeLists.txt || die "unable to sanitise CXXFLAGS"
+
+ mycmakeargs="$(cmake-utils_use_want alsa SOUND)
+ $(cmake-utils_use_want jack JACK)
+ $(cmake-utils_use_want dssi DSSI)
+ $(cmake-utils_use_want lirc LIRC)"
+ cmake-utils_src_compile
+}
+
+src_install() {
+ cmake-utils_src_install
+ dodoc AUTHORS README TRANSLATORS
+}