summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2011-06-09 18:43:01 +0000
committerAlexis Ballier <aballier@gentoo.org>2011-06-09 18:43:01 +0000
commit4a0fde545eeecbc608b275428bc628c878a85f2c (patch)
tree25a59a6717686a6facb4d90ddb187c1501f8a264 /media-sound
parentVersion bump. (diff)
downloadgentoo-2-4a0fde545eeecbc608b275428bc628c878a85f2c.tar.gz
gentoo-2-4a0fde545eeecbc608b275428bc628c878a85f2c.tar.bz2
gentoo-2-4a0fde545eeecbc608b275428bc628c878a85f2c.zip
version bump
(Portage version: 2.2.0_alpha38/cvs/Linux x86_64)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/vmpk/ChangeLog9
-rw-r--r--media-sound/vmpk/vmpk-0.4.0.ebuild35
2 files changed, 42 insertions, 2 deletions
diff --git a/media-sound/vmpk/ChangeLog b/media-sound/vmpk/ChangeLog
index 6d658b88c110..776ee5825aa3 100644
--- a/media-sound/vmpk/ChangeLog
+++ b/media-sound/vmpk/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/vmpk
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/vmpk/ChangeLog,v 1.10 2010/10/06 20:12:33 aballier Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/vmpk/ChangeLog,v 1.11 2011/06/09 18:43:01 aballier Exp $
+
+*vmpk-0.4.0 (09 Jun 2011)
+
+ 09 Jun 2011; Alexis Ballier <aballier@gentoo.org> +vmpk-0.4.0.ebuild:
+ version bump
*vmpk-0.3.3 (06 Oct 2010)
diff --git a/media-sound/vmpk/vmpk-0.4.0.ebuild b/media-sound/vmpk/vmpk-0.4.0.ebuild
new file mode 100644
index 000000000000..766ba9ba6e9b
--- /dev/null
+++ b/media-sound/vmpk/vmpk-0.4.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/vmpk/vmpk-0.4.0.ebuild,v 1.1 2011/06/09 18:43:01 aballier Exp $
+
+inherit cmake-utils eutils
+
+DESCRIPTION="Virtual MIDI Piano Keyboard"
+HOMEPAGE="http://vmpk.sourceforge.net/"
+SRC_URI="mirror://sourceforge/vmpk/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="dbus"
+
+RDEPEND="x11-libs/qt-core
+ x11-libs/qt-gui
+ x11-libs/qt-svg
+ dbus? ( x11-libs/qt-dbus )
+ media-libs/alsa-lib"
+DEPEND="${RDEPEND}
+ app-text/docbook-xsl-stylesheets
+ dev-util/pkgconfig"
+
+DOCS="AUTHORS ChangeLog NEWS README TODO"
+
+src_compile() {
+ local mycmakeargs=( "$(cmake-utils_use_enable dbus DBUS)" )
+ cmake-utils_src_compile
+}
+
+src_install() {
+ cmake-utils_src_install
+ rm -rf "${D}/usr/share/doc/packages"
+}