summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Mende <angelos@gentoo.org>2010-06-03 17:22:10 +0000
committerChristoph Mende <angelos@gentoo.org>2010-06-03 17:22:10 +0000
commit4be7f94d639a4d40dba75937bcc8e304d6c66c2b (patch)
treeaca96bae56dcf3fef2bc9d1f15abf4fc6e2422d2 /media-sound
parentFix wiki flag. (diff)
downloadgentoo-2-4be7f94d639a4d40dba75937bcc8e304d6c66c2b.tar.gz
gentoo-2-4be7f94d639a4d40dba75937bcc8e304d6c66c2b.tar.bz2
gentoo-2-4be7f94d639a4d40dba75937bcc8e304d6c66c2b.zip
Take over maintainership, version bump and respect LDFLAGS
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/mpdas/ChangeLog10
-rw-r--r--media-sound/mpdas/files/mpdas-0.2.5-ldflags.patch13
-rw-r--r--media-sound/mpdas/metadata.xml4
-rw-r--r--media-sound/mpdas/mpdas-0.2.5.ebuild37
4 files changed, 62 insertions, 2 deletions
diff --git a/media-sound/mpdas/ChangeLog b/media-sound/mpdas/ChangeLog
index 16e8162fdaa6..357c4aa226de 100644
--- a/media-sound/mpdas/ChangeLog
+++ b/media-sound/mpdas/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/mpdas
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/mpdas/ChangeLog,v 1.6 2009/05/20 17:57:12 ssuominen Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mpdas/ChangeLog,v 1.7 2010/06/03 17:22:10 angelos Exp $
+
+*mpdas-0.2.5 (03 Jun 2010)
+
+ 03 Jun 2010; Christoph Mende <angelos@gentoo.org> +mpdas-0.2.5.ebuild,
+ +files/mpdas-0.2.5-ldflags.patch, metadata.xml:
+ Take over maintainership, version bump and respect LDFLAGS
20 May 2009; Samuli Suominen <ssuominen@gentoo.org>
-mpdas-0.2.3-r1.ebuild, mpdas-0.2.4.ebuild:
diff --git a/media-sound/mpdas/files/mpdas-0.2.5-ldflags.patch b/media-sound/mpdas/files/mpdas-0.2.5-ldflags.patch
new file mode 100644
index 000000000000..e6b4552e4332
--- /dev/null
+++ b/media-sound/mpdas/files/mpdas-0.2.5-ldflags.patch
@@ -0,0 +1,13 @@
+diff --git a/Makefile b/Makefile
+index 591ebcb..df380b3 100644
+--- a/Makefile
++++ b/Makefile
+@@ -21,7 +21,7 @@ all: $(OUT)
+
+ $(OUT): $(OBJ)
+ @echo [LD] $@
+- @$(CXX) $(OBJ) $(LIBS) -o $(OUT)
++ @$(CXX) $(LDFLAGS) $(OBJ) $(LIBS) -o $(OUT)
+
+ clean:
+ rm -rf $(OBJ) $(OUT)
diff --git a/media-sound/mpdas/metadata.xml b/media-sound/mpdas/metadata.xml
index 3bf6bcfeb512..159a30662957 100644
--- a/media-sound/mpdas/metadata.xml
+++ b/media-sound/mpdas/metadata.xml
@@ -2,4 +2,8 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>sound</herd>
+ <maintainer>
+ <email>angelos@gentoo.org</email>
+ <name>Christoph Mende</name>
+ </maintainer>
</pkgmetadata>
diff --git a/media-sound/mpdas/mpdas-0.2.5.ebuild b/media-sound/mpdas/mpdas-0.2.5.ebuild
new file mode 100644
index 000000000000..a82e05e1503d
--- /dev/null
+++ b/media-sound/mpdas/mpdas-0.2.5.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mpdas/mpdas-0.2.5.ebuild,v 1.1 2010/06/03 17:22:10 angelos Exp $
+
+inherit base toolchain-funcs
+
+DESCRIPTION="An AudioScrobbler client for MPD written in C++"
+HOMEPAGE="http://50hz.ws/mpdas/"
+SRC_URI="http://50hz.ws/mpdas/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="media-libs/libmpd
+ net-misc/curl"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+PATCHES=( "${FILESDIR}/${P}-ldflags.patch" )
+
+src_compile() {
+ tc-export CXX
+ emake CONFIG="/etc" || die "emake failed"
+}
+
+src_install() {
+ dobin ${PN} || die "dobin failed"
+ doman ${PN}.1
+ dodoc ChangeLog mpdasrc.example README
+}
+
+pkg_postinst() {
+ elog "For further configuration help consult the README in"
+ elog "${EPREFIX}/usr/share/doc/${PF}"
+}