summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2008-06-07 14:53:26 +0000
committerAlexis Ballier <aballier@gentoo.org>2008-06-07 14:53:26 +0000
commit56f16e557c11ac4c695c77ee25777c767b398e1c (patch)
tree1088047149f2718db911f3dc71b1ee2711f1c614 /media-sound
parentRemoved old versions. (diff)
downloadgentoo-2-56f16e557c11ac4c695c77ee25777c767b398e1c.tar.gz
gentoo-2-56f16e557c11ac4c695c77ee25777c767b398e1c.tar.bz2
gentoo-2-56f16e557c11ac4c695c77ee25777c767b398e1c.zip
version bump
(Portage version: 2.1.5.4)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/qjackctl/ChangeLog7
-rw-r--r--media-sound/qjackctl/qjackctl-0.3.3.ebuild57
2 files changed, 63 insertions, 1 deletions
diff --git a/media-sound/qjackctl/ChangeLog b/media-sound/qjackctl/ChangeLog
index fb848b6f1b95..ce88cb1e44ec 100644
--- a/media-sound/qjackctl/ChangeLog
+++ b/media-sound/qjackctl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/qjackctl
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/qjackctl/ChangeLog,v 1.54 2008/04/28 18:09:51 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/qjackctl/ChangeLog,v 1.55 2008/06/07 14:53:26 aballier Exp $
+
+*qjackctl-0.3.3 (07 Jun 2008)
+
+ 07 Jun 2008; Alexis Ballier <aballier@gentoo.org> +qjackctl-0.3.3.ebuild:
+ version bump
28 Apr 2008; Raúl Porcel <armin76@gentoo.org> qjackctl-0.3.2.ebuild:
sparc stable wrt #217726
diff --git a/media-sound/qjackctl/qjackctl-0.3.3.ebuild b/media-sound/qjackctl/qjackctl-0.3.3.ebuild
new file mode 100644
index 000000000000..a632cf776dc9
--- /dev/null
+++ b/media-sound/qjackctl/qjackctl-0.3.3.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/qjackctl/qjackctl-0.3.3.ebuild,v 1.1 2008/06/07 14:53:26 aballier Exp $
+
+EAPI=1
+
+inherit eutils qt4
+
+DESCRIPTION="A Qt application to control the JACK Audio Connection Kit and ALSA sequencer connections."
+HOMEPAGE="http://qjackctl.sourceforge.net/"
+SRC_URI="mirror://sourceforge/qjackctl/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+IUSE="alsa debug"
+
+DEPEND="alsa? ( media-libs/alsa-lib )
+ || ( (
+ x11-libs/qt-core:4
+ x11-libs/qt-gui:4
+ ) >=x11-libs/qt-4.1:4 )
+ media-sound/jack-audio-connection-kit"
+
+pkg_setup() {
+ if use alsa && ! built_with_use --missing true media-libs/alsa-lib midi; then
+ eerror ""
+ eerror "To be able to build ${CATEGORY}/${PN} with ALSA support you"
+ eerror "need to have built media-libs/alsa-lib with midi USE flag."
+ die "Missing midi USE flag on media-libs/alsa-lib"
+ fi
+}
+
+src_compile() {
+ econf \
+ $(use_enable alsa alsa-seq) \
+ $(use_enable debug) \
+ || die "econf failed"
+
+ # Emulate what the Makefile does, so that we can get the correct
+ # compiler used.
+ eqmake4 ${PN}.pro -o ${PN}.mak || die "eqmake4 failed"
+
+ emake -f ${PN}.mak || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+
+ rm "${D}/usr/share/applications/qjackctl.desktop"
+
+ # Upstream desktop file is invalid, better stick with our for now.
+ make_desktop_entry "${PN}" "QjackCtl" "${PN}"
+
+ dodoc README ChangeLog TODO AUTHORS
+}