summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-04-30 21:39:05 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-04-30 21:39:05 +0000
commit5c3bd0684cef027bc0f9feff02253d76627a9ee0 (patch)
treeac4046d343c086dc3e9b1ca4b76d0cf1ac748631 /media-sound
parentAdding dev-python/sip to deps for #267224. Should really fix python deps now.... (diff)
downloadgentoo-2-5c3bd0684cef027bc0f9feff02253d76627a9ee0.tar.gz
gentoo-2-5c3bd0684cef027bc0f9feff02253d76627a9ee0.tar.bz2
gentoo-2-5c3bd0684cef027bc0f9feff02253d76627a9ee0.zip
Bump to 1.12, fixes #267678
(Portage version: 2.2_rc31/cvs/Linux x86_64)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/apetag/ChangeLog9
-rw-r--r--media-sound/apetag/apetag-1.12.ebuild37
2 files changed, 44 insertions, 2 deletions
diff --git a/media-sound/apetag/ChangeLog b/media-sound/apetag/ChangeLog
index 130ac7049211..206da061cba9 100644
--- a/media-sound/apetag/ChangeLog
+++ b/media-sound/apetag/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/apetag
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/apetag/ChangeLog,v 1.7 2008/11/20 20:37:10 flameeyes Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/apetag/ChangeLog,v 1.8 2009/04/30 21:39:05 patrick Exp $
+
+*apetag-1.12 (30 Apr 2009)
+
+ 30 Apr 2009; Patrick Lauer <patrick@gentoo.org> +apetag-1.12.ebuild:
+ Bump to 1.12, fixes #267678
20 Nov 2008; Diego E. Pettenò <flameeyes@gentoo.org> apetag-1.10.ebuild:
Fix sed line, closes bug #246753.
diff --git a/media-sound/apetag/apetag-1.12.ebuild b/media-sound/apetag/apetag-1.12.ebuild
new file mode 100644
index 000000000000..d9c66d1b1e98
--- /dev/null
+++ b/media-sound/apetag/apetag-1.12.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/apetag/apetag-1.12.ebuild,v 1.1 2009/04/30 21:39:05 patrick Exp $
+
+inherit eutils toolchain-funcs base
+
+DESCRIPTION="Command-line ape 2.0 tagger"
+HOMEPAGE="http://muth.org/Robert/Apetag/"
+SRC_URI="http://muth.org/Robert/Apetag/${PN}.${PV}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="dev-lang/python"
+
+S=${WORKDIR}/Apetag
+
+src_unpack() {
+ base_src_unpack
+ sed -i \
+ -e 's,CXXDEBUG,LDFLAGS,g' \
+ "${S}"/Makefile \
+ || die "404. Makefile not found."
+}
+
+src_compile() {
+ emake CXX="$(tc-getCXX)" LDFLAGS="${LDFLAGS}" CXXOPT="${CXXFLAGS}" || die "emake failed"
+}
+
+src_install() {
+ dobin apetag || die
+ dobin tagdir.py rmid3tag.py cddb.py || die
+ dodoc 00readme || die
+}