summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoe Sapp <nixphoeni@gentoo.org>2014-05-06 02:07:28 +0000
committerJoe Sapp <nixphoeni@gentoo.org>2014-05-06 02:07:28 +0000
commit6b6d9922bc126d970f3158130c51f35f31725045 (patch)
tree22ac3422c792a634a2474f3bc19ecce1c6b0fbb7 /media-sound
parentVersion bump. (diff)
downloadgentoo-2-6b6d9922bc126d970f3158130c51f35f31725045.tar.gz
gentoo-2-6b6d9922bc126d970f3158130c51f35f31725045.tar.bz2
gentoo-2-6b6d9922bc126d970f3158130c51f35f31725045.zip
Version bump; add limits.d file for realtime priority
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 35488453)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/xwax/ChangeLog10
-rw-r--r--media-sound/xwax/files/xwax-etc-security-limits.conf1
-rw-r--r--media-sound/xwax/xwax-1.5.ebuild81
3 files changed, 90 insertions, 2 deletions
diff --git a/media-sound/xwax/ChangeLog b/media-sound/xwax/ChangeLog
index e93e7af8abec..52d4c43c3754 100644
--- a/media-sound/xwax/ChangeLog
+++ b/media-sound/xwax/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/xwax
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/xwax/ChangeLog,v 1.57 2013/12/24 12:42:04 ago Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/xwax/ChangeLog,v 1.58 2014/05/06 02:07:28 nixphoeni Exp $
+
+*xwax-1.5 (06 May 2014)
+
+ 06 May 2014; Joe Sapp <nixphoeni@gentoo.org> +xwax-1.5.ebuild,
+ +files/xwax-etc-security-limits.conf:
+ Version bump; add limits.d file for realtime priority
24 Dec 2013; Agostino Sarubbo <ago@gentoo.org> xwax-1.4.ebuild:
Stable for x86, wrt bug #492566
diff --git a/media-sound/xwax/files/xwax-etc-security-limits.conf b/media-sound/xwax/files/xwax-etc-security-limits.conf
new file mode 100644
index 000000000000..7ae166ec18f8
--- /dev/null
+++ b/media-sound/xwax/files/xwax-etc-security-limits.conf
@@ -0,0 +1 @@
+@xwax - rtprio 80
diff --git a/media-sound/xwax/xwax-1.5.ebuild b/media-sound/xwax/xwax-1.5.ebuild
new file mode 100644
index 000000000000..93a8b24a29a8
--- /dev/null
+++ b/media-sound/xwax/xwax-1.5.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/xwax/xwax-1.5.ebuild,v 1.1 2014/05/06 02:07:28 nixphoeni Exp $
+
+EAPI=5
+inherit toolchain-funcs user
+
+DESCRIPTION="Digital vinyl emulation software"
+HOMEPAGE="http://www.xwax.co.uk/"
+SRC_URI="http://www.xwax.co.uk/releases/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="alsa jack oss cdda mp3 +fallback"
+REQUIRED_USE="|| ( cdda mp3 fallback )
+ || ( alsa jack oss )"
+
+RDEPEND="sys-libs/glibc
+ sys-libs/pam
+ media-libs/libsdl
+ media-libs/sdl-ttf
+ media-fonts/dejavu
+ alsa? ( media-libs/alsa-lib )
+ jack? ( media-sound/jack-audio-connection-kit )
+ cdda? ( media-sound/cdparanoia )
+ mp3? ( media-sound/mpg123 )
+ fallback? ( virtual/ffmpeg )"
+DEPEND="${RDEPEND}"
+
+DOCS="README CHANGES"
+
+src_prepare() {
+ # Remove the forced optimization from 'CFLAGS' and 'LDFLAGS' in
+ # the Makefile
+ # Also remove the dependency on the .version target so we don't need
+ # git just to build
+ sed -i -e 's/\(^\(LD\|C\)FLAGS.*\)-O[0-9]\(.*\)/\1\3/g' \
+ -e 's/^xwax\.o:.*\.version//' \
+ Makefile || die "sed failed"
+}
+
+src_configure() {
+ tc-export CC
+ econf \
+ --prefix "${EROOT}usr" \
+ $(use_enable alsa) \
+ $(use_enable jack) \
+ $(use_enable oss)
+}
+
+src_compile() {
+ # EXECDIR is the default directory in which xwax will look for
+ # the 'xwax-import' and 'xwax-scan' scripts
+ emake EXECDIR="\$(BINDIR)" VERSION="${PV}" xwax
+}
+
+pkg_preinst() {
+ enewgroup ${PN}
+}
+
+src_install() {
+ # This is easier than setting all the environment variables
+ # needed, running the sed script required to get the man directory
+ # correct, and removing the GPL-2 after a 'make install' run
+ dobin xwax || die "failed to install xwax"
+ newbin scan xwax-scan || die "failed to install xwax-scan"
+ newbin import xwax-import || die "failed to install xwax-import"
+ doman xwax.1 || die "failed to install man page"
+
+ dodoc ${DOCS} || die "failed to install docs"
+
+ insinto "/etc/security/limits.d"
+ newins "${FILESDIR}/xwax-etc-security-limits.conf" xwax.conf
+}
+
+pkg_postinst() {
+ elog "Be sure to add any users that will be using ${PN} to the"
+ elog "\"${PN}\" group. Doing so will allow processes that user"
+ elog "runs to request realtime priority."
+}