summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Wijsman <tomwij@gentoo.org>2014-01-30 02:02:42 +0000
committerTom Wijsman <tomwij@gentoo.org>2014-01-30 02:02:42 +0000
commit80ec5ce30aa8ffbff57e7b50ba9dc71f8c28c4f3 (patch)
treef643420e5c0776a947214a80940b2dd366b4dca1 /media-sound
parent[QA] Revision bump. EAPI 5. Fixed underlinking bug #369759 and LDFLAGS bug #3... (diff)
downloadgentoo-2-80ec5ce30aa8ffbff57e7b50ba9dc71f8c28c4f3.tar.gz
gentoo-2-80ec5ce30aa8ffbff57e7b50ba9dc71f8c28c4f3.tar.bz2
gentoo-2-80ec5ce30aa8ffbff57e7b50ba9dc71f8c28c4f3.zip
[QA] Revision bump. EAPI 5. Add LINGUAS support to fix bug #403625, reported by Piotr Szymaniak.
(Portage version: HEAD/cvs/Linux x86_64, signed Manifest commit with key 6D34E57D)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/gbsplay/ChangeLog12
-rw-r--r--media-sound/gbsplay/gbsplay-0.0.91-r1.ebuild (renamed from media-sound/gbsplay/gbsplay-0.0.91.ebuild)39
2 files changed, 34 insertions, 17 deletions
diff --git a/media-sound/gbsplay/ChangeLog b/media-sound/gbsplay/ChangeLog
index 3bbe3f385670..39e17a71a35d 100644
--- a/media-sound/gbsplay/ChangeLog
+++ b/media-sound/gbsplay/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-sound/gbsplay
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/gbsplay/ChangeLog,v 1.2 2008/12/22 20:52:10 maekke Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/gbsplay/ChangeLog,v 1.3 2014/01/30 02:02:42 tomwij Exp $
+
+*gbsplay-0.0.91-r1 (30 Jan 2014)
+
+ 30 Jan 2014; Tom Wijsman <TomWij@gentoo.org> +gbsplay-0.0.91-r1.ebuild,
+ -gbsplay-0.0.91.ebuild:
+ [QA] Revision bump. EAPI 5. Add LINGUAS support to fix bug #403625, reported
+ by Piotr Szymaniak.
22 Dec 2008; Markus Meier <maekke@gentoo.org> gbsplay-0.0.91.ebuild:
add ~amd64, bug #251863
@@ -10,4 +17,3 @@
20 Dec 2008; <ssuominen@gentoo.org> +gbsplay-0.0.91.ebuild:
Initial commit for bug 51115, thanks to Christian Garbs and Tobias
Diedrich.
-
diff --git a/media-sound/gbsplay/gbsplay-0.0.91.ebuild b/media-sound/gbsplay/gbsplay-0.0.91-r1.ebuild
index 264861b59503..bbfa681969eb 100644
--- a/media-sound/gbsplay/gbsplay-0.0.91.ebuild
+++ b/media-sound/gbsplay/gbsplay-0.0.91-r1.ebuild
@@ -1,10 +1,13 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/gbsplay/gbsplay-0.0.91.ebuild,v 1.3 2008/12/22 20:52:10 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/gbsplay/gbsplay-0.0.91-r1.ebuild,v 1.1 2014/01/30 02:02:42 tomwij Exp $
-EAPI=1
+EAPI="5"
-inherit toolchain-funcs
+IUSE="+alsa nas nls oss"
+PLOCALES="de en"
+
+inherit l10n toolchain-funcs
DESCRIPTION="Nintendo Gameboy sound player for GBS format."
HOMEPAGE="http://gbsplay.berlios.de"
@@ -13,16 +16,17 @@ SRC_URI="mirror://berlios/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="+alsa nas nls oss"
-RDEPEND="alsa? ( media-libs/alsa-lib )
- nas? ( media-libs/nas )"
+RDEPEND="alsa? ( media-libs/alsa-lib:0 )
+ nas? ( media-libs/nas:0 )"
+
DEPEND="${RDEPEND}
- nls? ( sys-devel/gettext )"
+ nls? ( sys-devel/gettext:0 )"
-src_compile() {
+src_configure() {
tc-export AR CC
+ # No econf, because "unknown option '--build=x86_64-pc-linux-gnu'"
./configure \
--prefix=/usr \
--mandir=/usr/share/man \
@@ -32,12 +36,19 @@ src_compile() {
$(use_enable nls i18n) \
$(use_enable oss devdsp) \
$(use_enable alsa) \
- $(use_enable nas) || die "./configure failed."
+ $(use_enable nas) || die "Configure failed."
+}
- emake CC="$(tc-getCC)" SPLINT="true" || die "emake failed."
+src_compile() {
+ emake CC="$(tc-getCC)" SPLINT="true"
}
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed."
- prepalldocs
+remove_disabled_locale() {
+ rm -rf "${D}"/usr/share/locale/$1
}
+
+src_install() {
+ default
+
+ l10n_for_each_disabled_locale_do remove_disabled_locale
+} \ No newline at end of file