summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2013-08-19 14:29:44 +0000
committerManuel Rüger <mrueg@gentoo.org>2013-08-19 14:29:44 +0000
commit8a25abfb40d44947173e0fc37cd10491928dfa73 (patch)
treeb89bf0bc2994e4bcd51e2be02904633a0c210534 /media-sound
parentRemove mask for PostGIS 2.1.0. (diff)
downloadgentoo-2-8a25abfb40d44947173e0fc37cd10491928dfa73.tar.gz
gentoo-2-8a25abfb40d44947173e0fc37cd10491928dfa73.tar.bz2
gentoo-2-8a25abfb40d44947173e0fc37cd10491928dfa73.zip
Straight to stable revision bump, as KDE SC 4.11.0 and <amarok-2.8 don't work well together
(Portage version: 2.2.0/cvs/Linux x86_64, RepoMan options: --force, unsigned Manifest commit)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/amarok/ChangeLog8
-rw-r--r--media-sound/amarok/amarok-2.7.1-r1.ebuild130
2 files changed, 137 insertions, 1 deletions
diff --git a/media-sound/amarok/ChangeLog b/media-sound/amarok/ChangeLog
index 3f6a776c371f..1721dc4af1b4 100644
--- a/media-sound/amarok/ChangeLog
+++ b/media-sound/amarok/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/amarok
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/amarok/ChangeLog,v 1.459 2013/08/18 14:06:49 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/amarok/ChangeLog,v 1.460 2013/08/19 14:29:44 mrueg Exp $
+
+*amarok-2.7.1-r1 (19 Aug 2013)
+
+ 19 Aug 2013; Manuel Rüger <mrueg@gentoo.org> +amarok-2.7.1-r1.ebuild:
+ Straight to stable revision bump, as KDE SC 4.11.0 and <amarok-2.8 don't work
+ well together
18 Aug 2013; Manuel Rüger <mrueg@gentoo.org> amarok-2.8.0.ebuild:
Style fixes
diff --git a/media-sound/amarok/amarok-2.7.1-r1.ebuild b/media-sound/amarok/amarok-2.7.1-r1.ebuild
new file mode 100644
index 000000000000..fd6dd990bf54
--- /dev/null
+++ b/media-sound/amarok/amarok-2.7.1-r1.ebuild
@@ -0,0 +1,130 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/amarok/amarok-2.7.1-r1.ebuild,v 1.1 2013/08/19 14:29:44 mrueg Exp $
+
+EAPI=5
+
+KDE_LINGUAS="bs ca ca@valencia cs da de el en_GB es et eu fi fr
+ga gl hu it ja lt lv nb nl pa pl pt pt_BR ru sl sr sr@ijekavian
+sr@ijekavianlatin sr@latin sv uk zh_CN zh_TW"
+KDE_REQUIRED="never"
+VIRTUALX_REQUIRED=test
+inherit flag-o-matic kde4-base
+
+DESCRIPTION="Advanced audio player based on KDE framework."
+HOMEPAGE="http://amarok.kde.org/"
+if [[ ${PV} != *9999* ]]; then
+ if [[ $PV == *[6-9][0-9]* ]]; then
+ SRC_URI="mirror://kde/unstable/${PN}/${PV}/src/${P}.tar.bz2"
+ else
+ SRC_URI="mirror://kde/stable/${PN}/${PV}/src/${P}.tar.bz2"
+ fi
+ KEYWORDS="amd64 ppc x86"
+else
+ KEYWORDS=""
+fi
+
+LICENSE="GPL-2"
+SLOT="4"
+IUSE="cdda daap debug +embedded ipod lastfm mp3tunes mtp ofa opengl test +utils"
+
+if [[ ${PV} == *9999* ]]; then
+ RESTRICT="test"
+fi
+
+# ipod requires gdk enabled and also gtk compiled in libgpod
+COMMONDEPEND="
+ app-crypt/qca:2
+ >=app-misc/strigi-0.5.7
+ <kde-base/kdelibs-4.11.0
+ $(add_kdebase_dep kdelibs 'opengl?,semantic-desktop(+)' 4.8.4)
+ $(add_kdebase_dep kdebase-kioslaves)
+ >=media-libs/taglib-1.7[asf,mp4]
+ >=media-libs/taglib-extras-1.0.1
+ $(add_kdebase_dep nepomuk-core '' 4.9.0)
+ sys-libs/zlib
+ >=virtual/mysql-5.1[embedded?]
+ >=dev-qt/qtcore-4.8:4
+ >=dev-qt/qtdbus-4.8:4
+ >=dev-qt/qtscript-4.8:4
+ >=x11-libs/qtscriptgenerator-0.1.0
+ cdda? (
+ $(add_kdebase_dep libkcddb)
+ $(add_kdebase_dep libkcompactdisc)
+ $(add_kdebase_dep audiocd-kio)
+ )
+ ipod? ( >=media-libs/libgpod-0.7.0[gtk] )
+ lastfm? ( >=media-libs/liblastfm-1.0.3 )
+ mp3tunes? (
+ dev-libs/glib:2
+ dev-libs/libxml2
+ dev-libs/openssl
+ net-libs/loudmouth
+ net-misc/curl
+ >=dev-qt/qtcore-4.8.4:4[glib]
+ )
+ mtp? ( >=media-libs/libmtp-1.0.0 )
+ ofa? ( >=media-libs/libofa-0.9.0 )
+ opengl? ( virtual/opengl )
+"
+DEPEND="${COMMONDEPEND}
+ dev-util/automoc
+ virtual/pkgconfig
+ test? ( dev-cpp/gmock )
+"
+RDEPEND="${COMMONDEPEND}
+ !media-sound/amarok-utils
+ $(add_kdebase_dep phonon-kde)
+"
+
+src_configure() {
+ # Append minimal-toc cflag for ppc64, see bug 280552 and 292707
+ use ppc64 && append-flags -mminimal-toc
+ local mycmakeargs
+
+ mycmakeargs=(
+ -DWITH_PLAYER=ON
+ -DWITH_Libgcrypt=OFF
+ -DWITH_SPECTRUM_ANALYZER=OFF
+ $(cmake-utils_use embedded WITH_MYSQL_EMBEDDED)
+ $(cmake-utils_use_with ipod)
+ $(cmake-utils_use_with ipod Gdk)
+ $(cmake-utils_use_with lastfm LibLastFm)
+ $(cmake-utils_use_with mtp)
+ $(cmake-utils_use_with mp3tunes MP3Tunes)
+ $(cmake-utils_use_with ofa LibOFA)
+ )
+
+ mycmakeargs+=(
+ $(cmake-utils_use_with utils UTILITIES)
+ )
+
+ kde4-base_src_configure
+}
+
+pkg_postinst() {
+ kde4-base_pkg_postinst
+
+ if use daap; then
+ echo
+ elog "You have installed amarok with daap support."
+ elog "You may be interested in installing www-servers/mongrel as well."
+ echo
+ fi
+
+ if ! use embedded; then
+ echo
+ elog "You've disabled the amarok support for embedded mysql DBs."
+ elog "You'll have to configure amarok to use an external db server."
+ echo
+ elog "Please read http://amarok.kde.org/wiki/MySQL_Server for details on how"
+ elog "to configure the external db and migrate your data from the embedded database."
+ echo
+
+ if has_version "virtual/mysql[minimal]"; then
+ elog "You built mysql with the minimal use flag, so it doesn't include the server."
+ elog "You won't be able to use the local mysql installation to store your amarok collection."
+ echo
+ fi
+ fi
+}