summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-01-04 15:10:49 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-01-04 15:10:49 +0000
commit9969ae64301444c10b92174019c08e183be469d0 (patch)
treeea14a7e8ff80263a5f4b2401f1fbf8f7b8988026 /media-sound
parentFixed bug #104727. (diff)
downloadgentoo-2-9969ae64301444c10b92174019c08e183be469d0.tar.gz
gentoo-2-9969ae64301444c10b92174019c08e183be469d0.tar.bz2
gentoo-2-9969ae64301444c10b92174019c08e183be469d0.zip
Applied patch to fix bus error on sparc, and keyworded ~sparc as per bug #110663.
(Portage version: 2.1_pre3-r1)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/mt-daapd/ChangeLog7
-rw-r--r--media-sound/mt-daapd/files/mt-daapd-0.2.3-sparc.patch20
-rw-r--r--media-sound/mt-daapd/mt-daapd-0.2.3-r2.ebuild5
3 files changed, 29 insertions, 3 deletions
diff --git a/media-sound/mt-daapd/ChangeLog b/media-sound/mt-daapd/ChangeLog
index 6fb9e1c402d4..3db49fc757e2 100644
--- a/media-sound/mt-daapd/ChangeLog
+++ b/media-sound/mt-daapd/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/mt-daapd
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/mt-daapd/ChangeLog,v 1.10 2006/01/04 07:23:46 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mt-daapd/ChangeLog,v 1.11 2006/01/04 15:10:49 flameeyes Exp $
+
+ 04 Jan 2006; Diego Pettenò <flameeyes@gentoo.org>
+ +files/mt-daapd-0.2.3-sparc.patch, mt-daapd-0.2.3-r2.ebuild:
+ Applied patch to fix bus error on sparc, and keyworded ~sparc as per bug
+ #110663.
04 Jan 2006; Diego Pettenò <flameeyes@gentoo.org>
mt-daapd-0.2.3-r2.ebuild:
diff --git a/media-sound/mt-daapd/files/mt-daapd-0.2.3-sparc.patch b/media-sound/mt-daapd/files/mt-daapd-0.2.3-sparc.patch
new file mode 100644
index 000000000000..482b25c13779
--- /dev/null
+++ b/media-sound/mt-daapd/files/mt-daapd-0.2.3-sparc.patch
@@ -0,0 +1,20 @@
+diff -Nura mt-daapd-0.2.3/src/mp3-scanner.c mt-daapd-0.2.3.sparc/src/mp3-scanner.c
+--- mt-daapd-0.2.3/src/mp3-scanner.c 2005-02-05 18:22:47.000000000 -0300
++++ mt-daapd-0.2.3.sparc/src/mp3-scanner.c 2006-01-03 16:39:50.000000000 -0300
+@@ -1663,14 +1663,14 @@
+ /* now check for an XING header */
+ if(strncasecmp((char*)&buffer[index+fi.xing_offset+4],"XING",4) == 0) {
+ DPRINTF(E_DBG,L_SCAN,"Found Xing header\n");
+- xing_flags=*((int*)&buffer[index+fi.xing_offset+4+4]);
++ memcpy (&xing_flags, &buffer[index+fi.xing_offset+4+4], sizeof(int));
+ xing_flags=ntohs(xing_flags);
+
+ DPRINTF(E_DBG,L_SCAN,"Xing Flags: %02X\n",xing_flags);
+
+ if(xing_flags & 0x1) {
+ /* Frames field is valid... */
+- fi.number_of_frames=*((int*)&buffer[index+fi.xing_offset+4+8]);
++ memcpy (&fi.number_of_frames, &buffer[index+fi.xing_offset+4+8], sizeof(int));
+ fi.number_of_frames=ntohs(fi.number_of_frames);
+ }
+ }
diff --git a/media-sound/mt-daapd/mt-daapd-0.2.3-r2.ebuild b/media-sound/mt-daapd/mt-daapd-0.2.3-r2.ebuild
index 3632e3662912..55260a0e2e47 100644
--- a/media-sound/mt-daapd/mt-daapd-0.2.3-r2.ebuild
+++ b/media-sound/mt-daapd/mt-daapd-0.2.3-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/mt-daapd/mt-daapd-0.2.3-r2.ebuild,v 1.2 2006/01/04 07:23:46 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mt-daapd/mt-daapd-0.2.3-r2.ebuild,v 1.3 2006/01/04 15:10:49 flameeyes Exp $
inherit flag-o-matic eutils
@@ -12,7 +12,7 @@ SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc-macos ~sh ~x86"
+KEYWORDS="~amd64 ~ppc ~ppc-macos ~sh ~sparc ~x86"
IUSE="howl vorbis avahi"
DEPEND="sys-libs/zlib
@@ -41,6 +41,7 @@ src_unpack() {
cd ${S}
epatch "${FILESDIR}/${P}-pidfile.patch"
epatch "${FILESDIR}/${P}-persist-fix.patch"
+ epatch "${FILESDIR}/${P}-sparc.patch"
}
src_compile() {