summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2010-04-12 08:38:53 +0000
committerAlexis Ballier <aballier@gentoo.org>2010-04-12 08:38:53 +0000
commitab8d695246aaa16b78ed0a9f3fe42494b8518fd4 (patch)
tree0f001a08becea29b77b4acda1c73487242a808ca /media-sound
parentFix up -r4 patch to fix compilation issue, bug #314785 (diff)
downloadgentoo-2-ab8d695246aaa16b78ed0a9f3fe42494b8518fd4.tar.gz
gentoo-2-ab8d695246aaa16b78ed0a9f3fe42494b8518fd4.tar.bz2
gentoo-2-ab8d695246aaa16b78ed0a9f3fe42494b8518fd4.zip
version bump, by Richard Ash <richard@audacityteam.org>, bug #312837
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/audacity/ChangeLog8
-rw-r--r--media-sound/audacity/audacity-1.3.12.ebuild94
-rw-r--r--media-sound/audacity/files/audacity-1.3.12-automagic.patch63
3 files changed, 164 insertions, 1 deletions
diff --git a/media-sound/audacity/ChangeLog b/media-sound/audacity/ChangeLog
index 0a6dd38f45e3..b395c85c83cd 100644
--- a/media-sound/audacity/ChangeLog
+++ b/media-sound/audacity/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/audacity
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/audacity/ChangeLog,v 1.138 2010/01/20 19:06:10 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/audacity/ChangeLog,v 1.139 2010/04/12 08:38:53 aballier Exp $
+
+*audacity-1.3.12 (12 Apr 2010)
+
+ 12 Apr 2010; Alexis Ballier <aballier@gentoo.org> +audacity-1.3.12.ebuild,
+ +files/audacity-1.3.12-automagic.patch:
+ version bump, by Richard Ash <richard@audacityteam.org>, bug #312837
*audacity-1.3.11 (20 Jan 2010)
diff --git a/media-sound/audacity/audacity-1.3.12.ebuild b/media-sound/audacity/audacity-1.3.12.ebuild
new file mode 100644
index 000000000000..9f0c7e2f0bda
--- /dev/null
+++ b/media-sound/audacity/audacity-1.3.12.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/audacity/audacity-1.3.12.ebuild,v 1.1 2010/04/12 08:38:53 aballier Exp $
+
+EAPI=2
+
+inherit eutils wxwidgets autotools versionator
+
+IUSE="alsa ffmpeg flac id3tag jack ladspa libsamplerate midi mp3 soundtouch twolame vamp vorbis"
+
+MY_PV=$(replace_version_separator 3 -)
+MY_P="${PN}-src-${MY_PV}-beta"
+MY_T="${PN}-minsrc-${MY_PV}-beta"
+DESCRIPTION="Free crossplatform audio editor"
+HOMEPAGE="http://audacity.sourceforge.net/"
+SRC_URI="http://${PN}.googlecode.com/files/${MY_T}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+RESTRICT="test"
+
+COMMON_DEPEND="=x11-libs/wxGTK-2.8*
+ >=app-arch/zip-2.3
+ >=media-libs/libsndfile-1.0.0
+ dev-libs/expat
+ libsamplerate? ( >=media-libs/libsamplerate-0.1.2 )
+ vorbis? ( >=media-libs/libvorbis-1.0 )
+ mp3? ( >=media-libs/libmad-0.14.2b )
+ flac? ( >=media-libs/flac-1.2.0[cxx] )
+ id3tag? ( media-libs/libid3tag )
+ soundtouch? ( >=media-libs/libsoundtouch-1.3.1 )
+ vamp? ( >=media-libs/vamp-plugin-sdk-2.0 )
+ twolame? ( media-sound/twolame )
+ ffmpeg? ( >=media-video/ffmpeg-0.4.9_p20080617 )
+ alsa? ( media-libs/alsa-lib )
+ jack? ( >=media-sound/jack-audio-connection-kit-0.103.0 )"
+# Crashes at startup here...
+# lv2? ( >=media-libs/slv2-0.6.0 )
+# Disabled upstream ATM
+# ladspa? ( >=media-libs/liblrdf-0.4.0 )
+
+RDEPEND="${COMMON_DEPEND}
+ mp3? ( >=media-sound/lame-3.70 )"
+DEPEND="${COMMON_DEPEND}
+ dev-util/pkgconfig"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-1.3.12-automagic.patch"
+ AT_M4DIR="${S}/m4" eautoreconf
+}
+
+src_configure() {
+ WX_GTK_VER="2.8"
+ need-wxwidgets unicode
+
+ # * always use system libraries if possible
+ # * options listed in the order that configure --help lists them
+ # * if libsamplerate not requested, use libresample instead.
+ econf \
+ --enable-unicode \
+ --enable-nyquist \
+ $(use_enable ladspa) \
+ --with-libsndfile=system \
+ --with-expat=system \
+ $(use_with libsamplerate) \
+ $(use_with !libsamplerate libresample) \
+ $(use_with vorbis libvorbis) \
+ $(use_with mp3 libmad) \
+ $(use_with flac libflac) \
+ $(use_with id3tag libid3tag) \
+ $(use_with soundtouch) \
+ $(use_with vamp libvamp) \
+ $(use_with twolame libtwolame) \
+ $(use_with ffmpeg) \
+ $(use_with midi) \
+ $(use_with alsa) \
+ $(use_with jack)
+}
+
+# $(use_with lv2 slv2) \
+# $(use_with ladspa liblrdf) \
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ # Remove bad doc install
+ rm -rf "${D}"/usr/share/doc
+
+ # Install our docs
+ dodoc README.txt
+}
diff --git a/media-sound/audacity/files/audacity-1.3.12-automagic.patch b/media-sound/audacity/files/audacity-1.3.12-automagic.patch
new file mode 100644
index 000000000000..a7aa66d83d46
--- /dev/null
+++ b/media-sound/audacity/files/audacity-1.3.12-automagic.patch
@@ -0,0 +1,63 @@
+diff -ur ../audacity-src-1.3.12-beta.orig/configure.in ./configure.in
+--- ../audacity-src-1.3.12-beta.orig/configure.in 2010-03-30 12:32:42.000000000 +0100
++++ ./configure.in 2010-04-02 17:03:07.154028262 +0100
+@@ -559,6 +559,8 @@
+ esac
+
+ dnl PortAudio configuration
++AC_ARG_WITH([alsa], AS_HELP_STRING([--without-alsa], [Build without alsa library (default: test)]))
++AC_ARG_WITH([jack], AS_HELP_STRING([--without-jack], [Build without jack library (default: test)]))
+
+ LOCAL_LIBS="$LOCAL_LIBS portaudio-v19/lib/libportaudio.a"
+ EXTRAOBJS="$EXTRAOBJS ../lib-src/portaudio-v19/lib/libportaudio.a"
+@@ -575,13 +577,21 @@
+ ;;
+ *)
+ dnl Unix
+- AC_CHECK_LIB(asound, snd_pcm_open, have_alsa=yes, have_alsa=no)
+- if [[ $have_alsa = "yes" ]] ; then
+- LIBS="$LIBS -lasound"
+- fi
+- PKG_CHECK_MODULES(JACK, jack, have_jack=yes, have_jack=no)
+- if [[ $have_jack = "yes" ]] ; then
+- LIBS="$LIBS $JACK_LIBS"
++ if test "x$with_alsa" != "xno"; then
++ AC_CHECK_LIB(asound, snd_pcm_open, have_alsa=yes, have_alsa=no)
++ if [[ $have_alsa = "yes" ]] ; then
++ LIBS="$LIBS -lasound"
++ else
++ AC_MSG_WARN([Support for alsa not available])
++ fi
++ fi
++ if test "x$with_jack" != "xno"; then
++ PKG_CHECK_MODULES(JACK, jack, have_jack=yes, have_jack=no)
++ if [[ $have_jack = "yes" ]] ; then
++ LIBS="$LIBS $JACK_LIBS"
++ else
++ AC_MSG_WARN([Support for jack not available])
++ fi
+ fi
+ AC_CHECK_LIB(hpi, HPI_SubSysCreate, have_asihpi=yes, have_asihpi=no, -lm)
+ if [[ $have_asihpi = "yes" ]] ; then
+Only in .: configure.in.orig
+diff -ur ../audacity-src-1.3.12-beta.orig/lib-src/portmixer/configure.ac ./lib-src/portmixer/configure.ac
+--- ../audacity-src-1.3.12-beta.orig/lib-src/portmixer/configure.ac 2010-03-30 12:29:47.000000000 +0100
++++ ./lib-src/portmixer/configure.ac 2010-04-02 17:03:07.154028262 +0100
+@@ -97,6 +97,7 @@
+ AC_CHECK_HEADER(alsa/asoundlib.h, have_alsa=yes, have_alsa=no)
+ AC_CHECK_HEADER(CoreAudio/CoreAudio.h, have_coreaudio=yes, have_coreaudio=no)
+
++AC_ARG_WITH([alsa], AS_HELP_STRING([--without-alsa], [Build without alsa library (default: test)]))
+ #
+ # Set up to use the identified ones
+ #
+@@ -107,7 +108,7 @@
+ objects="$objects px_unix_oss.o"
+ fi
+
+-if [[ $have_alsa = "yes" ]] ; then
++if [[ $have_alsa = "yes" -a "x$with_alsa" != "xno" ]] ; then
+ AC_MSG_NOTICE(Including support for ALSA);
+ AC_DEFINE(PX_USE_LINUX_ALSA)
+ objects="$objects px_linux_alsa.o"
+Only in ./lib-src/portmixer: configure.ac.orig