summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2003-02-08 02:34:12 +0000
committerSeemant Kulleen <seemant@gentoo.org>2003-02-08 02:34:12 +0000
commitaef9f314960ce54587ed3f6b142b5e62121a6894 (patch)
treed4cf01c739d9b4084d6097842753b21610267bd4 /media-sound
parentAdded hppa to keywords. (diff)
downloadgentoo-2-aef9f314960ce54587ed3f6b142b5e62121a6894.tar.gz
gentoo-2-aef9f314960ce54587ed3f6b142b5e62121a6894.tar.bz2
gentoo-2-aef9f314960ce54587ed3f6b142b5e62121a6894.zip
waif cli frontend for audio
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/waif/ChangeLog16
-rw-r--r--media-sound/waif/files/digest-waif-0.59.32
-rw-r--r--media-sound/waif/waif-0.59.3.ebuild65
3 files changed, 83 insertions, 0 deletions
diff --git a/media-sound/waif/ChangeLog b/media-sound/waif/ChangeLog
new file mode 100644
index 000000000000..14db715eaaef
--- /dev/null
+++ b/media-sound/waif/ChangeLog
@@ -0,0 +1,16 @@
+# ChangeLog for media-sound/waif
+# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/waif/ChangeLog,v 1.1 2003/02/08 02:34:12 seemant Exp $
+
+*waif-0.59.3 (07 Feb 2003)
+
+ 07 Feb 2003; Seemant Kulleen <seemant@gentoo.org> waif-0.59.3.ebuild
+ ChangeLog files/digest-waif-0.59.3 :
+
+ Why Another Infernal Frontend?! Well, this is more of an un-frontend
+ written in expect. Essentially, it acts as a front end to play different
+ kinds of audio files (from wav to mp3 to ogg to realplayer to midi) -- you
+ choose the player (including xmms and freeamp) for each time, execute
+ waif, which backgrounds itself and plays at your command. It is heavily
+ documented, so take a peek through the docs, and emerge takcd to control
+ your cdplayer with waif as well. Note that this is a console app.
diff --git a/media-sound/waif/files/digest-waif-0.59.3 b/media-sound/waif/files/digest-waif-0.59.3
new file mode 100644
index 000000000000..97c9f107e19b
--- /dev/null
+++ b/media-sound/waif/files/digest-waif-0.59.3
@@ -0,0 +1,2 @@
+MD5 9b2dfe3b5aa3375fdeb110ff3c8495d0 waif.tar.gz 60133
+MD5 563a36a809ff3e422f41ed5cc90c8a69 wfxmms-0.6.tgz 5192
diff --git a/media-sound/waif/waif-0.59.3.ebuild b/media-sound/waif/waif-0.59.3.ebuild
new file mode 100644
index 000000000000..10b41a651aca
--- /dev/null
+++ b/media-sound/waif/waif-0.59.3.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/waif/waif-0.59.3.ebuild,v 1.1 2003/02/08 02:34:12 seemant Exp $
+
+IUSE="X gnome"
+
+S=${WORKDIR}/${PN}
+S2=${WORKDIR}/wfxmms
+DESCRIPTION="Why Another Infernal Frontend -- console front end for various media-players"
+HOMEPAGE="http://eds.org/~straycat"
+SRC_URI="http://www.eds.org/~straycat/${PN}.tar.gz
+ xmms? http://www.eds.org/~straycat/wfxmms-0.6.tgz"
+
+SLOT="0"
+LICENSE="as-is"
+KEYWORDS="~x86"
+
+DEPEND="dev-lang/tcl
+ dev-tcltk/expect"
+
+RDEPEND="dev-tcltk/expect
+ media-sound/takcd
+ media-sound/aumix
+ xmms? ( media-sound/xmms )
+ oggvorbis? ( media-sound/vorbis-tools )"
+
+
+src_compile() {
+ cd Waif
+ ./mkindex.sh || die
+
+ if use xmms
+ then
+ cd ${S2}
+ make || die
+ fi
+}
+
+src_install() {
+
+ local tclv
+ tclv=$(grep TCL_VER /usr/include/tcl.h | sed 's:^.*"\(.*\)".*:\1:')
+
+ cd ${S}
+ insinto /usr/lib/tcl${tclv}/Waif
+ doins Waif/*
+
+ into /usr
+ dobin waif-helper waifsh
+ doman waifsh.1
+
+ dodoc CHANGES FAQ INSTALL README* TODO WHATSNEW
+ docinto Documentation
+ dodoc Documentation/*
+
+ if use xmms
+ then
+ cd ${S2}
+ into /usr
+ dobin wfxmms
+
+ docinto wfxmms
+ dodoc BUGS CHANGES README
+ fi
+}