summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2009-10-07 17:43:19 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2009-10-07 17:43:19 +0000
commitb2f46cd2d0143c9cd8c4c99bbc6359878da89ecc (patch)
tree88ea28381b7319f3c6a40a090cbec60c34814b73 /media-sound
parentppc stable #276583 (diff)
downloadgentoo-2-b2f46cd2d0143c9cd8c4c99bbc6359878da89ecc.tar.gz
gentoo-2-b2f46cd2d0143c9cd8c4c99bbc6359878da89ecc.tar.bz2
gentoo-2-b2f46cd2d0143c9cd8c4c99bbc6359878da89ecc.zip
Fix build with -fweb compiler flag (bug #287391).
(Portage version: 2.2_rc44/cvs/Linux x86_64)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/pulseaudio/ChangeLog7
-rw-r--r--media-sound/pulseaudio/files/pulseaudio-0.9.19-fweb.patch59
-rw-r--r--media-sound/pulseaudio/pulseaudio-0.9.19-r50.ebuild4
-rw-r--r--media-sound/pulseaudio/pulseaudio-0.9.19.ebuild4
4 files changed, 71 insertions, 3 deletions
diff --git a/media-sound/pulseaudio/ChangeLog b/media-sound/pulseaudio/ChangeLog
index b50f15ba92dd..cda20ac5a820 100644
--- a/media-sound/pulseaudio/ChangeLog
+++ b/media-sound/pulseaudio/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/pulseaudio
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/pulseaudio/ChangeLog,v 1.170 2009/10/05 10:31:45 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/pulseaudio/ChangeLog,v 1.171 2009/10/07 17:43:19 flameeyes Exp $
+
+ 07 Oct 2009; Diego E. Pettenò <flameeyes@gentoo.org>
+ pulseaudio-0.9.19.ebuild, pulseaudio-0.9.19-r50.ebuild,
+ +files/pulseaudio-0.9.19-fweb.patch:
+ Fix build with -fweb compiler flag (bug #287391).
05 Oct 2009; Diego E. Pettenò <flameeyes@gentoo.org>
pulseaudio-0.9.18.ebuild, pulseaudio-0.9.18-r50.ebuild,
diff --git a/media-sound/pulseaudio/files/pulseaudio-0.9.19-fweb.patch b/media-sound/pulseaudio/files/pulseaudio-0.9.19-fweb.patch
new file mode 100644
index 000000000000..36a89bc59bab
--- /dev/null
+++ b/media-sound/pulseaudio/files/pulseaudio-0.9.19-fweb.patch
@@ -0,0 +1,59 @@
+From 8ec304d2d1e956cc3f5f35437ac4fe580b36f004 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Diego=20Elio=20'Flameeyes'=20Petten=C3=B2?= <flameeyes@gmail.com>
+Date: Wed, 7 Oct 2009 19:31:11 +0200
+Subject: [PATCH] Fix build when using -fweb, accept both register and memory constraints.
+
+This was reported as Gentoo bug #287391 by Torsten Kaiser, and the fix was
+suggested by Mike Frysinger.
+---
+ src/pulsecore/svolume_mmx.c | 4 ++--
+ src/pulsecore/svolume_sse.c | 4 ++--
+ 2 files changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/src/pulsecore/svolume_mmx.c b/src/pulsecore/svolume_mmx.c
+index 1768eb5..745c7de 100644
+--- a/src/pulsecore/svolume_mmx.c
++++ b/src/pulsecore/svolume_mmx.c
+@@ -152,7 +152,7 @@ pa_volume_s16ne_mmx (int16_t *samples, int32_t *volumes, unsigned channels, unsi
+ " emms \n\t"
+
+ : "+r" (samples), "+r" (volumes), "+r" (length), "=D" ((pa_reg_x86)channel), "=&r" (temp)
+- : "X" ((pa_reg_x86)channels)
++ : "rm" ((pa_reg_x86)channels)
+ : "cc"
+ );
+ }
+@@ -228,7 +228,7 @@ pa_volume_s16re_mmx (int16_t *samples, int32_t *volumes, unsigned channels, unsi
+ " emms \n\t"
+
+ : "+r" (samples), "+r" (volumes), "+r" (length), "=D" ((pa_reg_x86)channel), "=&r" (temp)
+- : "X" ((pa_reg_x86)channels)
++ : "rm" ((pa_reg_x86)channels)
+ : "cc"
+ );
+ }
+diff --git a/src/pulsecore/svolume_sse.c b/src/pulsecore/svolume_sse.c
+index ab9394f..1cc4e0a 100644
+--- a/src/pulsecore/svolume_sse.c
++++ b/src/pulsecore/svolume_sse.c
+@@ -149,7 +149,7 @@ pa_volume_s16ne_sse2 (int16_t *samples, int32_t *volumes, unsigned channels, uns
+ "8: \n\t"
+
+ : "+r" (samples), "+r" (volumes), "+r" (length), "=D" (channel), "=&r" (temp)
+- : "X" ((pa_reg_x86)channels)
++ : "rm" ((pa_reg_x86)channels)
+ : "cc"
+ );
+ }
+@@ -237,7 +237,7 @@ pa_volume_s16re_sse2 (int16_t *samples, int32_t *volumes, unsigned channels, uns
+ "8: \n\t"
+
+ : "+r" (samples), "+r" (volumes), "+r" (length), "=D" (channel), "=&r" (temp)
+- : "X" ((pa_reg_x86)channels)
++ : "rm" ((pa_reg_x86)channels)
+ : "cc"
+ );
+ }
+--
+1.6.5.rc2
+
diff --git a/media-sound/pulseaudio/pulseaudio-0.9.19-r50.ebuild b/media-sound/pulseaudio/pulseaudio-0.9.19-r50.ebuild
index ac572a5e5957..38f625665fe1 100644
--- a/media-sound/pulseaudio/pulseaudio-0.9.19-r50.ebuild
+++ b/media-sound/pulseaudio/pulseaudio-0.9.19-r50.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/pulseaudio/pulseaudio-0.9.19-r50.ebuild,v 1.3 2009/10/05 10:31:45 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/pulseaudio/pulseaudio-0.9.19-r50.ebuild,v 1.4 2009/10/07 17:43:19 flameeyes Exp $
EAPI=2
@@ -88,6 +88,8 @@ pkg_setup() {
}
src_prepare() {
+ epatch "${FILESDIR}"/${P}-fweb.patch
+
elibtoolize
}
diff --git a/media-sound/pulseaudio/pulseaudio-0.9.19.ebuild b/media-sound/pulseaudio/pulseaudio-0.9.19.ebuild
index c9be0484b29f..11bc1258a669 100644
--- a/media-sound/pulseaudio/pulseaudio-0.9.19.ebuild
+++ b/media-sound/pulseaudio/pulseaudio-0.9.19.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/pulseaudio/pulseaudio-0.9.19.ebuild,v 1.3 2009/10/05 10:31:45 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/pulseaudio/pulseaudio-0.9.19.ebuild,v 1.4 2009/10/07 17:43:19 flameeyes Exp $
EAPI=2
@@ -81,6 +81,8 @@ pkg_setup() {
}
src_prepare() {
+ epatch "${FILESDIR}"/${P}-fweb.patch
+
elibtoolize
}