summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Gryniewicz <dang@gentoo.org>2007-02-13 21:04:12 +0000
committerDaniel Gryniewicz <dang@gentoo.org>2007-02-13 21:04:12 +0000
commitd2328844f8744a19f83856549fcd3c6b3cc859a2 (patch)
tree5852ab81937bb9b940c3b1419588b62bc274ffbd /media-sound
parentBumped 5.5 to latest development release (diff)
downloadgentoo-2-d2328844f8744a19f83856549fcd3c6b3cc859a2.tar.gz
gentoo-2-d2328844f8744a19f83856549fcd3c6b3cc859a2.tar.bz2
gentoo-2-d2328844f8744a19f83856549fcd3c6b3cc859a2.zip
Fix excessive notifications from some streams; bug #166484
(Portage version: 2.1.2-r9)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/rhythmbox/ChangeLog9
-rw-r--r--media-sound/rhythmbox/files/digest-rhythmbox-0.9.7-r23
-rw-r--r--media-sound/rhythmbox/files/rhythmbox-0.9.7-excessive-notification.patch16
-rw-r--r--media-sound/rhythmbox/rhythmbox-0.9.7-r2.ebuild122
4 files changed, 149 insertions, 1 deletions
diff --git a/media-sound/rhythmbox/ChangeLog b/media-sound/rhythmbox/ChangeLog
index dad883337793..1a2f05144664 100644
--- a/media-sound/rhythmbox/ChangeLog
+++ b/media-sound/rhythmbox/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-sound/rhythmbox
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/rhythmbox/ChangeLog,v 1.86 2007/02/02 21:50:32 joem Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/rhythmbox/ChangeLog,v 1.87 2007/02/13 21:04:12 dang Exp $
+
+*rhythmbox-0.9.7-r2 (13 Feb 2007)
+
+ 13 Feb 2007; Daniel Gryniewicz <dang@gentoo.org>
+ +files/rhythmbox-0.9.7-excessive-notification.patch,
+ +rhythmbox-0.9.7-r2.ebuild:
+ Fix excessive notifications from some streams; bug #166484
*rhythmbox-0.9.7-r1 (02 Feb 2007)
diff --git a/media-sound/rhythmbox/files/digest-rhythmbox-0.9.7-r2 b/media-sound/rhythmbox/files/digest-rhythmbox-0.9.7-r2
new file mode 100644
index 000000000000..9b731a17d661
--- /dev/null
+++ b/media-sound/rhythmbox/files/digest-rhythmbox-0.9.7-r2
@@ -0,0 +1,3 @@
+MD5 3ca989c655c5931ce056af7ff311885b rhythmbox-0.9.7.tar.bz2 3231718
+RMD160 547643b40b36e4e0c18b6d817c37426ce585119f rhythmbox-0.9.7.tar.bz2 3231718
+SHA256 2fac1912a15c19841d4ca3188df7aa8c7aaa37dbbffb279b24259cc1281ff995 rhythmbox-0.9.7.tar.bz2 3231718
diff --git a/media-sound/rhythmbox/files/rhythmbox-0.9.7-excessive-notification.patch b/media-sound/rhythmbox/files/rhythmbox-0.9.7-excessive-notification.patch
new file mode 100644
index 000000000000..ace510e2e0d0
--- /dev/null
+++ b/media-sound/rhythmbox/files/rhythmbox-0.9.7-excessive-notification.patch
@@ -0,0 +1,16 @@
+diff --exclude-from=/home/dang/bin/scripts/diffrc -up -ruN rhythmbox-0.9.7.orig/sources/rb-streaming-source.c rhythmbox-0.9.7/sources/rb-streaming-source.c
+--- rhythmbox-0.9.7.orig/sources/rb-streaming-source.c 2006-10-30 08:51:11.000000000 -0500
++++ rhythmbox-0.9.7/sources/rb-streaming-source.c 2007-02-13 15:53:31.000000000 -0500
+@@ -360,6 +360,12 @@ set_streaming_metadata (RBStreamingSourc
+ const char *value)
+ {
+ GValue v = {0,};
++
++ /* don't do anything if the value isn't changing */
++ if (*field != NULL && strcmp (*field, value) == 0) {
++ return;
++ }
++
+ g_free (*field);
+ *field = g_strdup (value);
+
diff --git a/media-sound/rhythmbox/rhythmbox-0.9.7-r2.ebuild b/media-sound/rhythmbox/rhythmbox-0.9.7-r2.ebuild
new file mode 100644
index 000000000000..a8857401db1a
--- /dev/null
+++ b/media-sound/rhythmbox/rhythmbox-0.9.7-r2.ebuild
@@ -0,0 +1,122 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/rhythmbox/rhythmbox-0.9.7-r2.ebuild,v 1.1 2007/02/13 21:04:12 dang Exp $
+
+inherit gnome2 eutils
+
+DESCRIPTION="Music management and playback software for GNOME"
+HOMEPAGE="http://www.rhythmbox.org/"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="vorbis flac mad ipod avahi hal howl daap dbus libnotify lirc musicbrainz
+tagwriting python keyring"
+#I want tagwriting to be on by default in the future. It is just a local flag
+#now because it is still considered experimental by upstream and doesn't work
+#well with all formats due to gstreamer limitation.
+
+SLOT="0"
+
+RDEPEND=">=x11-libs/gtk+-2.6
+ >=gnome-base/libgnomeui-2
+ >=gnome-base/libglade-2
+ >=gnome-base/gnome-vfs-2.7.4
+ >=gnome-base/libbonobo-2
+ >=gnome-extra/nautilus-cd-burner-2.11.3
+ >=media-video/totem-1.1.5
+ >=x11-libs/libsexy-0.1.5
+ >=gnome-extra/gnome-media-2.14.0
+ >=media-plugins/gst-plugins-cdparanoia-0.10
+ keyring? ( >=gnome-base/gnome-keyring-0.4.9 )
+ musicbrainz? ( >=media-libs/musicbrainz-2.1 )
+ >=net-libs/libsoup-2.2.99
+ hal? ( ipod? ( >=media-libs/libgpod-0.4 )
+ >=sys-apps/hal-0.5 )
+ avahi? ( >=net-dns/avahi-0.6 )
+ !avahi? ( howl? ( >=net-misc/howl-0.9.8 ) )
+ dbus? ( || ( >=dev-libs/dbus-glib-0.71
+ ( <sys-apps/dbus-0.90 >=sys-apps/dbus-0.35 ) ) )
+ >=media-libs/gst-plugins-base-0.10
+ >=media-plugins/gst-plugins-gnomevfs-0.10
+ vorbis? ( >=media-plugins/gst-plugins-vorbis-0.10
+ >=media-plugins/gst-plugins-ogg-0.10 )
+ mad? ( >=media-plugins/gst-plugins-mad-0.10 )
+ flac? ( >=media-plugins/gst-plugins-flac-0.10 )
+ libnotify? ( >=x11-libs/libnotify-0.3.2 )
+ python? ( >=dev-lang/python-2.4.2
+ >=dev-python/pygtk-2.8
+ >=dev-python/gnome-python-2.12 )"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ >=dev-util/intltool-0.29
+ app-text/scrollkeeper"
+
+MAKEOPTS="${MAKEOPTS} -j1"
+
+pkg_setup() {
+
+ if ! use avahi && ! use howl; then
+ if use daap ; then
+ ewarn "Daap support requires either howl or avahi"
+ ewarn "to be installed. Please remerge with either"
+ ewarn "USE=avahi or USE=howl"
+ fi
+ fi
+ if use howl || use avahi ; then
+ G2CONF="${G2CONF} $(use_enable daap)"
+ fi
+
+ if use howl ; then
+ G2CONF="${G2CONF} --with-mdns=howl"
+ fi
+
+ if use avahi ; then
+ G2CONF="${G2CONF} --with-mdns=avahi"
+ fi
+
+ G2CONF="${G2CONF} \
+ $(use_enable tagwriting tag-writing) \
+ $(use_with ipod) \
+ $(use_enable ipod ipod-writing) \
+ $(use_enable musicbrainz) \
+ $(use_with dbus) \
+ $(use_enable python) \
+ $(use_enable libnotify) \
+ $(use_enable lirc) \
+ $(use_with keyring gnome-keyring)
+ --with-playback=gstreamer-0-10 \
+ --with-cd-burning
+ --enable-mmkeys \
+ --enable-audioscrobbler \
+ --enable-track-transfer \
+ --with-metadata-helper \
+ --disable-schemas-install"
+
+DOCS="AUTHORS COPYING ChangeLog DOCUMENTERS INSTALL INTERNALS \
+ MAINTAINERS NEWS README README.iPod THANKS TODO"
+
+export GST_INSPECT=/bin/true
+USE_DESTDIR=1
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch "${FILESDIR}"/${P}-daap_fix.patch
+ epatch "${FILESDIR}"/${P}-excessive-notification.patch
+ gnome2_omf_fix
+}
+
+src_compile() {
+ addpredict "$(unset HOME; echo ~)/.gconf"
+ addpredict "$(unset HOME; echo ~)/.gconfd"
+ gnome2_src_compile
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ elog "The aac flag has been removed from rhythmbox."
+ elog "This is due to stabilization issues with any gst-bad plugins."
+ elog "Please emerge gst-plugins-bad and gst-plugins-faad to be able to play m4a files"
+ elog "See bug #159538 for more information"
+}