summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-05-30 10:01:11 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-05-30 10:01:11 +0000
commitd99c19d1749bff2fa4f862e0eef5998c0ea4f5a5 (patch)
tree814bbe7257e3a1ab5fee2f5fa6431c2855b270f9 /media-sound
parentFixed nspluging install even with unset use flag, bug #134878 (diff)
downloadgentoo-2-d99c19d1749bff2fa4f862e0eef5998c0ea4f5a5.tar.gz
gentoo-2-d99c19d1749bff2fa4f862e0eef5998c0ea4f5a5.tar.bz2
gentoo-2-d99c19d1749bff2fa4f862e0eef5998c0ea4f5a5.zip
Version bump, thanks to Barry Shilliday in bug #134888.
(Portage version: 2.1_rc3-r2)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/lame/ChangeLog8
-rw-r--r--media-sound/lame/files/digest-lame-3.97_beta23
-rw-r--r--media-sound/lame/lame-3.97_beta2.ebuild75
3 files changed, 85 insertions, 1 deletions
diff --git a/media-sound/lame/ChangeLog b/media-sound/lame/ChangeLog
index 59dbcdbadcbe..4869f3f45378 100644
--- a/media-sound/lame/ChangeLog
+++ b/media-sound/lame/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/lame
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/lame/ChangeLog,v 1.69 2006/05/26 17:51:07 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/lame/ChangeLog,v 1.70 2006/05/30 10:01:11 flameeyes Exp $
+
+*lame-3.97_beta2 (30 May 2006)
+
+ 30 May 2006; Diego Pettenò <flameeyes@gentoo.org>
+ +lame-3.97_beta2.ebuild:
+ Version bump, thanks to Barry Shilliday in bug #134888.
26 May 2006; Diego Pettenò <flameeyes@gentoo.org> -lame-3.96.ebuild,
lame-3.96.1-r1.ebuild:
diff --git a/media-sound/lame/files/digest-lame-3.97_beta2 b/media-sound/lame/files/digest-lame-3.97_beta2
new file mode 100644
index 000000000000..208670a3f5fd
--- /dev/null
+++ b/media-sound/lame/files/digest-lame-3.97_beta2
@@ -0,0 +1,3 @@
+MD5 f3109237dfa9e025a2eb23fdae338166 lame-3.97b2.tar.gz 1327960
+RMD160 24d1bf8a1e73001960b434ff9323b3d2e55ad0a1 lame-3.97b2.tar.gz 1327960
+SHA256 1aee06e15571f5316ba91e40ae8d5a0413efdcef1f15aa6a34c8e1dc438a2a62 lame-3.97b2.tar.gz 1327960
diff --git a/media-sound/lame/lame-3.97_beta2.ebuild b/media-sound/lame/lame-3.97_beta2.ebuild
new file mode 100644
index 000000000000..8d70dde80b8b
--- /dev/null
+++ b/media-sound/lame/lame-3.97_beta2.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/lame/lame-3.97_beta2.ebuild,v 1.1 2006/05/30 10:01:11 flameeyes Exp $
+
+inherit flag-o-matic toolchain-funcs eutils autotools
+
+MY_P="${P/_beta/b}"
+S="${WORKDIR}/${P%%_beta*}"
+
+DESCRIPTION="LAME Ain't an MP3 Encoder"
+HOMEPAGE="http://lame.sourceforge.net"
+SRC_URI="mirror://sourceforge/lame/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc-macos ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="gtk debug"
+
+RDEPEND=">=sys-libs/ncurses-5.2
+ gtk? ( =x11-libs/gtk+-1.2* )"
+DEPEND="${RDEPEND}
+ sys-devel/autoconf"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S} || die
+
+ # The frontened tries to link staticly, but we prefer shared libs
+ epatch "${FILESDIR}/${PN}-3.96.1-shared-frontend.patch"
+
+ # If ccc (alpha compiler) is installed on the system, the default
+ # configure is broken, fix it to respect CC. This is only
+ # directly broken for ARCH=alpha but would affect anybody with a
+ # ccc binary in their PATH. Bug #41908 (26 Jul 2004 agriffis)
+ epatch "${FILESDIR}/${PN}-3.96-ccc.patch"
+
+ # Make sure -lm is linked in the library to fix other programs linking to
+ # this while using --as-needed
+ epatch "${FILESDIR}/${PN}-3.96.1-asneeded.patch"
+
+ AT_M4DIR="${S}" eautoreconf || die
+ epunt_cxx # embedded bug #74498
+}
+
+src_compile() {
+ # take out -fomit-frame-pointer from CFLAGS if k6-2
+ is-flag "-march=k6-3" && filter-flags "-fomit-frame-pointer"
+ is-flag "-march=k6-2" && filter-flags "-fomit-frame-pointer"
+ is-flag "-march=k6" && filter-flags "-fomit-frame-pointer"
+
+ [ "`gcc-fullversion`" == "3.3.2" ] && replace-flags -march=2.0 -march=1.0
+
+ # The user sets compiler optimizations... But if you'd like
+ # lame to choose it's own... uncomment one of these (experiMENTAL)
+ # myconf="${myconf} --enable-expopt=full \
+ # myconf="${myconf} --enable-expopt=norm \
+
+ econf \
+ --enable-shared \
+ --enable-mp3rtp \
+ $(use_enable debug debug norm) \
+ $(use_enable gtk mp3x) \
+ ${myconf} || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" pkghtmldir="/usr/share/doc/${PF}/html" install || die
+
+ dodoc API ChangeLog HACKING PRESETS.draft README* STYLEGUIDE TODO USAGE
+ dohtml misc/lameGUI.html Dll/LameDLLInterface.htm
+
+ dobin ${S}/misc/mlame
+}