summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2007-12-16 14:06:44 +0000
committerAlexis Ballier <aballier@gentoo.org>2007-12-16 14:06:44 +0000
commitde88f6813d11b655debeab597479c6b65e64da4d (patch)
tree29327ecf9c301af1b4ffaada86ec64d205a2efed /media-sound
parentadd ~x86-fbsd, its fine here (diff)
downloadgentoo-2-de88f6813d11b655debeab597479c6b65e64da4d.tar.gz
gentoo-2-de88f6813d11b655debeab597479c6b65e64da4d.tar.bz2
gentoo-2-de88f6813d11b655debeab597479c6b65e64da4d.zip
use external libgsm, bug #192736
(Portage version: 2.1.4_rc10)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/sox/ChangeLog7
-rw-r--r--media-sound/sox/files/digest-sox-14.0.0-r13
-rw-r--r--media-sound/sox/sox-14.0.0-r1.ebuild61
3 files changed, 70 insertions, 1 deletions
diff --git a/media-sound/sox/ChangeLog b/media-sound/sox/ChangeLog
index e5355e105f43..e6e4f6c3c3a8 100644
--- a/media-sound/sox/ChangeLog
+++ b/media-sound/sox/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/sox
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/sox/ChangeLog,v 1.73 2007/11/28 17:34:41 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/sox/ChangeLog,v 1.74 2007/12/16 14:06:43 aballier Exp $
+
+*sox-14.0.0-r1 (16 Dec 2007)
+
+ 16 Dec 2007; Alexis Ballier <aballier@gentoo.org> +sox-14.0.0-r1.ebuild:
+ use external libgsm, bug #192736
28 Nov 2007; Raúl Porcel <armin76@gentoo.org> sox-14.0.0.ebuild:
alpha/sparc stable wrt #200051
diff --git a/media-sound/sox/files/digest-sox-14.0.0-r1 b/media-sound/sox/files/digest-sox-14.0.0-r1
new file mode 100644
index 000000000000..9fe465799644
--- /dev/null
+++ b/media-sound/sox/files/digest-sox-14.0.0-r1
@@ -0,0 +1,3 @@
+MD5 c0c242fb2760cea9dc30de884eb1facc sox-14.0.0.tar.gz 1188338
+RMD160 705e104c6dbc31238a9de146a7b2bf3c634bd003 sox-14.0.0.tar.gz 1188338
+SHA256 8c2a6aa3404917205858d6ecb9c6ed1e9487b03575679638f026ad4d2d01fbd0 sox-14.0.0.tar.gz 1188338
diff --git a/media-sound/sox/sox-14.0.0-r1.ebuild b/media-sound/sox/sox-14.0.0-r1.ebuild
new file mode 100644
index 000000000000..4d6e9ab2561f
--- /dev/null
+++ b/media-sound/sox/sox-14.0.0-r1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/sox/sox-14.0.0-r1.ebuild,v 1.1 2007/12/16 14:06:43 aballier Exp $
+
+inherit flag-o-matic eutils
+
+DESCRIPTION="The swiss army knife of sound processing programs"
+HOMEPAGE="http://sox.sourceforge.net"
+SRC_URI="mirror://sourceforge/sox/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~x86-fbsd"
+IUSE="alsa ao debug ffmpeg flac encode ladspa mad libsamplerate ogg oss sndfile"
+
+DEPEND="alsa? ( media-libs/alsa-lib )
+ encode? ( media-sound/lame )
+ flac? ( media-libs/flac )
+ mad? ( media-libs/libmad )
+ sndfile? ( media-libs/libsndfile )
+ libsamplerate? ( media-libs/libsamplerate )
+ ogg? ( media-libs/libvorbis media-libs/libogg )
+ ao? ( media-libs/libao )
+ ffmpeg? ( media-video/ffmpeg )
+ ladspa? ( media-libs/ladspa-sdk )
+ >=media-sound/gsm-1.0.12-r1"
+# Fails to compile here ...
+# amrnb? ( media-libs/amrnb )
+# amrwb? ( media-libs/amrwb )
+
+src_compile () {
+ # Fixes wav segfaults. See Bug #35745.
+ append-flags -fsigned-char
+
+ econf $(use_enable alsa) \
+ $(use_enable debug) \
+ $(use_enable ao libao) \
+ $(use_enable oss) \
+ $(use_with encode lame) \
+ $(use_with mad) \
+ $(use_with sndfile) \
+ $(use_with flac) \
+ $(use_with ogg) \
+ $(use_with libsamplerate samplerate) \
+ $(use_with ffmpeg) \
+ $(use_with ladspa) \
+ --without-amr-wb \
+ --without-amr-nb \
+ --enable-fast-ulaw \
+ --enable-fast-alaw \
+ || die "configure failed"
+
+ #workaround for flac, it wants to include a damn config.h file
+ touch src/config.h
+ emake || die "emake failed."
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed."
+ dodoc NEWS ChangeLog README AUTHORS
+}