summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Schwarzott <zzam@gentoo.org>2006-01-06 12:14:26 +0000
committerMatthias Schwarzott <zzam@gentoo.org>2006-01-06 12:14:26 +0000
commit1efef3a58bc919c44af425bbb04790ed2ca3e459 (patch)
treeee6594dbe7498f809fd7ebe9cae68dc08a0a5fcf /media-tv/dvbtune/dvbtune-0.5.ebuild
parentAdded ~sparc keyword. (diff)
downloadgentoo-2-1efef3a58bc919c44af425bbb04790ed2ca3e459.tar.gz
gentoo-2-1efef3a58bc919c44af425bbb04790ed2ca3e459.tar.bz2
gentoo-2-1efef3a58bc919c44af425bbb04790ed2ca3e459.zip
Initial import of ebuild, thanks to Ben De luca <bedel@allmail.net>, Bug #48741
(Portage version: 2.1_pre3-r1)
Diffstat (limited to 'media-tv/dvbtune/dvbtune-0.5.ebuild')
-rw-r--r--media-tv/dvbtune/dvbtune-0.5.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/media-tv/dvbtune/dvbtune-0.5.ebuild b/media-tv/dvbtune/dvbtune-0.5.ebuild
new file mode 100644
index 000000000000..2b7005ca899a
--- /dev/null
+++ b/media-tv/dvbtune/dvbtune-0.5.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-tv/dvbtune/dvbtune-0.5.ebuild,v 1.1 2006/01/06 12:14:26 zzam Exp $
+
+inherit eutils
+
+DESCRIPTION="simple tuning app for DVB cards"
+HOMEPAGE="http://sourceforge.net/projects/dvbtools"
+SRC_URI="mirror://sourceforge/dvbtools/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="xml2"
+
+RDEPEND="xml2? ( dev-libs/libxml2 )"
+DEPEND="${RDEPEND}
+ media-tv/linuxtv-dvb-headers"
+
+src_unpack() {
+ unpack ${A}
+
+ epatch ${FILESDIR}/${P}-gentoo.diff
+}
+
+src_compile() {
+ emake dvbtune
+
+ use xml2 && emake xml2vdr
+}
+
+src_install() {
+ dobin dvbtune
+
+ use xml2 && dobin xml2vdr
+
+ dodoc README scripts/*
+}
+