summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Dibb <beandog@gentoo.org>2007-01-08 02:39:46 +0000
committerSteve Dibb <beandog@gentoo.org>2007-01-08 02:39:46 +0000
commit3587b0466e437fa377dcaa19e6b4014cf1706d5d (patch)
tree6ea6b828ec6971ef44c4ffef33bffc7579877372 /media-tv/ivtv/ivtv-0.8.2-r1.ebuild
parentQA: Removed unused versions. (diff)
downloadgentoo-2-3587b0466e437fa377dcaa19e6b4014cf1706d5d.tar.gz
gentoo-2-3587b0466e437fa377dcaa19e6b4014cf1706d5d.tar.bz2
gentoo-2-3587b0466e437fa377dcaa19e6b4014cf1706d5d.zip
Remove VIDEO_TUNER, VIDEO_TVEEPROM options since they are unselectable, and replace with VIDEO_CX88
(Portage version: 2.1.2_rc4-r6)
Diffstat (limited to 'media-tv/ivtv/ivtv-0.8.2-r1.ebuild')
-rw-r--r--media-tv/ivtv/ivtv-0.8.2-r1.ebuild78
1 files changed, 78 insertions, 0 deletions
diff --git a/media-tv/ivtv/ivtv-0.8.2-r1.ebuild b/media-tv/ivtv/ivtv-0.8.2-r1.ebuild
new file mode 100644
index 000000000000..c2be89f1c3b8
--- /dev/null
+++ b/media-tv/ivtv/ivtv-0.8.2-r1.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-tv/ivtv/ivtv-0.8.2-r1.ebuild,v 1.1 2007/01/08 02:39:46 beandog Exp $
+
+inherit eutils linux-mod
+
+DESCRIPTION="ivtv driver for Hauppauge PVR PCI cards"
+HOMEPAGE="http://www.ivtvdriver.org"
+SRC_URI="http://dl.ivtvdriver.org/ivtv/archive/0.8.x/${P}.tar.gz"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="fbcon"
+
+RDEPEND="sys-apps/hotplug-base"
+DEPEND="app-arch/unzip"
+PDEPEND="media-tv/pvr-firmware"
+
+pkg_setup() {
+
+ MODULE_NAMES="ivtv(extra:${S}/driver)
+ saa717x(extra:${S}/i2c-drivers)"
+ BUILD_TARGETS="all"
+ CONFIG_CHECK="EXPERIMENTAL KMOD VIDEO_DEV I2C VIDEO_V4L1_COMPAT VIDEO_V4L2
+ FW_LOADER VIDEO_CX88 VIDEO_WM8775 VIDEO_MSP3400 VIDEO_CX25840
+ VIDEO_SAA711X VIDEO_CX2341X VIDEO_SAA7127"
+
+ if use fbcon; then
+ MODULE_NAMES="${MODULE_NAMES} ivtv-fb(extra:${S}/driver)"
+ CONFIG_CHECK="${CONFIG_CHECK} FB"
+ fi
+
+ if ! kernel_is 2 6 18; then
+ eerror "Each IVTV driver branch will only work with a specific"
+ eerror "linux kernel branch."
+ eerror ""
+ eerror "You will need to either:"
+ eerror "a) emerge a different kernel"
+ eerror "b) emerge a different driver"
+ eerror ""
+ eerror "ivtv branch <--> kernel branch"
+ eerror "0.8.x <--> 2.6.18.x"
+ eerror "0.7.x <--> 2.6.17.x"
+ eerror "0.6.x <--> 2.6.16.x"
+ eerror "0.4.x <--> 2.6.15.x"
+ eerror ""
+ eerror "See http://ivtvdriver.org/ for more information"
+ die "This only works on 2.6.18 kernels"
+ fi
+
+ linux-mod_pkg_setup
+
+ BUILD_PARAMS="KDIR=${KV_DIR}"
+}
+
+src_compile() {
+
+ cd "${S}/driver"
+ linux-mod_src_compile || die "failed to build driver"
+
+ cd "${S}/utils"
+ emake INCDIR="${KV_DIR}/include" || die "failed to build utils "
+}
+
+src_install() {
+ cd "${S}/utils"
+ make DESTDIR="${D}" PREFIX="/usr" install || die "failed to install utils"
+
+ cd "${S}"
+ dodoc README doc/* utils/README.X11
+
+ cd "${S}/driver"
+ linux-mod_src_install || die "failed to install modules"
+
+ # Add the aliases
+ insinto /etc/modules.d
+ newins "${FILESDIR}"/ivtv ivtv
+}