summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Schwarzott <zzam@gentoo.org>2005-10-09 12:29:17 +0000
committerMatthias Schwarzott <zzam@gentoo.org>2005-10-09 12:29:17 +0000
commit61eb006c4562337e743f6f0c62ada838264c4867 (patch)
tree296ed759ecd4e69621f231cb449ff221ac8bc9af /media-tv/xawtv
parenttrim whitespace; fix IUSE (diff)
downloadgentoo-2-61eb006c4562337e743f6f0c62ada838264c4867.tar.gz
gentoo-2-61eb006c4562337e743f6f0c62ada838264c4867.tar.bz2
gentoo-2-61eb006c4562337e743f6f0c62ada838264c4867.zip
Enable compilation with USE=-X. See Bug #98797.
(Portage version: 2.0.51.22-r3)
Diffstat (limited to 'media-tv/xawtv')
-rw-r--r--media-tv/xawtv/ChangeLog6
-rw-r--r--media-tv/xawtv/files/xawtv-3.94-no-x11.patch20
-rw-r--r--media-tv/xawtv/xawtv-3.94-r2.ebuild41
3 files changed, 52 insertions, 15 deletions
diff --git a/media-tv/xawtv/ChangeLog b/media-tv/xawtv/ChangeLog
index 85b648a674a1..f7cdbf7cabf8 100644
--- a/media-tv/xawtv/ChangeLog
+++ b/media-tv/xawtv/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-tv/xawtv
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/xawtv/ChangeLog,v 1.27 2005/09/15 20:10:18 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/xawtv/ChangeLog,v 1.28 2005/10/09 12:29:17 zzam Exp $
+
+ 09 Oct 2005; Matthias Schwarzott <zzam@gentoo.org>
+ +files/xawtv-3.94-no-x11.patch, xawtv-3.94-r2.ebuild:
+ Enable compilation with USE=-X. See Bug #98797.
15 Sep 2005; Aron Griffis <agriffis@gentoo.org> xawtv-3.94-r1.ebuild:
Mark 3.94-r1 stable on alpha
diff --git a/media-tv/xawtv/files/xawtv-3.94-no-x11.patch b/media-tv/xawtv/files/xawtv-3.94-no-x11.patch
new file mode 100644
index 000000000000..d91c398e2806
--- /dev/null
+++ b/media-tv/xawtv/files/xawtv-3.94-no-x11.patch
@@ -0,0 +1,20 @@
+--- xawtv-3.94/common/midictrl.c.orig 2005-07-09 15:58:53.000000000 +0200
++++ xawtv-3.94/common/midictrl.c 2005-07-09 15:59:02.000000000 +0200
+@@ -6,7 +6,6 @@
+ #include <stdlib.h>
+ #include <unistd.h>
+ #include <pthread.h>
+-#include <X11/Intrinsic.h>
+
+ #include "grab-ng.h"
+ #include "commands.h"
+--- xawtv-3.94/common/vbi-data.c.orig 2005-07-09 15:58:53.000000000 +0200
++++ xawtv-3.94/common/vbi-data.c 2005-07-09 15:59:02.000000000 +0200
+@@ -6,7 +6,6 @@
+ #include <assert.h>
+ #include <pthread.h>
+
+-#include <X11/Intrinsic.h>
+
+ #include "vbi-data.h"
+ #include "vbi-sim.h"
diff --git a/media-tv/xawtv/xawtv-3.94-r2.ebuild b/media-tv/xawtv/xawtv-3.94-r2.ebuild
index 96bbaca89fc9..88eb8a464d3b 100644
--- a/media-tv/xawtv/xawtv-3.94-r2.ebuild
+++ b/media-tv/xawtv/xawtv-3.94-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/xawtv/xawtv-3.94-r2.ebuild,v 1.4 2005/08/16 19:16:52 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/xawtv/xawtv-3.94-r2.ebuild,v 1.5 2005/10/09 12:29:17 zzam Exp $
inherit virtualx eutils font
@@ -11,7 +11,7 @@ MY_FONT=tv-fonts-1.0
DESCRIPTION="TV application for the bttv driver"
HOMEPAGE="http://bytesex.org/xawtv/"
SRC_URI="http://dl.bytesex.org/releases/xawtv/${P}.tar.gz
- http://dl.bytesex.org/releases/tv-fonts/${MY_FONT}.tar.bz2
+ X? ( http://dl.bytesex.org/releases/tv-fonts/${MY_FONT}.tar.bz2 )
mirror://gentoo/${MY_PATCH}"
SLOT="0"
@@ -37,10 +37,17 @@ DEPEND=">=sys-libs/ncurses-5.1
sys-devel/automake
sys-devel/libtool"
+pkg_setup() {
+ if use X; then
+ font_pkg_setup
+ fi
+}
+
src_unpack() {
unpack ${A}
epatch ${FILESDIR}/${P}-allow-xlibs-in-normal-search-path.patch
epatch ${FILESDIR}/${P}-gcc4.patch
+ epatch ${FILESDIR}/${P}-no-x11.patch
cd ${S}
autoreconf || "reconf failed"
}
@@ -63,8 +70,10 @@ src_compile() {
emake || die "Make failed"
- cd ${WORKDIR}/${MY_FONT}
- DISPLAY="" Xmake || die "tvfonts failed"
+ if use X; then
+ cd ${WORKDIR}/${MY_FONT}
+ DISPLAY="" Xmake || die "tvfonts failed"
+ fi
}
src_install() {
@@ -72,7 +81,7 @@ src_install() {
make install DESTDIR=${D} resdir=${D}/etc/X11 || die "make install failed"
dodoc COPYING Changes README* TODO ${FILESDIR}/webcamrc
- dointo cgi-bin
+ insinto cgi-bin
dodoc scripts/webcam.cgi
use X || use xv || \
@@ -96,17 +105,21 @@ src_install() {
mv ${D}/usr/share/*.list ${D}/usr/share/${PN}
mv ${D}/usr/share/Index* ${D}/usr/share/${PN}
- cd ${WORKDIR}/${MY_FONT}
- insinto /usr/share/fonts/xawtv
- doins *.gz fonts.alias
+ if use X; then
+ cd ${WORKDIR}/${MY_FONT}
+ insinto /usr/share/fonts/xawtv
+ doins *.gz fonts.alias
- font_xfont_config
- font_xft_config
+ font_xfont_config
+ font_xft_config
+ fi
}
pkg_postinst() {
- ebegin "installing teletype fonts into /usr/share/fonts/xawtv"
- cd /usr/share/fonts/xawtv
- mkfontdir
- eend
+ if use X; then
+ ebegin "installing teletype fonts into /usr/share/fonts/xawtv"
+ cd /usr/share/fonts/xawtv
+ mkfontdir
+ eend
+ fi
}