summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-08-08 22:28:37 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-08-08 22:28:37 +0000
commit7403cdb767f94cf754899f5e865dfb1de2e4b6cc (patch)
tree795cb7dda5652aff53cfd0fc58804e50168f1f52 /media-tv
parentFix building with GLIBC 2.10+ wrt #272517. (diff)
downloadgentoo-2-7403cdb767f94cf754899f5e865dfb1de2e4b6cc.tar.gz
gentoo-2-7403cdb767f94cf754899f5e865dfb1de2e4b6cc.tar.bz2
gentoo-2-7403cdb767f94cf754899f5e865dfb1de2e4b6cc.zip
Fix building with GLIBC 2.10+ wrt #275119, thanks to Markus Rathgeb for patch.
(Portage version: 2.2_rc36/cvs/Linux x86_64)
Diffstat (limited to 'media-tv')
-rw-r--r--media-tv/tvtime/ChangeLog9
-rw-r--r--media-tv/tvtime/files/tvtime-1.0.2-glibc-2.10.patch24
-rw-r--r--media-tv/tvtime/tvtime-1.0.2-r2.ebuild7
3 files changed, 35 insertions, 5 deletions
diff --git a/media-tv/tvtime/ChangeLog b/media-tv/tvtime/ChangeLog
index e113ea42f59c..7ab9f310dae9 100644
--- a/media-tv/tvtime/ChangeLog
+++ b/media-tv/tvtime/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-tv/tvtime
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/tvtime/ChangeLog,v 1.43 2007/11/27 10:46:09 zzam Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-tv/tvtime/ChangeLog,v 1.44 2009/08/08 22:28:37 ssuominen Exp $
+
+ 08 Aug 2009; Samuli Suominen <ssuominen@gentoo.org>
+ tvtime-1.0.2-r2.ebuild, +files/tvtime-1.0.2-glibc-2.10.patch:
+ Fix building with GLIBC 2.10+ wrt #275119, thanks to Markus Rathgeb for
+ patch.
27 Nov 2007; Matthias Schwarzott <zzam@gentoo.org> tvtime-1.0.2.ebuild,
tvtime-1.0.2-r1.ebuild, tvtime-1.0.2-r2.ebuild:
diff --git a/media-tv/tvtime/files/tvtime-1.0.2-glibc-2.10.patch b/media-tv/tvtime/files/tvtime-1.0.2-glibc-2.10.patch
new file mode 100644
index 000000000000..c3d8ad87d733
--- /dev/null
+++ b/media-tv/tvtime/files/tvtime-1.0.2-glibc-2.10.patch
@@ -0,0 +1,24 @@
+diff -Naur tvtime-1.0.2.org/src/xmltv.c tvtime-1.0.2/src/xmltv.c
+--- tvtime-1.0.2.org/src/xmltv.c 2009-07-02 21:48:49.426191088 +0200
++++ tvtime-1.0.2/src/xmltv.c 2009-07-02 21:50:20.842066085 +0200
+@@ -118,9 +118,9 @@
+ typedef struct {
+ const char *code;
+ const char *name;
+-} locale_t;
++} tvtime_locale_t;
+
+-static locale_t locale_table[] = {
++static tvtime_locale_t locale_table[] = {
+ {"AA", "Afar"}, {"AB", "Abkhazian"}, {"AF", "Afrikaans"},
+ {"AM", "Amharic"}, {"AR", "Arabic"}, {"AS", "Assamese"},
+ {"AY", "Aymara"}, {"AZ", "Azerbaijani"}, {"BA", "Bashkir"},
+@@ -168,7 +168,7 @@
+ {"XH", "Xhosa"}, {"YO", "Yoruba"}, {"ZH", "Chinese"},
+ {"ZU", "Zulu"} };
+
+-const int num_locales = sizeof( locale_table ) / sizeof( locale_t );
++const int num_locales = sizeof( locale_table ) / sizeof( tvtime_locale_t );
+
+ /**
+ * Timezone parsing code based loosely on the algorithm in
diff --git a/media-tv/tvtime/tvtime-1.0.2-r2.ebuild b/media-tv/tvtime/tvtime-1.0.2-r2.ebuild
index 32461053099d..80aaecac66c3 100644
--- a/media-tv/tvtime/tvtime-1.0.2-r2.ebuild
+++ b/media-tv/tvtime/tvtime-1.0.2-r2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/tvtime/tvtime-1.0.2-r2.ebuild,v 1.2 2007/11/27 10:46:09 zzam Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/tvtime/tvtime-1.0.2-r2.ebuild,v 1.3 2009/08/08 22:28:37 ssuominen Exp $
WANT_AUTOMAKE=1.7
WANT_AUTOCONF=2.5
@@ -39,7 +39,8 @@ src_unpack() {
unpack ${A}
cd "${S}"
- epatch "${FILESDIR}"/tvtime-1.0.2-gcc41.patch
+ epatch "${FILESDIR}"/${P}-gcc41.patch
+ epatch "${FILESDIR}"/${P}-glibc-2.10.patch
# use 'tvtime' for the application icon see bug #66293
sed -i -e "s/tvtime.png/tvtime/" docs/net-tvtime.desktop