summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohann Schmitz <ercpe@gentoo.org>2014-07-12 07:47:22 +0000
committerJohann Schmitz <ercpe@gentoo.org>2014-07-12 07:47:22 +0000
commitbaa3f5cf06bb819e740d5e3f3f75f4fac5edbdc2 (patch)
tree38700c736909bbef2a62d5da84af3f517eab1bcf /media-tv
parentNew ebuild for texthyphj (dependency of tvbrowser) (diff)
downloadgentoo-2-baa3f5cf06bb819e740d5e3f3f75f4fac5edbdc2.tar.gz
gentoo-2-baa3f5cf06bb819e740d5e3f3f75f4fac5edbdc2.tar.bz2
gentoo-2-baa3f5cf06bb819e740d5e3f3f75f4fac5edbdc2.zip
Version bump of tvbrowser (bug #476594); based on work of Jeroen Roovers
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 77C501ED)
Diffstat (limited to 'media-tv')
-rw-r--r--media-tv/tvbrowser/ChangeLog10
-rw-r--r--media-tv/tvbrowser/files/3.4-build.xml.patch150
-rw-r--r--media-tv/tvbrowser/files/3.4-remove-registrykey.patch154
-rw-r--r--media-tv/tvbrowser/tvbrowser-3.4.ebuild98
4 files changed, 410 insertions, 2 deletions
diff --git a/media-tv/tvbrowser/ChangeLog b/media-tv/tvbrowser/ChangeLog
index 569a841eef1a..5a435becd46f 100644
--- a/media-tv/tvbrowser/ChangeLog
+++ b/media-tv/tvbrowser/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-tv/tvbrowser
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/tvbrowser/ChangeLog,v 1.38 2013/08/16 13:06:46 tomwij Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-tv/tvbrowser/ChangeLog,v 1.39 2014/07/12 07:47:22 ercpe Exp $
+
+*tvbrowser-3.4 (12 Jul 2014)
+
+ 12 Jul 2014; Johann Schmitz <ercpe@gentoo.org> +files/3.4-build.xml.patch,
+ +files/3.4-remove-registrykey.patch, +tvbrowser-3.4.ebuild:
+ Version bump of tvbrowser (bug #476594); based on work of Jeroen Roovers
16 Aug 2013; Tom Wijsman <TomWij@gentoo.org> -tvbrowser-3.2.1.ebuild,
-tvbrowser-3.2.ebuild:
diff --git a/media-tv/tvbrowser/files/3.4-build.xml.patch b/media-tv/tvbrowser/files/3.4-build.xml.patch
new file mode 100644
index 000000000000..a1d6db698d22
--- /dev/null
+++ b/media-tv/tvbrowser/files/3.4-build.xml.patch
@@ -0,0 +1,150 @@
+diff --git a/tvbrowser-3.4/build.xml b/tvbrowser-3.4/build.xml
+index 2073823..615f576 100644
+--- a/tvbrowser-3.4/build.xml
++++ b/tvbrowser-3.4/build.xml
+@@ -104,31 +104,6 @@
+ |
+ - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -->
+
+- <!-- Creates an .app file for Mac OS X (http://informagen.com/JarBundler/) -->
+- <taskdef name="jarbundler"
+- classpath="deployment/macosx/jarbundler-2.0.0.jar"
+- classname="net.sourceforge.jarbundler.JarBundler" />
+-
+- <!-- Creates a Windows Executable using launch4j (http://launch4j.sf.net) -->
+- <taskdef name="launch4j"
+- classname="net.sf.launch4j.ant.Launch4jTask"
+- classpath="${deployment.dir}/win/launch4j/launch4j.jar:${deployment.dir}/win/launch4j/lib/xstream.jar" />
+-
+- <!-- Creates a linux desktopEntry-->
+- <taskdef name="desktopEntry"
+- classname="com.googlecode.ant_deb_task.DesktopEntry"
+- classpathref="ant-deb.classpath"/>
+-
+- <!-- Creates an Ubuntu package-->
+- <taskdef name="deb"
+- classname="com.googlecode.ant_deb_task.Deb"
+- classpathref="ant-deb.classpath"/>
+-
+- <!-- Creates a RedHad package-->
+- <taskdef name="rrpm"
+- classname="org.redline_rpm.RedlineTask"
+- classpathref="ant-rpm.classpath"/>
+-
+ <!-- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
+ |
+ | Display all targets
+@@ -304,6 +279,7 @@
+ <echo message="Creating the jars ..."/>
+
+ <!-- Extract the libraries for the tvbrowser.jar into the temp.dir -->
++ <!--
+ <unjar src="${lib.dir}/${lib.skinlf.name}-${lib.skinlf.version}.jar" dest="${unpacked.dir}/${lib.skinlf.name}.jar"/>
+ <unjar src="${lib.dir}/${lib.bsh.name}-${lib.bsh.version}.jar" dest="${unpacked.dir}/${lib.bsh.name}.jar"/>
+ <unjar src="${lib.dir}/${lib.jgoodies-common.name}-${lib.jgoodies-common.version}.jar" dest="${unpacked.dir}/${lib.jgoodies-common.name}.jar"/>
+@@ -318,6 +294,7 @@
+ <unjar src="${lib.dir}/${lib.texhyphj.name}-${lib.texhyphj.version}.jar" dest="${unpacked.dir}/${lib.texhyphj.name}.jar" />
+ <unjar src="${lib.dir}/${lib.substance.name}-${lib.substance.version}.jar" dest="${unpacked.dir}/${lib.substance.name}.jar" />
+ <unjar src="${lib.dir}/${lib.trident.name}-${lib.trident.version}.jar" dest="${unpacked.dir}/${lib.trident.name}.jar" />
++ -->
+
+ <!-- Pack the tvbrowser.jar -->
+ <jar jarfile="${tvbrowser-default.runtime.dir}/tvbrowser.jar"
+@@ -333,6 +310,7 @@
+ <fileset dir="${classes.dir}" includes="util/**"/>
+ <fileset dir="${classes.dir}" includes="com/**"/>
+ <fileset dir="${classes.dir}/imgs" includes="splash.png"/>
++ <!--
+ <fileset dir="${unpacked.dir}/${lib.skinlf.name}.jar" includes="com/**"/>
+ <fileset dir="${unpacked.dir}/${lib.skinlf.name}.jar" includes="org/**"/>
+ <fileset dir="${unpacked.dir}/${lib.bsh.name}.jar" includes="bsh/**"/>
+@@ -348,6 +326,7 @@
+ <fileset dir="${unpacked.dir}/${lib.texhyphj.name}.jar" includes="net/**"/>
+ <fileset dir="${unpacked.dir}/${lib.substance.name}.jar" includes="org/**"/>
+ <fileset dir="${unpacked.dir}/${lib.trident.name}.jar" includes="org/**"/>
++ -->
+ </jar>
+
+ <!-- Copy the other stuff -->
+@@ -406,8 +385,9 @@
+
+ <!-- Extract the libraries for the tvbrowser.jar into the temp.dir -->
+ <mkdir dir="${unpacked.dir}/${lib.commons.net.name}.jar"/>
++ <!--
+ <unjar src="${lib.dir}/${lib.commons.net.name}-${lib.commons.net.version}.jar" dest="${unpacked.dir}/${lib.commons.net.name}.jar"/>
+-
++-->
+ </target>
+
+
+@@ -446,7 +426,7 @@
+
+ <!-- Creates the runtime folder for the Mac platform -->
+ <target name="runtime-mac" depends="clean-mac, make-mac, runtime, test">
+-
++<!--
+ <delete dir="${tvbrowser-mac.runtime.dir}"/>
+ <mkdir dir="${tvbrowser-mac.runtime.dir}"/>
+
+@@ -477,11 +457,12 @@
+ <copy todir="${tvbrowser-mac.runtime.dir}/TV-Browser.app/Contents/Resources">
+ <fileset dir="${deployment.dir}" includes="osx.properties"/>
+ </copy>
+-
++-->
+ </target>
+
+ <!-- Creates the desktop entry file for Linux platforms -->
+ <target name="tvbrowser-desktop-entry">
++ <!--
+ <desktopEntry
+ toFile="${tvbrowser-linux.runtime.dir}/tvbrowser.desktop"
+ name="TV-Browser"
+@@ -498,10 +479,12 @@
+ <comment lang="de" value="Anpassbare und einfach zu benutzende TV-Zeitschrift - geschrieben in Java"/>
+ </desktopEntry>
+ <echo file="${tvbrowser-linux.runtime.dir}/tvbrowser.desktop" append="true">StartupWMClass=tvbrowser-TVBrowser</echo>
++ -->
+ </target>
+
+ <!-- Creates the desktop entry file for Ubuntu platform -->
+ <target name="tvbrowser-desktop-entry-deb">
++ <!--
+ <desktopEntry
+ toFile="${tvbrowser-linux.runtime.dir}/tvbrowser.desktop"
+ name="${programname}"
+@@ -518,6 +501,7 @@
+ <comment lang="de" value="Anpassbare und einfach zu benutzende TV-Zeitschrift - geschrieben in Java"/>
+ </desktopEntry>
+ <echo file="${tvbrowser-linux.runtime.dir}/tvbrowser.desktop" append="true">StartupWMClass=tvbrowser-TVBrowser</echo>
++ -->
+ </target>
+
+ <!-- Creates the runtime folder for linux platforms -->
+@@ -673,6 +657,7 @@
+
+ <!-- Creates the windows exe file -->
+ <target name="exe" depends="runtime-win">
++ <!--
+ <launch4j configFile="${deployment.dir}/win/launch4j/tvbrowser.xml"
+ fileversion="${tvbrowser.version.file}"
+ productversion="${tvbrowser.version.file}"
+@@ -683,15 +668,18 @@
+ productversion="${tvbrowser.version.file}"
+ txtfileversion="${tvbrowser.version}"
+ txtproductversion="${tvbrowser.version}"/>
++ -->
+ </target>
+
+ <!-- Creates the windows transportable exe file -->
+ <target name="transportable-exe" depends="runtime-transportable">
++ <!--
+ <launch4j configFile="${deployment.dir}/win/launch4j/tvbrowser-transportable.xml"
+ fileversion="${tvbrowser.version.file}"
+ productversion="${tvbrowser.version.file}"
+ txtfileversion="${tvbrowser.version}"
+ txtproductversion="${tvbrowser.version}"/>
++ -->
+ </target>
+
+ <!-- Creates the release binaries (.exe installer) for windows platforms -->
diff --git a/media-tv/tvbrowser/files/3.4-remove-registrykey.patch b/media-tv/tvbrowser/files/3.4-remove-registrykey.patch
new file mode 100644
index 000000000000..e886aaf22d1f
--- /dev/null
+++ b/media-tv/tvbrowser/files/3.4-remove-registrykey.patch
@@ -0,0 +1,154 @@
+diff --git a/tvbrowser-3.4/src/tvbrowser/TVBrowser.java b/tvbrowser-3.4/src/tvbrowser/TVBrowser.java
+index 1aaedb5..51558be 100644
+--- a/tvbrowser-3.4/src/tvbrowser/TVBrowser.java
++++ b/tvbrowser-3.4/src/tvbrowser/TVBrowser.java
+@@ -113,9 +113,6 @@ import util.ui.Localizer;
+ import util.ui.UIThreadRunner;
+ import util.ui.UiUtilities;
+ import util.ui.textcomponentpopup.TextComponentPopupEventQueue;
+-import ca.beq.util.win32.registry.RegistryKey;
+-import ca.beq.util.win32.registry.RegistryValue;
+-import ca.beq.util.win32.registry.RootKey;
+
+ import com.jgoodies.looks.LookUtils;
+ import com.l2fprod.gui.plaf.skin.SkinLookAndFeel;
+@@ -575,77 +572,6 @@ public class TVBrowser {
+ public void run() {
+ ChannelList.completeChannelLoading();
+ initializeAutomaticDownload();
+- if (Launch.isOsWindowsNtBranch()) {
+- try {
+- RegistryKey desktopSettings = new RegistryKey(
+- RootKey.HKEY_CURRENT_USER, "Control Panel\\Desktop");
+- RegistryValue autoEnd = desktopSettings
+- .getValue("AutoEndTasks");
+-
+- if (autoEnd.getData().equals("1")) {
+- RegistryValue killWait = desktopSettings
+- .getValue("WaitToKillAppTimeout");
+-
+- int i = Integer.parseInt(killWait.getData().toString());
+-
+- if (i < 5000) {
+- JOptionPane pane = new JOptionPane();
+-
+- String cancel = mLocalizer.msg("registryCancel",
+- "Close TV-Browser");
+- String dontDoIt = mLocalizer.msg("registryJumpOver",
+- "Not this time");
+-
+- pane.setOptions(new String[] {
+- Localizer.getLocalization(Localizer.I18N_OK), dontDoIt,
+- cancel });
+- pane.setOptionType(JOptionPane.YES_NO_CANCEL_OPTION);
+- pane.setMessageType(JOptionPane.WARNING_MESSAGE);
+- pane
+- .setMessage(mLocalizer
+- .msg(
+- "registryWarning",
+- "The fast shutdown of Windows is activated.\nThe timeout to wait for before Windows is closing an application is too short,\nto give TV-Browser enough time to save all settings.\n\nThe setting hasn't the default value. It was changed by a tool or by you.\nTV-Browser will now try to change the timeout.\n\nIf you don't want to change this timeout select 'Not this time' or 'Close TV-Browser'."));
+-
+- pane.setInitialValue(mLocalizer.msg("registryCancel",
+- "Close TV-Browser"));
+-
+- JDialog d = pane.createDialog(UiUtilities
+- .getLastModalChildOf(mainFrame), UIManager
+- .getString("OptionPane.messageDialogTitle"));
+- d.setModal(true);
+- UiUtilities.centerAndShow(d);
+-
+- if (pane.getValue() == null
+- || pane.getValue().equals(cancel)) {
+- mainFrame.quit();
+- } else if (!pane.getValue().equals(dontDoIt)) {
+- try {
+- killWait.setData("5000");
+- desktopSettings.setValue(killWait);
+- JOptionPane
+- .showMessageDialog(
+- UiUtilities.getLastModalChildOf(mainFrame),
+- mLocalizer
+- .msg("registryChanged",
+- "The timeout was changed successfully.\nPlease reboot Windows!"));
+- } catch (Exception registySetting) {
+- JOptionPane
+- .showMessageDialog(
+- UiUtilities.getLastModalChildOf(mainFrame),
+- mLocalizer
+- .msg(
+- "registryNotChanged",
+- "<html>The Registry value couldn't be changed. Maybe you haven't the right to do it.<br>If it is so contact you Administrator and let him do it for you.<br><br><b><Attention:/b> The following description is for experts. If you change or delete the wrong value in the Registry you could destroy your Windows installation.<br><br>To get no warning on TV-Browser start the Registry value <b>WaitToKillAppTimeout</b> in the Registry path<br><b>HKEY_CURRENT_USER\\Control Panel\\Desktop</b> have to be at least <b>5000</b> or the value for <b>AutoEndTasks</b> in the same path have to be <b>0</b>.</html>"),
+- Localizer.getLocalization(Localizer.I18N_ERROR),
+- JOptionPane.ERROR_MESSAGE);
+- }
+- }
+- }
+- }
+- } catch (Throwable registry) {
+- }
+- }
+
+ if (currentVersion != null
+ && currentVersion.compareTo(new Version(2, 71, false)) < 0) {
+diff --git a/tvbrowser-3.4/src/tvbrowser/ui/settings/StartupSettingsTab.java b/tvbrowser-3.4/src/tvbrowser/ui/settings/StartupSettingsTab.java
+index fa90661..fe13256 100644
+--- a/tvbrowser-3.4/src/tvbrowser/ui/settings/StartupSettingsTab.java
++++ b/tvbrowser-3.4/src/tvbrowser/ui/settings/StartupSettingsTab.java
+@@ -50,8 +50,6 @@ import tvbrowser.ui.mainframe.MainFrame;
+ import tvbrowser.ui.mainframe.PeriodItem;
+ import util.ui.Localizer;
+ import util.ui.UiUtilities;
+-import ca.beq.util.win32.registry.RegistryKey;
+-import ca.beq.util.win32.registry.RootKey;
+
+ import com.jgoodies.forms.builder.PanelBuilder;
+ import com.jgoodies.forms.factories.Borders;
+@@ -163,41 +161,6 @@ public class StartupSettingsTab implements devplugin.SettingsTab {
+ .getBoolean());
+ mSettingsPn.add(mShowStartScreenChB, cc.xy(2, ++y));
+
+- if (System.getProperty("os.name").toLowerCase().startsWith("windows") && !TVBrowser.isTransportable()) {
+- layout.insertRow(++y, RowSpec.decode("1dlu"));
+- layout.insertRow(++y, RowSpec.decode("pref"));
+-
+- try {
+- RegistryKey shellFolders = new RegistryKey(RootKey.HKEY_CURRENT_USER, "SOFTWARE\\Microsoft\\Windows\\CurrentVersion\\Explorer\\Shell Folders");
+- String path = shellFolders.getValue("Startup").getData().toString();
+-
+- if(path == null || path.length() < 1 || !(new File(path)).isDirectory()) {
+- throw new Exception();
+- }
+-
+- mLinkFileFile = new File(path,"TV-Browser.url");
+-
+- try {
+- mLinkFile = new LinkFile(mLinkFileFile);
+-
+- if(mLinkFileFile.isFile()) {
+- try {
+- if (!mLinkFile.hasTarget((new File("tvbrowser.exe")).getAbsoluteFile())) {
+- createLink(mLinkFile);
+- }
+- }catch(Exception linkException) {
+- mLinkFileFile.delete();
+- }
+- }
+- }catch(FileNotFoundException fe) {}
+-
+- mAutostartWithWindows = new JCheckBox(mLocalizer.msg("autostart","Start TV-Browser with Windows"),
+- mLinkFileFile.isFile());
+-
+- mSettingsPn.add(mAutostartWithWindows, cc.xy(2, y));
+- } catch (Throwable e) {e.printStackTrace();}
+- }
+-
+ y++;
+
+ mSettingsPn.add(createRefreshPanel(), cc.xyw(1,++y,5));
+@@ -513,4 +476,4 @@ public class StartupSettingsTab implements devplugin.SettingsTab {
+ return new File(mTarget).equals(file);
+ }
+ }
+-}
+\ No newline at end of file
++}
diff --git a/media-tv/tvbrowser/tvbrowser-3.4.ebuild b/media-tv/tvbrowser/tvbrowser-3.4.ebuild
new file mode 100644
index 000000000000..ddd0a04c6eb2
--- /dev/null
+++ b/media-tv/tvbrowser/tvbrowser-3.4.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-tv/tvbrowser/tvbrowser-3.4.ebuild,v 1.1 2014/07/12 07:47:22 ercpe Exp $
+
+EAPI="5"
+
+JAVA_PKG_IUSE="doc source test"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="Themeable and easy to use TV Guide - written in Java."
+HOMEPAGE="http://www.tvbrowser.org/"
+SRC_URI="mirror://sourceforge/${PN}/${P/-/_}_src.zip"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+LICENSE="GPL-3"
+IUSE=""
+
+COMMON_DEP="dev-java/bsh:0
+ dev-java/commons-codec:0
+ dev-java/commons-lang:3.1
+ dev-java/commons-net:0
+ dev-java/jakarta-oro:2.0
+ dev-java/jgoodies-common:1.8
+ dev-java/jgoodies-forms:1.8
+ dev-java/jgoodies-looks:2.6
+ dev-java/l2fprod-common:0
+ dev-java/htmlparser-org:0
+ dev-java/log4j:0
+ dev-java/skinlf:0
+ dev-java/stax:0
+ dev-java/xalan:0
+ dev-java/opencsv:0
+ dev-java/texhyphj:0
+ dev-java/trident:0
+ x11-libs/libXt
+ x11-libs/libSM
+ x11-libs/libICE
+ x11-libs/libXext
+ x11-libs/libXtst
+ x11-libs/libX11
+ x11-libs/libXau
+ x11-libs/libXdmcp"
+
+DEPEND="${COMMON_DEP}
+ app-arch/unzip
+ >=virtual/jdk-1.6"
+RDEPEND="${COMMON_DEP}
+ >=virtual/jre-1.6"
+
+java_prepare() {
+ epatch "${FILESDIR}"/${PV}-*.patch
+
+ rm -v lib/{bsh-,commons,jgoodies,l2fprod-common-tasks,skinlf,stax,htmlparser,opencsv,trident,texhyphj,jRegistryKey}*.jar
+
+ find deployment -name '*.jar' -delete || die
+ find . -name '*.class' -delete || die
+}
+
+JAVA_ANT_REWRITE_CLASSPATH="true"
+EANT_GENTOO_CLASSPATH="bsh
+ commons-codec
+ commons-lang-3.1
+ jgoodies-common-1.8
+ jgoodies-forms-1.8
+ jgoodies-looks-2.6
+ l2fprod-common
+ skinlf
+ htmlparser-org
+ opencsv
+ texhyphj"
+EANT_BUILD_TARGET="runtime-linux"
+EANT_DOC_TARGET="public-doc"
+
+src_install() {
+ java-pkg_dojar runtime/${PN}_linux/${PN}.jar
+ java-pkg_dojar lib/substance-6.1.jar
+ java-pkg_register-dependency trident,opencsv
+
+ insinto /usr/share/${PN}
+ doins -r runtime/${PN}_linux/{imgs,icons,plugins,infothemes}
+ doins runtime/${PN}_linux/linux.properties
+
+ insinto /usr/share/${PN}/themepacks
+ doins themepacks/themepack.zip
+
+ java-pkg_dolauncher "tvbrowser" \
+ --main tvbrowser.TVBrowser \
+ --pwd /usr/share/${PN} \
+ --java_args " -Dpropertiesfile=/usr/share/${PN}/linux.properties"
+
+ make_desktop_entry ${PN} "TV-Browser" \
+ /usr/share/tvbrowser/imgs/tvbrowser128.png "AudioVideo;TV;Video"
+
+ use source && java-pkg_dosrc src/*
+ use doc && java-pkg_dojavadoc doc
+}