summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Ahlberg <aliz@gentoo.org>2003-12-11 21:22:54 +0000
committerDaniel Ahlberg <aliz@gentoo.org>2003-12-11 21:22:54 +0000
commitcd298ec42c55006cec6b3a48f84b525de660c96f (patch)
tree297681afc2c6329672a45a710d9f23976022fc34 /media-tv
parentVersion bumps (diff)
downloadgentoo-2-cd298ec42c55006cec6b3a48f84b525de660c96f.tar.gz
gentoo-2-cd298ec42c55006cec6b3a48f84b525de660c96f.tar.bz2
gentoo-2-cd298ec42c55006cec6b3a48f84b525de660c96f.zip
Version bumps
Diffstat (limited to 'media-tv')
-rw-r--r--media-tv/mythfrontend/ChangeLog7
-rw-r--r--media-tv/mythfrontend/Manifest4
-rw-r--r--media-tv/mythfrontend/files/digest-mythfrontend-0.131
-rw-r--r--media-tv/mythfrontend/mythfrontend-0.13.ebuild100
-rw-r--r--media-tv/mythtv/ChangeLog7
-rw-r--r--media-tv/mythtv/Manifest4
-rw-r--r--media-tv/mythtv/files/digest-mythtv-0.131
-rw-r--r--media-tv/mythtv/mythtv-0.13.ebuild148
-rw-r--r--media-tv/xmltv/Manifest2
-rw-r--r--media-tv/xmltv/files/digest-xmltv-0.5.251
-rw-r--r--media-tv/xmltv/xmltv-0.5.25.ebuild163
11 files changed, 431 insertions, 7 deletions
diff --git a/media-tv/mythfrontend/ChangeLog b/media-tv/mythfrontend/ChangeLog
index e8a3e8e28346..26ee37b1e33d 100644
--- a/media-tv/mythfrontend/ChangeLog
+++ b/media-tv/mythfrontend/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-tv/mythfrontend
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/mythfrontend/ChangeLog,v 1.7 2003/10/28 16:15:15 max Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/mythfrontend/ChangeLog,v 1.8 2003/12/11 21:22:50 aliz Exp $
+
+*mythfrontend-0.13 (11 Dec 2003)
+
+ 11 Dec 2003; Daniel Ahlberg <aliz@gentoo.org> mythtv-0.13.ebuild:
+ Version bump.
28 Oct 2003; Max Kalika <max@gentoo.org> mythfrontend-0.12.ebuild:
Remove DVB depend. Extend CPU detection. Fix potential portage bug in
diff --git a/media-tv/mythfrontend/Manifest b/media-tv/mythfrontend/Manifest
index 2a8438269fc5..a4ed493564d5 100644
--- a/media-tv/mythfrontend/Manifest
+++ b/media-tv/mythfrontend/Manifest
@@ -1,7 +1,7 @@
MD5 c3f67cc91781e0b6358a0a1cf9971157 mythfrontend-0.11.ebuild 1415
-MD5 081ac6f1d465f836b5a9108475cd476f mythfrontend-0.13.ebuild 2808
+MD5 2d320d554a58bb4dbfc1a8153be8f613 mythfrontend-0.13.ebuild 2810
MD5 aed36892462269a8080b52fa26962f65 mythfrontend-0.10.ebuild 1479
-MD5 40f65a16415626a2f9299afa96a4233c ChangeLog 1200
+MD5 cbe2201eaf436b4d1fb30c566e423fc9 ChangeLog 1320
MD5 1b083ee6bfff0d9a00025757e9462061 mythfrontend-0.12.ebuild 2816
MD5 20e2255501865de5b568424821abf69d metadata.xml 161
MD5 e14a28e72b9ac693884dc418dbeef119 files/digest-mythfrontend-0.10 65
diff --git a/media-tv/mythfrontend/files/digest-mythfrontend-0.13 b/media-tv/mythfrontend/files/digest-mythfrontend-0.13
new file mode 100644
index 000000000000..d64835745f92
--- /dev/null
+++ b/media-tv/mythfrontend/files/digest-mythfrontend-0.13
@@ -0,0 +1 @@
+MD5 bdca237336453cf68835063c1a4efa91 mythtv-0.13.tar.bz2 3263341
diff --git a/media-tv/mythfrontend/mythfrontend-0.13.ebuild b/media-tv/mythfrontend/mythfrontend-0.13.ebuild
new file mode 100644
index 000000000000..7a8b94928c1d
--- /dev/null
+++ b/media-tv/mythfrontend/mythfrontend-0.13.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-tv/mythfrontend/mythfrontend-0.13.ebuild,v 1.1 2003/12/11 21:22:50 aliz Exp $
+
+inherit flag-o-matic
+
+DESCRIPTION="Homebrew PVR project frontend."
+HOMEPAGE="http://www.mythtv.org/"
+SRC_URI="http://www.mythtv.org/mc/mythtv-${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="alsa lcd lirc nvidia"
+
+DEPEND="virtual/x11
+ >=x11-libs/qt-3.1
+ >=media-sound/lame-3.93.1
+ >=media-libs/freetype-2.0
+ >=sys-apps/sed-4
+ alsa? ( media-libs/alsa-lib )
+ lcd? ( app-misc/lcdproc )
+ lirc? ( app-misc/lirc )
+ nvidia? ( media-video/nvidia-glx )"
+
+RDEPEND="${DEPEND}
+ !media-tv/mythtv"
+
+S="${WORKDIR}/mythtv-${PV}"
+
+pkg_setup() {
+ local qt_use="$(</var/db/pkg/`best_version x11-libs/qt`/USE)"
+ if [ ! "`has mysql ${qt_use}`" ] ; then
+ eerror "Qt is missing MySQL support. Please add"
+ eerror "'mysql' to your USE flags, and re-emerge Qt."
+ die "Qt needs mysql support"
+ fi
+
+ return 0
+}
+
+src_unpack() {
+ unpack ${A}
+
+ for i in `grep -lr "usr/local" "${S}"` ; do
+ sed -e "s:usr/local:usr:g" -i "${i}" || die "sed failed"
+ done
+}
+
+src_compile() {
+ local cpu="`get-flag march || get-flag mcpu`"
+ if [ "${cpu}" ] ; then
+ sed -e "s:pentiumpro:${cpu}:g" -i "settings.pro" || die "sed failed"
+ fi
+
+ if [ "`use alsa`" ] ; then
+ sed -e "s:#CONFIG += using_alsa:CONFIG += using_alsa:" \
+ -e "s:#ALSA_LIBS = -lasound:ALSA_LIBS = -lasound:" \
+ -i "settings.pro" || die "enable alsa sed failed"
+ fi
+ if [ "`use lcd`" ] ; then
+ sed -e "s:#DEFINES += LCD_DEVICE:DEFINES += LCD_DEVICE:" \
+ -i "settings.pro" || die "enable lcd sed failed"
+ fi
+ if [ "`use lirc`" ] ; then
+ sed -e "s:#CONFIG += using_lirc:CONFIG += using_lirc:" \
+ -e "s:#LIRC_LIBS = -llirc_client:LIRC_LIBS = -llirc_client:" \
+ -i "settings.pro" || die "enable lirc sed failed"
+ fi
+ if [ "`use nvidia`" ] ; then
+ sed -e "s:#CONFIG += using_xvmc:CONFIG += using_xvmc:" \
+ -e "s:#EXTRA_LIBS += -lXvMCNVIDIA:EXTRA_LIBS += -lXvMCNVIDIA:" \
+ -i "settings.pro" || die "enable xvmc sed failed"
+ fi
+ # Needs a VIA supported kernel driver.
+ #if [ "`use via`" ] ; then
+ # sed -e "s:#CONFIG += using_via:CONFIG += using_via:"
+ # -e "s:#EXTRA_LIBS += -lddmpeg:EXTRA_LIBS += -lddmpeg:"
+ # -i "settings.pro" || die "enable lirc sed failed"
+ #fi
+
+ qmake -o "Makefile" "mythtv.pro"
+
+ econf
+ make || die "compile problem"
+}
+
+src_install() {
+ einstall INSTALL_ROOT="${D}"
+
+ dodir /etc/mythtv
+ mv "${D}/usr/share/mythtv/mysql.txt" "${D}/etc/mythtv"
+ dosym /etc/mythtv/mysql.txt /usr/share/mythtv/mysql.txt
+
+ rm -rf "${D}"/usr/bin/myth{backend,commflag,filldatabase,transcode} \
+ "${D}/usr/share/mythtv/setup.xml"
+
+ dodoc AUTHORS COPYING FAQ README UPGRADING keys.txt docs/*.{txt,pdf}
+ dohtml docs/*.html
+}
diff --git a/media-tv/mythtv/ChangeLog b/media-tv/mythtv/ChangeLog
index 16ea12508855..e269a63539e3 100644
--- a/media-tv/mythtv/ChangeLog
+++ b/media-tv/mythtv/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-tv/mythtv
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/mythtv/ChangeLog,v 1.10 2003/12/04 23:16:40 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/mythtv/ChangeLog,v 1.11 2003/12/11 21:22:50 aliz Exp $
+
+*mythtv-0.13 (11 Dec 2003)
+
+ 11 Dec 2003; Daniel Ahlberg <aliz@gentoo.org> mythtv-0.13.ebuild:
+ Version bump.
04 Dec 2003; Michael Sterrett <mr_bones_@gentoo.org> mythtv-0.10.ebuild:
clean old version per max
diff --git a/media-tv/mythtv/Manifest b/media-tv/mythtv/Manifest
index dc0f9f54ddcf..6967292dd2fc 100644
--- a/media-tv/mythtv/Manifest
+++ b/media-tv/mythtv/Manifest
@@ -1,7 +1,7 @@
MD5 a580ceddbe5794beba1e44706de19a02 mythtv-0.12.ebuild 4493
MD5 ff7a010a65450c2f3c3aa1d78c9e3dbb mythtv-0.11.ebuild 2778
-MD5 3380ba4cbb626e17239d8734f631cabd mythtv-0.13.ebuild 4486
-MD5 ede98b1ed78564fdcd599c9b2b44b457 ChangeLog 3732
+MD5 9e7913c1bd9d999c1a33e131766d8e4e mythtv-0.13.ebuild 4487
+MD5 f555753ffc18f69d6e2aa4e929d98c32 ChangeLog 3840
MD5 20e2255501865de5b568424821abf69d metadata.xml 161
MD5 ce8c4dae21199ea11abd156b16cc3b8a files/mythbackend.conf 867
MD5 897368570b822b7a42c9693e16f1f052 files/mythbackend.rc6 1670
diff --git a/media-tv/mythtv/files/digest-mythtv-0.13 b/media-tv/mythtv/files/digest-mythtv-0.13
new file mode 100644
index 000000000000..d64835745f92
--- /dev/null
+++ b/media-tv/mythtv/files/digest-mythtv-0.13
@@ -0,0 +1 @@
+MD5 bdca237336453cf68835063c1a4efa91 mythtv-0.13.tar.bz2 3263341
diff --git a/media-tv/mythtv/mythtv-0.13.ebuild b/media-tv/mythtv/mythtv-0.13.ebuild
new file mode 100644
index 000000000000..10b776c622c7
--- /dev/null
+++ b/media-tv/mythtv/mythtv-0.13.ebuild
@@ -0,0 +1,148 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-tv/mythtv/mythtv-0.13.ebuild,v 1.1 2003/12/11 21:22:50 aliz Exp $
+
+inherit flag-o-matic
+
+DESCRIPTION="Homebrew PVR project."
+HOMEPAGE="http://www.mythtv.org/"
+SRC_URI="http://www.mythtv.org/mc/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="alsa lcd lirc nvidia"
+
+DEPEND="virtual/x11
+ >=x11-libs/qt-3.1
+ >=media-sound/lame-3.93.1
+ >=media-libs/freetype-2.0
+ >=media-tv/xmltv-0.5.16
+ >=sys-apps/sed-4
+ alsa? ( media-libs/alsa-lib )
+ lcd? ( app-misc/lcdproc )
+ lirc? ( app-misc/lirc )
+ nvidia? ( media-video/nvidia-glx )"
+ #dvb? ( media-libs/libdvb )
+
+RDEPEND="${DEPEND}
+ !media-tv/mythfrontend"
+
+pkg_setup() {
+ local qt_use="$(</var/db/pkg/`best_version x11-libs/qt`/USE)"
+ if [ ! "`has mysql ${qt_use}`" ] ; then
+ eerror "Qt is missing MySQL support. Please add"
+ eerror "'mysql' to your USE flags, and re-emerge Qt."
+ die "Qt needs mysql support"
+ fi
+
+ return 0
+}
+
+src_unpack() {
+ unpack ${A}
+
+ for i in `grep -lr "usr/local" "${S}"` ; do
+ sed -e "s:usr/local:usr:g" -i "${i}" || die "sed failed"
+ done
+}
+
+src_compile() {
+ local cpu="`get-flag march || get-flag mcpu`"
+ if [ "${cpu}" ] ; then
+ sed -e "s:pentiumpro:${cpu}:g" -i "settings.pro" || die "sed failed"
+ fi
+
+ if [ "`use alsa`" ] ; then
+ sed -e "s:#CONFIG += using_alsa:CONFIG += using_alsa:" \
+ -e "s:#ALSA_LIBS = -lasound:ALSA_LIBS = -lasound:" \
+ -i "settings.pro" || die "enable alsa sed failed"
+ fi
+ # Not quite ready for prime time.
+ #if [ "`use dvb`" ] ; then
+ # sed -e "s:#CONFIG += using_dvb:CONFIG += using_dvb:" \
+ # -e "s:#DEFINES += USING_DVB:DEFINES += USING_DVB:" \
+ # -e "s:#INCLUDEPATH += /usr/src:INCLUDEPATH += /usr:" \
+ # -i "settings.pro" || die "enable dvb sed failed"
+ #fi
+ if [ "`use lcd`" ] ; then
+ sed -e "s:#DEFINES += LCD_DEVICE:DEFINES += LCD_DEVICE:" \
+ -i "settings.pro" || die "enable lcd sed failed"
+ fi
+ if [ "`use lirc`" ] ; then
+ sed -e "s:#CONFIG += using_lirc:CONFIG += using_lirc:" \
+ -e "s:#LIRC_LIBS = -llirc_client:LIRC_LIBS = -llirc_client:" \
+ -i "settings.pro" || die "enable lirc sed failed"
+ fi
+ if [ "`use nvidia`" ] ; then
+ sed -e "s:#CONFIG += using_xvmc:CONFIG += using_xvmc:" \
+ -e "s:#EXTRA_LIBS += -lXvMCNVIDIA:EXTRA_LIBS += -lXvMCNVIDIA:" \
+ -i "settings.pro" || die "enable xvmc sed failed"
+ fi
+ # Needs a VIA supported kernel driver.
+ #if [ "`use via`" ] ; then
+ # sed -e "s:#CONFIG += using_via:CONFIG += using_via:"
+ # -e "s:#EXTRA_LIBS += -lddmpeg:EXTRA_LIBS += -lddmpeg:"
+ # -i "settings.pro" || die "enable lirc sed failed"
+ #fi
+
+ qmake -o "Makefile" "${PN}.pro"
+
+ econf
+ make || die "compile problem"
+}
+
+src_install() {
+ einstall INSTALL_ROOT="${D}"
+ newbin "setup/setup" "mythsetup"
+
+ dodir /etc/mythtv
+ mv "${D}/usr/share/mythtv/mysql.txt" "${D}/etc/mythtv"
+ dosym /etc/mythtv/mysql.txt /usr/share/mythtv/mysql.txt
+
+ insinto /usr/share/mythtv/database
+ doins database/*
+
+ exeinto /usr/share/mythtv
+ doexe "${FILESDIR}/mythfilldatabase.cron"
+
+ exeinto /etc/init.d
+ newexe "${FILESDIR}/mythbackend.rc6" mythbackend
+ insinto /etc/conf.d
+ newins "${FILESDIR}/mythbackend.conf" mythbackend
+
+ dodoc AUTHORS COPYING FAQ README UPGRADING keys.txt docs/*.{txt,pdf}
+ dohtml docs/*.html
+
+ keepdir /var/{log,run}/mythtv
+}
+
+pkg_postinst() {
+ ewarn "Please note that /usr/share/mythtv/setup has been moved"
+ ewarn "to /usr/bin/mythsetup"
+ echo
+
+ einfo "If this is the first time you install MythTV,"
+ einfo "you need to add /usr/share/mythtv/database/mc.sql"
+ einfo "to your mysql database."
+ einfo
+ einfo "You might run 'mysql < /usr/share/mythtv/database/mc.sql'"
+ einfo
+ einfo "Next, you need to run the mythsetup program."
+ einfo "It will ask you some questions about your hardware, and"
+ einfo "then run xmltv's grabber to configure your channels."
+ einfo
+ einfo "Once you have configured your database, you can run"
+ einfo "/usr/bin/mythfilldatabase to populate the schedule"
+ einfo "or copy /usr/share/mythtv/mythfilldatabase.cron to"
+ einfo "/etc/cron.daily for this to happen automatically."
+ einfo
+ einfo "If you're upgrading from an older version and for more"
+ einfo "setup and usage instructions, please refer to:"
+ einfo " /usr/share/doc/${PF}/README.gz"
+ einfo " /usr/share/doc/${PF}/UPGRADING.gz"
+ ewarn "This part is important as there might be database changes"
+ ewarn "which need to be performed or this package will not work"
+ ewarn "properly."
+ echo
+}
diff --git a/media-tv/xmltv/Manifest b/media-tv/xmltv/Manifest
index 1046f550a692..d442a68e8c53 100644
--- a/media-tv/xmltv/Manifest
+++ b/media-tv/xmltv/Manifest
@@ -1,4 +1,4 @@
-MD5 a50f1b9a0c04b438bd4937384afbc06b xmltv-0.5.25.ebuild 6094
+MD5 40655b67f94b104b47a92f75ce82495d xmltv-0.5.25.ebuild 6095
MD5 7601529043af413db63e1e2f5dce9963 xmltv-0.5.24.ebuild 6087
MD5 7eb0f5ddfbd22ad6ee0fc9762dc35df5 ChangeLog 5131
MD5 20e2255501865de5b568424821abf69d metadata.xml 161
diff --git a/media-tv/xmltv/files/digest-xmltv-0.5.25 b/media-tv/xmltv/files/digest-xmltv-0.5.25
new file mode 100644
index 000000000000..c778c5f529f7
--- /dev/null
+++ b/media-tv/xmltv/files/digest-xmltv-0.5.25
@@ -0,0 +1 @@
+MD5 f254392570c99d77550d93abc770ac4f xmltv-0.5.25.tar.bz2 404386
diff --git a/media-tv/xmltv/xmltv-0.5.25.ebuild b/media-tv/xmltv/xmltv-0.5.25.ebuild
new file mode 100644
index 000000000000..0e8681ccbc42
--- /dev/null
+++ b/media-tv/xmltv/xmltv-0.5.25.ebuild
@@ -0,0 +1,163 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-tv/xmltv/xmltv-0.5.25.ebuild,v 1.1 2003/12/11 21:22:50 aliz Exp $
+
+inherit perl-module
+
+DESCRIPTION="Set of utilities to manage TV listings stored in the XMLTV format."
+HOMEPAGE="http://membled.com/work/apps/xmltv/"
+SRC_URI="mirror://sourceforge/xmltv/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+# NOTE: you can customize the xmltv installation by
+# defining a XMLTV_OPTS variable which contains
+# a space-separated list of optional features.
+# If this variable is unspecified or has an
+# empty value, everything will be *enabled*.
+#
+# none: Don't enable any of the features below
+# tv_grab_de: Germany and Austria listing grabbers
+# tv_grab_uk: Britain listings grabber
+# tv_grab_uk_rt: Alternate Britain listings grabber
+# tv_grab_it: Italy listings grabber
+# tv_grab_na: North America listings grabber
+# tv_grab_sn: Sweden and Norway listings grabber
+# tv_grab_nz: New Zealand listings grabber
+# tv_grab_fi: Finland listings grabber
+# tv_grab_es: Spain listings grabber
+# tv_grab_nl: Netherlands listings grabber
+# tv_grab_nl_wolf: Alternate Netherlands listings grabber
+# tv_grab_hu: Hungary listings grabber
+# tv_grab_dk: Denmark listings grabber
+# tv_check: Graphical front-end for listings data
+# tv_pick_cgi: CGI front-end for listings data
+
+# EXAMPLES:
+# enable just North American grabber
+# XMLTV_OPTS="tv_grab_na"
+#
+# enable graphical front-end, New Zealand and Italy grabbers
+# XMLTV_OPTS="tv_check tv_grab_nz tv_grab_it"
+
+DEPEND=">=sys-apps/sed-4
+ >=dev-perl/libwww-perl-5.65
+ >=dev-perl/XML-Parser-2.34
+ >=dev-perl/XML-Twig-3.09
+ dev-perl/XML-Writer
+ >=dev-perl/DateManip-5.42
+ dev-perl/Memoize
+ >=dev-perl/Term-ProgressBar-2.03
+ dev-perl/Compress-Zlib
+ dev-perl/Lingua-EN-Numbers-Ordinate
+ dev-perl/Lingua-Preferred
+ >=dev-perl/Storable-2.04
+ dev-perl/Unicode-String"
+
+# for tv_check
+DEPEND="${DEPEND} dev-perl/perl-tk dev-perl/Tk-TableMatrix dev-perl/XML-Simple"
+# for tv_grab_na
+DEPEND="${DEPEND} >=dev-perl/HTML-Parser-3.34"
+# for tv_grab_sn
+DEPEND="${DEPEND} >=dev-perl/HTML-TableExtract-1.08"
+# for tv_grab_nz
+DEPEND="${DEPEND} >=dev-lang/python-1.5.2"
+# for tv_grab_fi tv_grab_es tv_grab_nl tv_grab_nl_wolf tv_grab_hu tv_grab_dk
+DEPEND="${DEPEND} dev-perl/HTML-Tree"
+
+### disabled until portage dependecy checker has notions of things
+### other then incrementals that are in /etc/make.conf
+### 6/13/2003 Max Kalika <max@gentoo.org>
+#[ -z "${XMLTV_OPTS}" -o "`has tv_grab_na ${XMLTV_OPTS}`" ] \
+# && DEPEND="${DEPEND} dev-perl/HTML-Parser"
+#[ -z "${XMLTV_OPTS}" -o "`has tv_grab_sn ${XMLTV_OPTS}`" ] \
+# && DEPEND="${DEPEND} >=dev-perl/HTML-TableExtract-1.0.8"
+#[ -z "${XMLTV_OPTS}" -o "`has tv_grab_nz ${XMLTV_OPTS}`" ] \
+# && DEPEND="${DEPEND} >=dev-lang/python-1.5.1"
+#[ -z "${XMLTV_OPTS}" -o "`has tv_grab_fi ${XMLTV_OPTS}`" ] \
+# && DEPEND="${DEPEND} dev-perl/HTML-Tree"
+#[ -z "${XMLTV_OPTS}" -o "`has tv_grab_es ${XMLTV_OPTS}`" ] \
+# && DEPEND="${DEPEND} dev-perl/HTML-Tree"
+#[ -z "${XMLTV_OPTS}" -o "`has tv_grab_nl ${XMLTV_OPTS}`" ] \
+# && DEPEND="${DEPEND} dev-perl/HTML-Tree"
+#[ -z "${XMLTV_OPTS}" -o "`has tv_grab_nl_wolf ${XMLTV_OPTS}`" ] \
+# && DEPEND="${DEPEND} dev-perl/HTML-Tree"
+#[ -z "${XMLTV_OPTS}" -o "`has tv_grab_hu ${XMLTV_OPTS}`" ] \
+# && DEPEND="${DEPEND} dev-perl/HTML-Tree"
+#[ -z "${XMLTV_OPTS}" -o "`has tv_grab_dk ${XMLTV_OPTS}`" ] \
+# && DEPEND="${DEPEND} dev-perl/HTML-Tree"
+#[ -z "${XMLTV_OPTS}" -o "`has tv_check ${XMLTV_OPTS}`" ] \
+# && DEPEND="${DEPEND} dev-perl/perl-tk dev-perl/Tk-TableMatrix dev-perl/XML-Simple"
+
+make_config() {
+ if [ -z "${XMLTV_OPTS}" ] ; then
+ # No customization needed, build everything (default)
+ echo "yes"
+ return
+ else
+ # Need to specify custom settings, do not accept defaults
+ echo "no"
+ fi
+
+ # Enable Germany and Austria (disabled currently)
+ #[ "`has tv_grab_de ${XMLTV_OPTS}`" ] && echo "yes" || echo "no"
+ # Enable Brittain
+ [ "`has tv_grab_uk ${XMLTV_OPTS}`" ] && echo "yes" || echo "no"
+ # Enable Alternate Brittain
+ [ "`has tv_grab_uk_rt ${XMLTV_OPTS}`" ] && echo "yes" || echo "no"
+ # Enable Italy
+ [ "`has tv_grab_it ${XMLTV_OPTS}`" ] && echo "yes" || echo "no"
+ # Enable North America
+ [ "`has tv_grab_na ${XMLTV_OPTS}`" ] && echo "yes" || echo "no"
+ # Enable Sweden and Norway
+ [ "`has tv_grab_sn ${XMLTV_OPTS}`" ] && echo "yes" || echo "no"
+ # Enable New Zealand
+ [ "`has tv_grab_nz ${XMLTV_OPTS}`" ] && echo "yes" || echo "no"
+ # Enable Finland
+ [ "`has tv_grab_fi ${XMLTV_OPTS}`" ] && echo "yes" || echo "no"
+ # Enable Spain
+ [ "`has tv_grab_es ${XMLTV_OPTS}`" ] && echo "yes" || echo "no"
+ # Enable Netherlands
+ [ "`has tv_grab_nl ${XMLTV_OPTS}`" ] && echo "yes" || echo "no"
+ # Enable Alternate Netherlands
+ [ "`has tv_grab_nl_wolf ${XMLTV_OPTS}`" ] && echo "yes" || echo "no"
+ # Enable Hungary
+ [ "`has tv_grab_hu ${XMLTV_OPTS}`" ] && echo "yes" || echo "no"
+ # Enable Denmark
+ [ "`has tv_grab_dk ${XMLTV_OPTS}`" ] && echo "yes" || echo "no"
+ # Enable GUI checking.
+ [ "`has tv_check ${XMLTV_OPTS}`" ] && echo "yes" || echo "no"
+ # Enable CGI support
+ [ "`has tv_pick_cgi ${XMLTV_OPTS}`" ] && echo "yes" || echo "no"
+}
+
+src_compile() {
+ make_config | perl-module_src_compile
+}
+
+src_install() {
+ perl-module_src_install
+
+ for i in `grep -rl "${D}" "${D}"` ; do
+ sed -e "s:${D}::g" -i "${i}"
+ done
+
+ if [ -z "${XMLTV_OPTS}" -o "`has tv_pick_cgi ${XMLTV_OPTS}`" ] ; then
+ dobin choose/tv_pick/tv_pick_cgi
+ einfo
+ einfo "To use tv_pick_cgi, please link it from /usr/bin/tv_pick_cgi"
+ einfo "to where the ScriptAlias directive is configured."
+ einfo
+ fi
+}
+
+pkg_postinst() {
+ ewarn "If you are upgrading from < 0.5.10 and you need to use the"
+ ewarn "DE (Germany/Austria), UK or UK_RT (Britain), or IT (Italy)"
+ ewarn "grabbers, please make sure you have the appropriate value"
+ ewarn "specified in your XMLTV_OPTS setting because these grabbers"
+ ewarn "no longer build by default."
+ echo
+}