summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Schwarzott <zzam@gentoo.org>2007-12-01 21:41:23 +0000
committerMatthias Schwarzott <zzam@gentoo.org>2007-12-01 21:41:23 +0000
commitd7591abc28b7cf7af25be095e5744ad3f0ed68f1 (patch)
tree42cc096ccdcc80844c10be62c2e9572e2ee72fc3 /media-tv
parentStable on amd64 wrt bug #200821 (diff)
downloadgentoo-2-d7591abc28b7cf7af25be095e5744ad3f0ed68f1.tar.gz
gentoo-2-d7591abc28b7cf7af25be095e5744ad3f0ed68f1.tar.bz2
gentoo-2-d7591abc28b7cf7af25be095e5744ad3f0ed68f1.zip
Added new snapshot. This solves Bug #200608
(Portage version: 2.1.4_rc4)
Diffstat (limited to 'media-tv')
-rw-r--r--media-tv/linuxtv-dvb-apps/ChangeLog8
-rw-r--r--media-tv/linuxtv-dvb-apps/files/digest-linuxtv-dvb-apps-1.1.1.200712013
-rw-r--r--media-tv/linuxtv-dvb-apps/linuxtv-dvb-apps-1.1.1.20071201.ebuild89
3 files changed, 99 insertions, 1 deletions
diff --git a/media-tv/linuxtv-dvb-apps/ChangeLog b/media-tv/linuxtv-dvb-apps/ChangeLog
index de51009da8a2..5392afbfe262 100644
--- a/media-tv/linuxtv-dvb-apps/ChangeLog
+++ b/media-tv/linuxtv-dvb-apps/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-tv/linuxtv-dvb-apps
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/linuxtv-dvb-apps/ChangeLog,v 1.37 2007/11/27 10:04:07 zzam Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/linuxtv-dvb-apps/ChangeLog,v 1.38 2007/12/01 21:41:22 zzam Exp $
+
+*linuxtv-dvb-apps-1.1.1.20071201 (01 Dec 2007)
+
+ 01 Dec 2007; Matthias Schwarzott <zzam@gentoo.org>
+ +linuxtv-dvb-apps-1.1.1.20071201.ebuild:
+ Added new snapshot. This solves Bug #200608
27 Nov 2007; Matthias Schwarzott <zzam@gentoo.org>
linuxtv-dvb-apps-1.1.0.ebuild, linuxtv-dvb-apps-1.1.1.20060917.ebuild,
diff --git a/media-tv/linuxtv-dvb-apps/files/digest-linuxtv-dvb-apps-1.1.1.20071201 b/media-tv/linuxtv-dvb-apps/files/digest-linuxtv-dvb-apps-1.1.1.20071201
new file mode 100644
index 000000000000..f7c773abfbe2
--- /dev/null
+++ b/media-tv/linuxtv-dvb-apps/files/digest-linuxtv-dvb-apps-1.1.1.20071201
@@ -0,0 +1,3 @@
+MD5 634b3d36062ec9f2c1579b159f92e31d linuxtv-dvb-apps-20071201.tar.bz2 306775
+RMD160 a26e9c06e90c5fc32326e54eadb4bd8a0537fecd linuxtv-dvb-apps-20071201.tar.bz2 306775
+SHA256 c40e598d45b7be0656485a6a455ad7c20b1f0ffc06216e9dee367685d08457ea linuxtv-dvb-apps-20071201.tar.bz2 306775
diff --git a/media-tv/linuxtv-dvb-apps/linuxtv-dvb-apps-1.1.1.20071201.ebuild b/media-tv/linuxtv-dvb-apps/linuxtv-dvb-apps-1.1.1.20071201.ebuild
new file mode 100644
index 000000000000..0a3f78b4f05d
--- /dev/null
+++ b/media-tv/linuxtv-dvb-apps/linuxtv-dvb-apps-1.1.1.20071201.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-tv/linuxtv-dvb-apps/linuxtv-dvb-apps-1.1.1.20071201.ebuild,v 1.1 2007/12/01 21:41:22 zzam Exp $
+
+inherit eutils versionator multilib
+
+MY_P="${PN}-$(get_version_component_range 4)"
+
+IUSE="usb"
+SLOT="0"
+HOMEPAGE="http://www.linuxtv.org/"
+DESCRIPTION="small utils for DVB to scan, zap, view signal strength, ..."
+LICENSE="GPL-2"
+SRC_URI="mirror://gentoo/${MY_P}.tar.bz2"
+KEYWORDS="~amd64 ~ia64 ~ppc ~x86"
+
+RDEPEND="usb? ( >=dev-libs/libusb-0.1.10a )"
+DEPEND="${DEPEND}
+ media-tv/linuxtv-dvb-headers"
+
+S="${WORKDIR}/dvb-apps-435a56faec09"
+
+src_unpack()
+{
+ unpack ${A}
+
+ cd "${S}"
+
+ # disables compilation of ttusb_dec_reset which requires libusb
+ if ! use usb; then
+ sed -i util/Makefile \
+ -e '/ttusb_dec_reset/d' \
+ -e '/dib3000-watch/d'
+ fi
+
+ # do not compile test-progs
+ sed -i Makefile -e '/-C test/d'
+
+ # remove copy of header-files
+ rm -rf "${S}"/include
+}
+
+src_compile()
+{
+ # interferes with variable in Makefile
+ unset ARCH
+
+ emake bindir=/usr/bin datadir=/usr/share libdir=/usr/$(get_libdir) || die "failed to compile"
+}
+
+src_install()
+{
+ # interferes with variable in Makefile
+ unset ARCH
+
+ insinto /usr/bin
+ emake bindir=/usr/bin datadir=/usr/share libdir=/usr/$(get_libdir) prefix=/usr \
+ DESTDIR="${D}" INSTDIR="${T}" install || die "install failed"
+
+ # rename scan to dvbscan
+ mv "${D}"/usr/bin/scan "${D}"/usr/bin/dvbscan
+
+ # install zap-files
+ for dir in dvb-{s,c,t} atsc; do
+ insinto /usr/share/dvb/zap/${dir}
+ doins "${S}"/util/szap/channels-conf/${dir}/*
+ done
+
+ # install remote-key files
+ insinto /usr/share/dvb/av7110_loadkeys
+ doins "${S}"/util/av7110_loadkeys/*.rc*
+
+ # install Documentation
+ dodoc README TODO
+ newdoc util/scan/README README.dvbscan
+ newdoc util/szap/README README.zap
+ newdoc util/av7110_loadkeys/README README.av7110_loadkeys
+
+ use usb && newdoc util/ttusb_dec_reset/README README.ttusb_dec_reset
+}
+
+pkg_postinst()
+{
+ elog "Please read the documentation in /usr/share/doc/${PF}."
+ elog "The channel lists and other files are installed in"
+ elog "/usr/share/dvb"
+ elog
+ elog "The scanning utility is now installed as dvbscan."
+}