summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Dibb <beandog@gentoo.org>2007-01-22 15:52:37 +0000
committerSteve Dibb <beandog@gentoo.org>2007-01-22 15:52:37 +0000
commit0ebb1297bbebcf11f6119b7c61555390ecf1bafc (patch)
treeafb33aa22297ec7c5faa2adef583d827a13ef870 /media-video/avidemux
parentStable on Alpha + IA64. (diff)
downloadgentoo-2-0ebb1297bbebcf11f6119b7c61555390ecf1bafc.tar.gz
gentoo-2-0ebb1297bbebcf11f6119b7c61555390ecf1bafc.tar.bz2
gentoo-2-0ebb1297bbebcf11f6119b7c61555390ecf1bafc.zip
Version bump, bug 150175
(Portage version: 2.1.1-r2)
Diffstat (limited to 'media-video/avidemux')
-rw-r--r--media-video/avidemux/ChangeLog9
-rw-r--r--media-video/avidemux/avidemux-2.3.0.ebuild122
-rw-r--r--media-video/avidemux/files/avidemux-2.3.0-configure.patch214
-rw-r--r--media-video/avidemux/files/avidemux-2.3.0-dts.patch10
-rw-r--r--media-video/avidemux/files/digest-avidemux-2.3.03
5 files changed, 357 insertions, 1 deletions
diff --git a/media-video/avidemux/ChangeLog b/media-video/avidemux/ChangeLog
index ee19f625ea38..2b1c7ac4b46a 100644
--- a/media-video/avidemux/ChangeLog
+++ b/media-video/avidemux/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-video/avidemux
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/avidemux/ChangeLog,v 1.104 2007/01/10 21:27:44 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/avidemux/ChangeLog,v 1.105 2007/01/22 15:52:37 beandog Exp $
+
+*avidemux-2.3.0 (22 Jan 2007)
+
+ 22 Jan 2007; Steve Dibb <beandog@gentoo.org>
+ +files/avidemux-2.3.0-configure.patch, +files/avidemux-2.3.0-dts.patch,
+ +avidemux-2.3.0.ebuild:
+ Version bump, bug 150175
10 Jan 2007; Diego Pettenò <flameeyes@gentoo.org> metadata.xml:
Add missing email address for herd with name != alias.
diff --git a/media-video/avidemux/avidemux-2.3.0.ebuild b/media-video/avidemux/avidemux-2.3.0.ebuild
new file mode 100644
index 000000000000..155aef49355b
--- /dev/null
+++ b/media-video/avidemux/avidemux-2.3.0.ebuild
@@ -0,0 +1,122 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/avidemux/avidemux-2.3.0.ebuild,v 1.1 2007/01/22 15:52:37 beandog Exp $
+
+inherit eutils flag-o-matic subversion
+
+MY_P=${PN}_${PV}
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="Great Video editing/encoding tool"
+HOMEPAGE="http://fixounet.free.fr/avidemux/"
+SRC_URI="http://download.berlios.de/${PN}/${MY_P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="2"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="a52 aac alsa altivec arts encode esd mad nls vorbis sdl truetype x264 xvid xv oss"
+
+RDEPEND="
+ >=x11-libs/gtk+-2.6
+ >=dev-libs/libxml2-2.6.7
+ >=dev-lang/spidermonkey-1.5-r2
+ a52? ( >=media-libs/a52dec-0.7.4 )
+ encode? ( >=media-sound/lame-3.93 )
+ aac? ( >=media-libs/faac-1.23.5
+ >=media-libs/faad2-2.0-r7 )
+ esd? ( media-sound/esound )
+ mad? ( media-libs/libmad )
+ xvid? ( >=media-libs/xvid-1.0.0 )
+ x264? ( media-libs/x264-svn )
+ nls? ( >=sys-devel/gettext-0.12.1 )
+ vorbis? ( >=media-libs/libvorbis-1.0.1 )
+ arts? ( >=kde-base/arts-1.2.3 )
+ truetype? ( >=media-libs/freetype-2.1.5 )
+ alsa? ( >=media-libs/alsa-lib-1.0.3b-r2 )
+ sdl? ( media-libs/libsdl )
+ || ( (
+ xv? ( x11-libs/libXv )
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXrender
+ ) virtual/x11 )"
+# media-sound/toolame is supported as well
+
+DEPEND="$RDEPEND
+ || ( (
+ x11-base/xorg-server
+ x11-libs/libXt
+ x11-proto/xextproto
+ ) virtual/x11 )
+ dev-util/pkgconfig
+ >=sys-devel/autoconf-2.58
+ >=sys-devel/automake-1.8.3"
+
+pkg_setup() {
+ filter-flags "-fno-default-inline"
+ filter-flags "-funroll-loops"
+ filter-flags "-funroll-all-loops"
+ filter-flags "-fforce-addr"
+
+ if ! built_with_use dev-lang/spidermonkey threadsafe; then
+ eerror "dev-lang/spidermonkey is missing threadsafe support, please make"
+ eerror "sure you get the spidermonkey ebuild with threadsafe USE flag"
+ eerror "from an overlay, enable the threadsafe USE flag and re-emerge"
+ eerror "dev-lang/spidermonkey - this avidemux build will not compile"
+ eerror "nor work without it!"
+ die "dev-lang/spidermonkey needs threadsafe support"
+ fi
+
+ if ! ( use oss || use arts || use alsa ); then
+ eerror "You must select at least one between oss, arts and alsa audio output."
+ die "Fix USE flags"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S} || die
+
+ epatch ${FILESDIR}/${P}-dts.patch
+ epatch ${FILESDIR}/${P}-configure.patch
+ #sed -i -e 's/x264=no,-lm/x264=no,-lm -lX11/' configure.in.in || die "sed failed."
+
+
+ gmake -f Makefile.dist || die "autotools failed."
+}
+
+src_compile() {
+ econf \
+ $(use_enable nls) \
+ $(use_enable altivec) \
+ $(use_enable xv) \
+ $(use_with arts) \
+ $(use_with alsa) \
+ $(use_with esd) \
+ $(use_with oss) \
+ $(use_with vorbis) \
+ $(use_with sdl libsdl) \
+ $(use_with truetype freetype2) \
+ $(use_enable aac faac) $(use_with aac faad2) \
+ $(use_with encode lame) \
+ --with-newfaad --with-jsapi-include=/usr/include/js \
+ --disable-warnings --disable-dependency-tracking \
+ ${myconf} || die "configure failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die "make install failed"
+ dodoc AUTHORS ChangeLog History README TODO
+ insinto /usr/share/pixmaps
+ newins ${S}/avidemux_icon.png avidemux.png
+ make_desktop_entry avidemux2 "Avidemux2" avidemux.png
+}
+
+pkg_postinst() {
+ if use ppc && use oss; then
+ echo
+ einfo "OSS sound output may not work on ppc"
+ einfo "If your hear only static noise, try"
+ einfo "changing the sound device to ALSA or arts"
+ fi
+}
diff --git a/media-video/avidemux/files/avidemux-2.3.0-configure.patch b/media-video/avidemux/files/avidemux-2.3.0-configure.patch
new file mode 100644
index 000000000000..702aa959bf8c
--- /dev/null
+++ b/media-video/avidemux/files/avidemux-2.3.0-configure.patch
@@ -0,0 +1,214 @@
+--- avidemux_2.3_preview2/configure.in.old 2006-10-26 21:18:36.453792624 +0200
++++ avidemux_2.3_preview2/configure.in 2006-10-26 22:41:06.403158349 +0200
+@@ -196,7 +196,7 @@
+ have_divx=yes
+ have_little_endian=yes
+ have_vorbis=yes
+-have_ac3=yes
++have_ac3=no
+ have_xx_xvid=yes
+ have_xx_xvid_cvs=yes
+ have_xvid4=yes
+@@ -270,6 +270,16 @@
+
+ dnl __________________divx______________
+ dnl __________________x264 ______________
++AC_ARG_WITH([aften],
++ AC_HELP_STRING([--without-aften], [Force compilation without aften (default: test)]),
++ [with_aften=${withval}], [with_aften=test])
++
++AC_MSG_CHECKING([if aften support is requested])
++AC_MSG_RESULT($with_aften)
++
++have_aften=no
++
++if test "x$with_aften" != "xno"; then
+ AC_MSG_CHECKING(for aften codec )
+ AC_CHECK_HEADER(aften/aften.h,,have_aften=no)
+ if test "x$have_aften" = "xyes"; then
+@@ -277,22 +287,42 @@
+ fi
+ if test "x$have_aften" = "xyes"; then
+ AC_DEFINE(USE_AFTEN,1,[use aften ac3 encoder])
++ have_ac3=yes
++fi
+ fi
+-
+
+ dnl __________________x264 ______________
++AC_ARG_WITH([x264],
++ AC_HELP_STRING([--without-x264], [Force compilation without x264 (default: test)]),
++ [with_x264=${withval}], [with_x264=test])
++
++AC_MSG_CHECKING([if x264 support is requested])
++AC_MSG_RESULT($with_x264)
++
++have_x264=no
++
++if test "x$with_x264" != "xno"; then
+ AC_MSG_CHECKING(for x264 codec )
+-AC_CHECK_HEADER(x264.h,,have_x264=no)
+-if test "x$have_x264" = "xyes"; then
++AC_CHECK_HEADER(x264.h,have_x264=yes,have_x264=no)
+ AC_CHECK_LIB(x264,x264_encoder_open,,have_x264=no,-lm )
+-fi
+ if test "x$have_x264" = "xyes"; then
+ AC_DEFINE(USE_X264,1,[use x264 encoder])
+ fi
++fi
+
+ dnl __________________xvid 0.9 ______________
++AC_ARG_WITH([xx-xvid],
++ AC_HELP_STRING([--without-xx-xvid], [Force compilation without xvid 0.9 (default: test)]),
++ [with_xx_xvid=${withval}], [with_xx_xvid=test])
++
++AC_MSG_CHECKING([if xvid 0.9 support is requested])
++AC_MSG_RESULT($with_xx_xvid)
++
++have_xx_xvid=no
++
++if test "x$with_xx_xvid" != "xno"; then
+ AC_MSG_CHECKING(for xvid codec 0.9)
+-AC_CHECK_HEADER(xvid.h,,have_xx_xvid=no)
++AC_CHECK_HEADER(xvid.h,have_xx_xvid=yes,have_xx_xvid=no)
+
+ dnl -- check API version 2.1 and not 2.0--
+
+@@ -318,16 +348,38 @@
+ if test "x$have_xx_xvid" = "xyes"; then
+ AC_DEFINE(USE_XX_XVID,1,[use xvid api])
+ fi
++ fi
+ dnl __________________libpng ______________
++AC_ARG_WITH([png],
++ AC_HELP_STRING([--without-png], [Force compilation without png support (default: test)]),
++ [with_png=${withval}], [with_png=test])
++
++AC_MSG_CHECKING([if PNG support is requested])
++AC_MSG_RESULT($with_png)
++
++have_png=no
++
++if test "x$with_png" != "xno"; then
+ AC_MSG_CHECKING(for libpng )
+-have_png=yes
+-AC_CHECK_HEADER(png.h,,have_png=no)
++AC_CHECK_HEADER(png.h,have_png=yes,have_png=no)
+ AC_CHECK_LIB(png,png_malloc,,have_png=no)
+
+ if test "x$have_png" = "xyes"; then
+ AC_DEFINE(USE_PNG,1,[Png is available])
+ fi
++fi
+ dnl __________________xvid 1.0 ______________
++AC_ARG_WITH([xvid4],
++ AC_HELP_STRING([--without-xvid4], [Force compilation without xvid4 support (default: test)]),
++ [with_xvid4=${withval}], [with_xvid4=test])
++
++AC_MSG_CHECKING([if Xvid 4 support is requested])
++AC_MSG_RESULT($with_xvid4)
++
++have_xvid4=no
++
++if test "x$with_xvid4" != "xno"; then
++have_xvid4=yes
+ AC_MSG_CHECKING(for xvid codec 1.0)
+ AC_CHECK_HEADER(xvid.h,,have_xvid4=no)
+
+@@ -353,6 +405,7 @@
+ AC_DEFINE(USE_XVID_4,1,[use xvid api 1.0 beta])
+ fi
+ fi
++ fi
+
+ dnl __________________FFMPEG______________
+
+@@ -486,6 +539,17 @@
+ fi
+
+ dnl __________________ALSA______________
++AC_ARG_WITH([alsa],
++ AC_HELP_STRING([--without-alsa], [Force compilation without alsa (default: test)]),
++ [with_alsa=${withval}], [with_alsa=test])
++
++AC_MSG_CHECKING([if alsa support is requested])
++AC_MSG_RESULT($with_alsa)
++
++have_alsa=no
++
++if test "x$with_alsa" != "xno"; then
++have_alsa=yes
+ AC_MSG_CHECKING(for ALSA audio support)
+ AC_CHECK_HEADERS(alsa/asoundlib.h,,have_alsa=no)
+ dnl check version 0.9.x
+@@ -526,7 +590,7 @@
+ if test "x$have_alsa_1" = "xyes"; then
+ AC_DEFINE(ALSA_1_0_SUPPORT,1,"[Alsa is 1.0]")
+ fi
+-
++fi
+ dnl __________________/ALSA______________
+
+
+@@ -646,6 +710,16 @@
+
+
+ dnl ____________ faac ?________________
++AC_ARG_WITH([faac],
++ AC_HELP_STRING([--without-faac], [Force compilation without faac (default: test)]),
++ [with_faac=${withval}], [with_faac=test])
++
++AC_MSG_CHECKING([if faac support is requested])
++AC_MSG_RESULT($with_faac)
++
++have_faac=no
++
++if test "x$with_faac" != "xno"; then
+ have_faac=yes
+ AC_CHECK_HEADERS(faac.h,,have_faac=no)
+
+@@ -659,15 +733,35 @@
+ fi
+ AC_MSG_CHECKING(faac library)
+ AC_MSG_RESULT($have_faac)
+-
++ fi
+ dnl _______________/faac_______________
+ dnl _________________ /freetype 2 _________________
+ dnl __________________ac3______________
+ dnl
+ dnl a52dec decoding library
++AC_ARG_WITH([a52],
++ AC_HELP_STRING([--without-a52], [Force compilation without a52 (default: enabled)]),
++ [with_a52=${withval}], [with_a52=test])
++
++AC_MSG_CHECKING([if a52 support is requested])
++AC_MSG_RESULT($with_a52)
++
++if test "x$with_a52" != "xno"; then
+ AC_DEFINE(USE_AC3,1,[liba52dec])
++have_ac3=yes
++fi
+ dnl __________________/ac3______________
+ dnl __________________VORBIS______________
++AC_ARG_WITH([vorbis],
++ AC_HELP_STRING([--without-vorbis], [Force compilation without vorbis (default: enabled)]),
++ [with_vorbis=${withval}], [with_vorbis=test])
++
++AC_MSG_CHECKING([if vorbis support is requested])
++AC_MSG_RESULT($with_vorbis)
++
++have_vorbis=no
++if test "x$with_vorbis" != "xno"; then
++have_vorbis=yes
+ AC_CHECK_LIB(vorbis,vorbis_info_init,,have_vorbis=no, -lm)
+ if test "x$have_vorbis" = "xyes"; then
+ AC_CHECK_LIB(vorbisenc,vorbis_encode_init,,have_vorbis=no, -lm)
+@@ -678,6 +772,7 @@
+ fi
+ fi
+ fi
++fi
+ dnl __________________/VORBIS______________
+
+ dnl __________________LAME______________
diff --git a/media-video/avidemux/files/avidemux-2.3.0-dts.patch b/media-video/avidemux/files/avidemux-2.3.0-dts.patch
new file mode 100644
index 000000000000..bdc9cc412a77
--- /dev/null
+++ b/media-video/avidemux/files/avidemux-2.3.0-dts.patch
@@ -0,0 +1,10 @@
+--- avidemux/ADM_audiocodec/ADM_dca.cpp.old 2006-05-23 21:25:58.000000000 -0400
++++ avidemux/ADM_audiocodec/ADM_dca.cpp 2006-05-23 21:26:15.000000000 -0400
+@@ -31,7 +31,6 @@
+ extern "C"
+ {
+ #include "dts.h"
+-#include "dts_internal.h"
+
+ }
+ #include "ADM_audio/ADM_dcainfo.h"
diff --git a/media-video/avidemux/files/digest-avidemux-2.3.0 b/media-video/avidemux/files/digest-avidemux-2.3.0
new file mode 100644
index 000000000000..6730eea28c24
--- /dev/null
+++ b/media-video/avidemux/files/digest-avidemux-2.3.0
@@ -0,0 +1,3 @@
+MD5 14c58c14fc9757d36e4d72498431da42 avidemux_2.3.0.tar.gz 4750919
+RMD160 1e10183d4b80104a42d40bfd9d9e9b5c54843d9e avidemux_2.3.0.tar.gz 4750919
+SHA256 ef083ab24e3ec612b10c8a0163845ff680fea845d5eade21d60d47e843b4c623 avidemux_2.3.0.tar.gz 4750919