summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-03-29 01:58:50 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-03-29 01:58:50 +0000
commit52df407e52198ab4209dc45384b1262fd889d4fa (patch)
tree20d5f585e68e35c2da9a9fcef2a46c8ed2d95015 /media-video/avifile
parent_pre33 release (diff)
downloadgentoo-2-52df407e52198ab4209dc45384b1262fd889d4fa.tar.gz
gentoo-2-52df407e52198ab4209dc45384b1262fd889d4fa.tar.bz2
gentoo-2-52df407e52198ab4209dc45384b1262fd889d4fa.zip
Added many USE dependent compilation options, such as oggvorbis, avi for win32codecs, sdl, mmx/3dnow/sse for optimisations, and kde for kde examples
Diffstat (limited to 'media-video/avifile')
-rw-r--r--media-video/avifile/ChangeLog10
-rw-r--r--media-video/avifile/avifile-0.6.0.20011220-r1.ebuild83
-rw-r--r--media-video/avifile/files/digest-avifile-0.6.0.20011220-r11
3 files changed, 93 insertions, 1 deletions
diff --git a/media-video/avifile/ChangeLog b/media-video/avifile/ChangeLog
index 231b897bd152..e5cd1d215eb8 100644
--- a/media-video/avifile/ChangeLog
+++ b/media-video/avifile/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for media-video/avifile
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/media-video/avifile/ChangeLog,v 1.2 2002/02/17 15:29:50 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/avifile/ChangeLog,v 1.3 2002/03/29 01:58:50 seemant Exp $
+
+*avifile-0.6.0.20011220-r1 (28 Mar 2002)
+
+ 28 Mar 2002; Seemant Kulleen <seemant@gentoo.org> avifile-0.6.0-20011220-r1.ebuild :
+
+ Many changes in here, involving USE dependent compilation of support for:
+ oggvorbis, avi (win32codecs), sdl, mmx/3dnow/sse (x86 optimisation), kde
+ (for kde sample somethings)
*avifile-0.6.0.20011220 (17 Feb 2002)
diff --git a/media-video/avifile/avifile-0.6.0.20011220-r1.ebuild b/media-video/avifile/avifile-0.6.0.20011220-r1.ebuild
new file mode 100644
index 000000000000..e6c84c70844d
--- /dev/null
+++ b/media-video/avifile/avifile-0.6.0.20011220-r1.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author: Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/media-video/avifile/avifile-0.6.0.20011220-r1.ebuild,v 1.1 2002/03/29 01:58:50 seemant Exp $
+
+MY_P=${P/.200/-200}
+MY_S=${MY_P/avifile-/avifile}
+MY_S=${MY_S/.0-200/-200}
+S=${WORKDIR}/${MY_S}
+DESCRIPTION="Library for AVI-Files"
+SRC_URI="http://avifile.sourceforge.net/${MY_P}admin.tgz"
+HOMEPAGE="http://divx.euro.ru/"
+
+DEPEND=">=media-libs/divx4linux-20011025
+ media-libs/jpeg
+ sdl? ( >=media-libs/libsdl-1.2.2 )
+ avi? ( media-libs/win32codecs )
+ qt? ( =x11-libs/qt-2* )
+ nas? ( >=media-libs/nas-1.4.2 )
+ oggvorbis? ( media-libs/libvorbis )"
+
+
+src_compile() {
+
+ local myconf
+
+ use mmx && myconf="--enable-x86opt"
+ use sse && myconf="--enable-x86opt"
+ use 3dnow && myconf="--enable-x86opt"
+
+ use qt \
+ && myconf="${myconf} --with-qt-dir=/usr/qt/2" \
+ || myconf="${myconf} --disable-qt"
+
+ use kde \
+ && myconf="${myconf} --enable-kde" \
+ || myconf="${myconf} --disable-kde"
+
+ use sdl \
+ && myconf="${myconf} --enable-sdl" \
+ || myconf="${myconf} --disable-sdl --disable-sdltest"
+
+ use nas && LDFLAGS="-L/usr/X11R6/lib -lXt"
+
+ use avi \
+ && myconf="${myconf} --enable-win32" \
+ || myconf="${myconf} --disable-win32"
+
+ use oggvorbis \
+ && myconf="${myconf} --enable-vorbis" \
+ || myconf="${myconf} --disable-vorbis --disable-oggtest --disable-vorbistest"
+
+ export CFLAGS=${CFLAGS/-O?/-O2}
+ LDFLAGS="$LDFLAGS -L/usr/kde/2/lib"
+ export LDFLAGS
+ ./configure --prefix=/usr \
+ --host=${CHOST} \
+ --enable-quiet \
+ --disable-tsc \
+ --with-extra-libraries=/usr/kde/2 \
+ ${myconf} || die
+
+# cp Makefile Makefile.orig
+# sed -e "s:/usr/lib/win32:${D}/usr/lib/win32:" \
+# Makefile.orig > Makefile
+
+ make || die
+}
+
+src_install () {
+
+ dodir /usr/lib /usr/bin
+ use avi && dodir /usr/lib/win32
+
+ make prefix=${D}/usr install || die
+
+ cd ${S}
+ dodoc COPYING README
+ cd doc
+ dodoc CREDITS EXCEPTIONS FreeBSD LICENSING TODO
+ dodoc VIDEO-PERFORMANCE WARNINGS
+}
+
diff --git a/media-video/avifile/files/digest-avifile-0.6.0.20011220-r1 b/media-video/avifile/files/digest-avifile-0.6.0.20011220-r1
new file mode 100644
index 000000000000..a2398611d718
--- /dev/null
+++ b/media-video/avifile/files/digest-avifile-0.6.0.20011220-r1
@@ -0,0 +1 @@
+MD5 89c096520c14a68922669dbda0132baa avifile-0.6.0-20011220admin.tgz 2043485