summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2009-12-24 12:04:17 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2009-12-24 12:04:17 +0000
commite8fedb0c10192acf82f0562c0b7ad08514b991ab (patch)
tree366bc28403e75b164822059f9d64c3913e6c85ba /media-video/cclive
parentamd64 stable, bug 287988 (diff)
downloadgentoo-2-e8fedb0c10192acf82f0562c0b7ad08514b991ab.tar.gz
gentoo-2-e8fedb0c10192acf82f0562c0b7ad08514b991ab.tar.bz2
gentoo-2-e8fedb0c10192acf82f0562c0b7ad08514b991ab.zip
Version bump. Try to accomodate offesnive part of bug #298150.
(Portage version: 2.2_rc60/cvs/Linux i686)
Diffstat (limited to 'media-video/cclive')
-rw-r--r--media-video/cclive/ChangeLog7
-rw-r--r--media-video/cclive/cclive-0.5.7.ebuild39
2 files changed, 45 insertions, 1 deletions
diff --git a/media-video/cclive/ChangeLog b/media-video/cclive/ChangeLog
index c92e47fb5336..33c8e2a2ada8 100644
--- a/media-video/cclive/ChangeLog
+++ b/media-video/cclive/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-video/cclive
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/cclive/ChangeLog,v 1.10 2009/12/16 14:01:20 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/cclive/ChangeLog,v 1.11 2009/12/24 12:04:17 scarabeus Exp $
+
+*cclive-0.5.7 (24 Dec 2009)
+
+ 24 Dec 2009; Tomáš Chvátal <scarabeus@gentoo.org> +cclive-0.5.7.ebuild:
+ Version bump. Try to accomodate offesnive part of bug #298150.
*cclive-0.5.6 (16 Dec 2009)
diff --git a/media-video/cclive/cclive-0.5.7.ebuild b/media-video/cclive/cclive-0.5.7.ebuild
new file mode 100644
index 000000000000..57155e063469
--- /dev/null
+++ b/media-video/cclive/cclive-0.5.7.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/cclive/cclive-0.5.7.ebuild,v 1.1 2009/12/24 12:04:17 scarabeus Exp $
+
+EAPI=2
+
+DESCRIPTION="Command line tool for extracting videos from various websites"
+HOMEPAGE="http://code.google.com/p/cclive/"
+SRC_URI="http://cclive.googlecode.com/files/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="test offensive"
+
+RDEPEND=">=net-misc/curl-7.18.0
+ >=dev-libs/libpcre-7.9[cxx]"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_configure() {
+ econf \
+ --with-man \
+ $(use_enable test tests)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog NEWS README TODO || die "dodoc failed"
+}
+
+src_test() {
+ local value
+
+ ewarn "Tests require internet connection in order to work."
+
+ use offensive && value="true" || value="false"
+ ADULT_OK="${value}" emake check || die "emake test failed"
+}