summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-02-08 16:21:49 +0000
committerAlexis Ballier <aballier@gentoo.org>2015-02-08 16:21:49 +0000
commit9090b6794a7c4b5565f879e479d833d79e5d20d8 (patch)
treefcdc365f295547ffa796875fb5488960ce360608 /media-video/cinelerra
parentAdd KDE herd. (diff)
downloadgentoo-2-9090b6794a7c4b5565f879e479d833d79e5d20d8.tar.gz
gentoo-2-9090b6794a7c4b5565f879e479d833d79e5d20d8.tar.bz2
gentoo-2-9090b6794a7c4b5565f879e479d833d79e5d20d8.zip
Fix build with gcc 4.9, patch by Bernd Feige in bug #526118
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'media-video/cinelerra')
-rw-r--r--media-video/cinelerra/ChangeLog6
-rw-r--r--media-video/cinelerra/cinelerra-20140710.ebuild5
-rw-r--r--media-video/cinelerra/files/cinelerra-pngtoh.patch15
3 files changed, 23 insertions, 3 deletions
diff --git a/media-video/cinelerra/ChangeLog b/media-video/cinelerra/ChangeLog
index d144589604d2..e674e09d64ce 100644
--- a/media-video/cinelerra/ChangeLog
+++ b/media-video/cinelerra/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-video/cinelerra
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/cinelerra/ChangeLog,v 1.70 2015/01/29 19:14:51 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/cinelerra/ChangeLog,v 1.71 2015/02/08 16:21:49 aballier Exp $
+
+ 08 Feb 2015; Alexis Ballier <aballier@gentoo.org> cinelerra-20140710.ebuild,
+ +files/cinelerra-pngtoh.patch:
+ Fix build with gcc 4.9, patch by Bernd Feige in bug #526118
29 Jan 2015; Michał Górny <mgorny@gentoo.org> cinelerra-20120707.ebuild,
cinelerra-20140710.ebuild:
diff --git a/media-video/cinelerra/cinelerra-20140710.ebuild b/media-video/cinelerra/cinelerra-20140710.ebuild
index 5dcfc45afb04..bb46c737a19b 100644
--- a/media-video/cinelerra/cinelerra-20140710.ebuild
+++ b/media-video/cinelerra/cinelerra-20140710.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/cinelerra/cinelerra-20140710.ebuild,v 1.2 2015/01/29 19:14:51 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/cinelerra/cinelerra-20140710.ebuild,v 1.3 2015/02/08 16:21:49 aballier Exp $
EAPI=5
inherit autotools eutils multilib flag-o-matic
@@ -60,7 +60,8 @@ src_prepare() {
"${FILESDIR}"/${PN}-ffmpeg.patch \
"${FILESDIR}"/${P}-underlinking.patch \
"${FILESDIR}"/${P}-ffmpeg-0.11.patch \
- "${FILESDIR}"/${PN}-libav9.patch
+ "${FILESDIR}"/${PN}-libav9.patch \
+ "${FILESDIR}"/${PN}-pngtoh.patch
if has_version '>=media-video/ffmpeg-2' ; then
epatch "${FILESDIR}"/${PN}-ffmpeg2.patch
diff --git a/media-video/cinelerra/files/cinelerra-pngtoh.patch b/media-video/cinelerra/files/cinelerra-pngtoh.patch
new file mode 100644
index 000000000000..81a8432b8729
--- /dev/null
+++ b/media-video/cinelerra/files/cinelerra-pngtoh.patch
@@ -0,0 +1,15 @@
+https://bugs.gentoo.org/show_bug.cgi?id=526118
+http://bugs.cinelerra-cv.org/ticket/1005
+
+Author: Bernd Feige
+
+--- guicast/pngtoh.c 2015-01-29 13:41:01 +0000
++++ guicast/pngtoh.c 2015-01-29 13:41:07 +0000
+@@ -148,4 +148,6 @@
+ fprintf(out, "};\n\n#endif\n");
+ fclose(out);
+ }
++
++ return 0;
+ }
+