summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Brinkmann <luckyduck@gentoo.org>2005-03-13 20:34:59 +0000
committerJan Brinkmann <luckyduck@gentoo.org>2005-03-13 20:34:59 +0000
commit97944091db6fff5bbf79b1d7d0a52174d5882253 (patch)
tree7e1431f4ebd7e710c231fd2d9d23650b709188f1 /media-video/cinepaint
parentAdded ~ppc64 to KEYWORDS (diff)
downloadgentoo-2-97944091db6fff5bbf79b1d7d0a52174d5882253.tar.gz
gentoo-2-97944091db6fff5bbf79b1d7d0a52174d5882253.tar.bz2
gentoo-2-97944091db6fff5bbf79b1d7d0a52174d5882253.zip
added patch to fix compilation with gcc3.4, also added ~amd64 to KEYWORDS. fixed #60753
(Portage version: 2.0.51.19)
Diffstat (limited to 'media-video/cinepaint')
-rw-r--r--media-video/cinepaint/ChangeLog9
-rw-r--r--media-video/cinepaint/cinepaint-0.18.3.ebuild13
-rw-r--r--media-video/cinepaint/cinepaint-0.18.ebuild4
-rw-r--r--media-video/cinepaint/files/cinepaint-0.18.3-gcc34.patch33
4 files changed, 52 insertions, 7 deletions
diff --git a/media-video/cinepaint/ChangeLog b/media-video/cinepaint/ChangeLog
index f990aecfa6ee..433a5097d350 100644
--- a/media-video/cinepaint/ChangeLog
+++ b/media-video/cinepaint/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-video/cinepaint
-# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/cinepaint/ChangeLog,v 1.4 2004/08/12 20:26:13 chriswhite Exp $
+# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/cinepaint/ChangeLog,v 1.5 2005/03/13 20:34:59 luckyduck Exp $
+
+ 13 Mar 2005; Jan Brinkmann <luckyduck@gentoo.org>
+ +files/cinepaint-0.18.3-gcc34.patch, cinepaint-0.18.3.ebuild:
+ added patch to fix compilation with gcc3.4, also added ~amd64 to KEYWORDS.
+ fixed #60753
13 Aug 2004; Chris White <chriswhite@gentoo.org> +metadata.xml:
Added missing metadata.xml. Taking over as maintainer.
diff --git a/media-video/cinepaint/cinepaint-0.18.3.ebuild b/media-video/cinepaint/cinepaint-0.18.3.ebuild
index 12e1c48d9cc5..80f6463616e2 100644
--- a/media-video/cinepaint/cinepaint-0.18.3.ebuild
+++ b/media-video/cinepaint/cinepaint-0.18.3.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/cinepaint/cinepaint-0.18.3.ebuild,v 1.1 2004/08/03 09:07:09 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/cinepaint/cinepaint-0.18.3.ebuild,v 1.2 2005/03/13 20:34:59 luckyduck Exp $
inherit eutils
@@ -10,7 +10,7 @@ DESCRIPTION="motion picture editing tool used for painting and retouching of mov
SRC_URI="mirror://sourceforge/cinepaint/${PN}-${MY_PV}.tar.gz"
HOMEPAGE="http://cinepaint.sourceforge.net/"
SLOT="0"
-KEYWORDS="~x86 ~ppc"
+KEYWORDS="~x86 ~ppc ~amd64"
LICENSE="GPL-2"
IUSE="png zlib"
@@ -21,6 +21,13 @@ DEPEND="=x11-libs/gtk+-1*
media-libs/tiff
media-libs/jpeg"
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ epatch ${FILESDIR}/${P}-gcc34.patch
+}
+
src_compile(){
econf --with-openexr-prefix=/usr || die "econf failed"
emake || die "emake failed"
diff --git a/media-video/cinepaint/cinepaint-0.18.ebuild b/media-video/cinepaint/cinepaint-0.18.ebuild
index 2046076309af..2c6fc2386450 100644
--- a/media-video/cinepaint/cinepaint-0.18.ebuild
+++ b/media-video/cinepaint/cinepaint-0.18.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/cinepaint/cinepaint-0.18.ebuild,v 1.2 2004/06/25 00:38:08 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/cinepaint/cinepaint-0.18.ebuild,v 1.3 2005/03/13 20:34:59 luckyduck Exp $
DESCRIPTION="motion picture editing tool used for painting and retouching of movies"
SRC_URI="mirror://sourceforge/cinepaint/${P}.tar.gz"
diff --git a/media-video/cinepaint/files/cinepaint-0.18.3-gcc34.patch b/media-video/cinepaint/files/cinepaint-0.18.3-gcc34.patch
new file mode 100644
index 000000000000..ef6a57d98f20
--- /dev/null
+++ b/media-video/cinepaint/files/cinepaint-0.18.3-gcc34.patch
@@ -0,0 +1,33 @@
+--- plug-ins/psd/psd.c.org 2005-01-04 21:43:35.538672936 -0100
++++ plug-ins/psd/psd.c 2005-01-04 21:56:03.886906712 -0100
+@@ -299,7 +299,7 @@
+ gint *nreturn_vals,
+ GimpParam **return_vals);
+
+-static GImageType psd_type_to_gimp_type (psd_imagetype psdtype);
++static GDrawableType psd_type_to_gimp_type (psd_imagetype psdtype);
+ static GImageType psd_type_to_gimp_base_type (psd_imagetype psdtype);
+ static GLayerMode psd_lmode_to_gimp_lmode (gchar modekey[4]);
+ static GimpUnit psd_unit_to_gimp_unit (gint psdunit);
+@@ -1759,16 +1759,16 @@
+ gimp_image_set_filename (image_ID, name);
+
+ /* in libfilmgimp v0.16 only set resolution of individual layers, not of
+- not of image? Tom Huffman - March 2003
++ not of image? Tom Huffman - March 2003*/
+
+- if (psd_image.resolution_is_set)
++ /*if (psd_image.resolution_is_set)
+ {
+ gimp_image_set_resolution(image_ID,
+ psd_image.resolution.hRes / 65536.0,
+- psd_image.resolution.vRes / 65536.0);
++ psd_image.resolution.vRes / 65536.0);*/
+ /* currently can only set one unit for the image so we use the
+- horizontal unit from the psd image
+- gimp_image_set_unit(image_ID, psd_unit_to_gimp_unit( psd_image.resolution.widthUnit));
++ horizontal unit from the psd image*/
++ /*gimp_image_set_unit(image_ID, psd_unit_to_gimp_unit( psd_image.resolution.widthUnit));
+ }
+ */
+