summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2011-01-11 20:25:04 +0000
committerMichael Weber <xmw@gentoo.org>2011-01-11 20:25:04 +0000
commita02fb251ab400b5b5922bedb5ba61cd0e31c32dd (patch)
treeaacbbb0bc9719ddcbf963ed198980fef86a1459e /media-video/coherence
parentNeeds gnome-panel with bonobo support (bug #348185). (diff)
downloadgentoo-2-a02fb251ab400b5b5922bedb5ba61cd0e31c32dd.tar.gz
gentoo-2-a02fb251ab400b5b5922bedb5ba61cd0e31c32dd.tar.bz2
gentoo-2-a02fb251ab400b5b5922bedb5ba61cd0e31c32dd.zip
Fix python issues (bug 313987) and version bump (bug 349476).
(Portage version: 2.1.9.25/cvs/Linux x86_64)
Diffstat (limited to 'media-video/coherence')
-rw-r--r--media-video/coherence/ChangeLog8
-rw-r--r--media-video/coherence/coherence-0.6.6.1.ebuild12
-rw-r--r--media-video/coherence/coherence-0.6.6.2.ebuild43
3 files changed, 58 insertions, 5 deletions
diff --git a/media-video/coherence/ChangeLog b/media-video/coherence/ChangeLog
index 8d0ae9e9bf39..5d91155f8ed4 100644
--- a/media-video/coherence/ChangeLog
+++ b/media-video/coherence/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-video/coherence
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/coherence/ChangeLog,v 1.5 2011/01/07 09:37:06 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/coherence/ChangeLog,v 1.6 2011/01/11 20:25:04 xmw Exp $
+
+*coherence-0.6.6.2 (11 Jan 2011)
+
+ 11 Jan 2011; Michael Weber <xmw@gentoo.org> coherence-0.6.6.1.ebuild,
+ +coherence-0.6.6.2.ebuild:
+ Fix python issues (bug 313987) and version bump (bug 349476).
07 Jan 2011; Michael Weber <xmw@gentoo.org> coherence-0.6.6.1.ebuild:
added ~sparc keyword (bug 311825)
diff --git a/media-video/coherence/coherence-0.6.6.1.ebuild b/media-video/coherence/coherence-0.6.6.1.ebuild
index 79c94ef5de9f..9ac2ae45603e 100644
--- a/media-video/coherence/coherence-0.6.6.1.ebuild
+++ b/media-video/coherence/coherence-0.6.6.1.ebuild
@@ -1,13 +1,18 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/coherence/coherence-0.6.6.1.ebuild,v 1.5 2011/01/07 09:37:06 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/coherence/coherence-0.6.6.1.ebuild,v 1.6 2011/01/11 20:25:04 xmw Exp $
EAPI=2
-inherit distutils
+PYTHON_DEPEND="*"
+PYTHON_USE_WITH="sqlite"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.4 3.* *-jython"
+
+inherit distutils python
MY_P="Coherence-${PV}"
-DESCRIPTION="Coherence is a framework written in Python for DLNA/UPnP components"
+DESCRIPTION="A framework written in Python for DLNA/UPnP components"
HOMEPAGE="https://coherence.beebits.net/"
SRC_URI="http://coherence.beebits.net/download/${MY_P}.tar.gz"
@@ -27,7 +32,6 @@ RDEPEND="${DEPEND}
dev-python/axiom
dev-python/gdata
dev-python/feedparser
- dev-lang/python[sqlite]
dev-python/tagpy"
S="${WORKDIR}/${MY_P}"
diff --git a/media-video/coherence/coherence-0.6.6.2.ebuild b/media-video/coherence/coherence-0.6.6.2.ebuild
new file mode 100644
index 000000000000..abee6536a86e
--- /dev/null
+++ b/media-video/coherence/coherence-0.6.6.2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/coherence/coherence-0.6.6.2.ebuild,v 1.1 2011/01/11 20:25:04 xmw Exp $
+
+EAPI=2
+PYTHON_DEPEND="*"
+PYTHON_USE_WITH="sqlite"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.4 3.* *-jython"
+
+inherit distutils python
+
+MY_P="Coherence-${PV}"
+
+DESCRIPTION="A framework written in Python for DLNA/UPnP components"
+HOMEPAGE="https://coherence.beebits.net/"
+SRC_URI="http://coherence.beebits.net/download/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~sparc ~x86"
+IUSE=""
+
+# deps are not exact and need some work
+DEPEND="dev-python/louie
+ dev-python/twisted
+ dev-python/twisted-web
+ dev-python/configobj
+ dev-python/gst-python
+ dev-python/nevow"
+RDEPEND="${DEPEND}
+ dev-python/axiom
+ dev-python/gdata
+ dev-python/feedparser
+ dev-python/tagpy"
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ DOCS="docs/*"
+ distutils_src_install
+ newinitd "${FILESDIR}"/coherence-init coherence
+}