summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Schwarzott <zzam@gentoo.org>2009-06-12 19:26:57 +0000
committerMatthias Schwarzott <zzam@gentoo.org>2009-06-12 19:26:57 +0000
commit12af170cc180bb53d758221fb753516f7e444ed1 (patch)
tree563d6a86b57a7c42b9d522b36759432a9a1bdbb9 /media-video/em8300-modules
parentVersion bump (diff)
downloadgentoo-2-12af170cc180bb53d758221fb753516f7e444ed1.tar.gz
gentoo-2-12af170cc180bb53d758221fb753516f7e444ed1.tar.bz2
gentoo-2-12af170cc180bb53d758221fb753516f7e444ed1.zip
Fix compilation with Kernel 2.6.30. Thanks to Helmut Auer <helmut@helmutauer.de>.
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'media-video/em8300-modules')
-rw-r--r--media-video/em8300-modules/ChangeLog10
-rw-r--r--media-video/em8300-modules/em8300-modules-0.17.2.ebuild3
-rw-r--r--media-video/em8300-modules/files/em8300-modules-0.17.2-kernel-2.6.30.patch81
3 files changed, 91 insertions, 3 deletions
diff --git a/media-video/em8300-modules/ChangeLog b/media-video/em8300-modules/ChangeLog
index 2810a6fd3c8b..d5d38d91dd6e 100644
--- a/media-video/em8300-modules/ChangeLog
+++ b/media-video/em8300-modules/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-video/em8300-modules
-# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/em8300-modules/ChangeLog,v 1.48 2009/03/03 10:49:48 zzam Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/em8300-modules/ChangeLog,v 1.49 2009/06/12 19:26:56 zzam Exp $
+
+ 12 Jun 2009; Matthias Schwarzott <zzam@gentoo.org>
+ em8300-modules-0.17.2.ebuild,
+ +files/em8300-modules-0.17.2-kernel-2.6.30.patch:
+ Fix compilation with Kernel 2.6.30. Thanks to Helmut Auer
+ <helmut@helmutauer.de>.
*em8300-modules-0.17.2 (03 Mar 2009)
diff --git a/media-video/em8300-modules/em8300-modules-0.17.2.ebuild b/media-video/em8300-modules/em8300-modules-0.17.2.ebuild
index ee9219dc4b16..fcc9b6f85da7 100644
--- a/media-video/em8300-modules/em8300-modules-0.17.2.ebuild
+++ b/media-video/em8300-modules/em8300-modules-0.17.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/em8300-modules/em8300-modules-0.17.2.ebuild,v 1.1 2009/03/03 10:49:48 zzam Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/em8300-modules/em8300-modules-0.17.2.ebuild,v 1.2 2009/06/12 19:26:56 zzam Exp $
inherit eutils linux-mod
@@ -26,6 +26,7 @@ S="${WORKDIR}/${MY_P}/modules"
src_unpack() {
unpack ${A}
cd "${S}/.."
+ epatch "${FILESDIR}/${P}-kernel-2.6.30.patch"
}
src_compile() {
diff --git a/media-video/em8300-modules/files/em8300-modules-0.17.2-kernel-2.6.30.patch b/media-video/em8300-modules/files/em8300-modules-0.17.2-kernel-2.6.30.patch
new file mode 100644
index 000000000000..6064c3528f40
--- /dev/null
+++ b/media-video/em8300-modules/files/em8300-modules-0.17.2-kernel-2.6.30.patch
@@ -0,0 +1,81 @@
+--- modules/adv717x.c 2008-11-03 01:21:31.000000000 +0100
++++ modules/adv717x.c 2009-06-12 10:51:09.000000000 +0200
+@@ -44,7 +44,9 @@
+
+ #include <linux/i2c.h>
+ #include <linux/i2c-algo-bit.h>
++#if LINUX_VERSION_CODE < KERNEL_VERSION(2,6,30)
+ #include <linux/video_encoder.h>
++#endif
+
+ #include "em8300_compat24.h"
+ #include "em8300_reg.h"
+--- modules/bt865.c 2008-11-03 01:21:31.000000000 +0100
++++ modules/bt865.c 2009-06-12 10:51:03.000000000 +0200
+@@ -48,7 +48,9 @@
+
+ #include <linux/i2c.h>
+ #include <linux/i2c-algo-bit.h>
++#if LINUX_VERSION_CODE < KERNEL_VERSION(2,6,30)
+ #include <linux/video_encoder.h>
++#endif
+
+ #include "em8300_compat24.h"
+ #include "bt865.h"
+--- modules/em8300_procfs.c 2008-11-03 01:21:31.000000000 +0100
++++ modules/em8300_procfs.c 2009-06-12 11:00:08.000000000 +0200
+@@ -154,7 +154,9 @@
+ if (proc) {
+ proc->data = (void *) em;
+ proc->read_proc = em8300_proc_read;
++#if LINUX_VERSION_CODE < KERNEL_VERSION(2,6,30)
+ proc->owner = THIS_MODULE;
++#endif
+ }
+ }
+ }
+@@ -180,11 +182,17 @@
+ em8300_proc = create_proc_entry(EM8300_PROCFS_DIR,
+ S_IFDIR | S_IRUGO | S_IXUGO,
+ NULL);
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,30)
++ if (!em8300_proc) {
++ printk(KERN_ERR "em8300: unable to register proc entry!\n");
++ }
++#else
+ if (em8300_proc) {
+ em8300_proc->owner = THIS_MODULE;
+ } else {
+ printk(KERN_ERR "em8300: unable to register proc entry!\n");
+ }
++#endif
+ }
+
+ struct em8300_registrar_s em8300_procfs_registrar =
+--- modules/em8300_ucode.c 2008-11-03 01:21:31.000000000 +0100
++++ modules/em8300_ucode.c 2009-06-12 10:56:18.000000000 +0200
+@@ -199,7 +199,11 @@
+ #if LINUX_VERSION_CODE >= KERNEL_VERSION(2,5,0)
+ if (request_firmware(&fw_entry, "em8300.bin", &em->dev->dev) != 0) {
+ printk(KERN_ALERT "%s: firmware %s is missing, cannot start.\n",
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,30)
++ dev_name(em->dev), "em8300.bin");
++#else
+ em->dev->dev.bus_id, "em8300.bin");
++#endif
+ return;
+ }
+ #else
+--- modules/em8300_compat24.h 2009-06-12 11:14:52.000000000 +0200
++++ modules/em8300_compat24.h 2009-06-12 11:14:26.000000000 +0200
+@@ -27,8 +27,10 @@
+ #ifndef IRQ_NONE
+ #define IRQ_NONE
+ #define IRQ_HANDLED
++#if LINUX_VERSION_CODE < KERNEL_VERSION(2,6,30)
+ typedef void irqreturn_t;
+ #endif
++#endif
+
+ #if LINUX_VERSION_CODE < KERNEL_VERSION(2,6,18)
+ #ifndef IRQF_DISABLED