summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-03-30 19:51:59 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-03-30 19:51:59 +0000
commit8b537dedf7f3f54e9d16e990c6dc8dee7fff731a (patch)
tree2aa4b40a9b535548bb4a9f5f836ce6f19063ae36 /media-video/flumotion
parentdev-java/netbeans-ide: fixed bug #361357 (diff)
downloadgentoo-2-8b537dedf7f3f54e9d16e990c6dc8dee7fff731a.tar.gz
gentoo-2-8b537dedf7f3f54e9d16e990c6dc8dee7fff731a.tar.bz2
gentoo-2-8b537dedf7f3f54e9d16e990c6dc8dee7fff731a.zip
Version bump wrt #344263.
(Portage version: 2.2.0_alpha29/cvs/Linux x86_64)
Diffstat (limited to 'media-video/flumotion')
-rw-r--r--media-video/flumotion/ChangeLog7
-rw-r--r--media-video/flumotion/flumotion-0.8.1.ebuild86
2 files changed, 92 insertions, 1 deletions
diff --git a/media-video/flumotion/ChangeLog b/media-video/flumotion/ChangeLog
index 663fa921fcab..fc200e9a2d62 100644
--- a/media-video/flumotion/ChangeLog
+++ b/media-video/flumotion/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-video/flumotion
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/flumotion/ChangeLog,v 1.23 2011/03/30 18:58:04 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/flumotion/ChangeLog,v 1.24 2011/03/30 19:51:59 ssuominen Exp $
+
+*flumotion-0.8.1 (30 Mar 2011)
+
+ 30 Mar 2011; Samuli Suominen <ssuominen@gentoo.org> +flumotion-0.8.1.ebuild:
+ Version bump wrt #344263.
30 Mar 2011; Samuli Suominen <ssuominen@gentoo.org> flumotion-0.6.2.ebuild:
Stop installing 91-flumotion-device-policy.fdi because sys-apps/hal is
diff --git a/media-video/flumotion/flumotion-0.8.1.ebuild b/media-video/flumotion/flumotion-0.8.1.ebuild
new file mode 100644
index 000000000000..6140d875fba8
--- /dev/null
+++ b/media-video/flumotion/flumotion-0.8.1.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/flumotion/flumotion-0.8.1.ebuild,v 1.1 2011/03/30 19:51:59 ssuominen Exp $
+
+EAPI=3
+
+PYTHON_DEPEND="2:2.6"
+
+inherit eutils flag-o-matic multilib python toolchain-funcs virtualx # AC_CHECK_PROG for Xvfb
+
+DESCRIPTION="Flumotion Streaming server"
+HOMEPAGE="http://www.flumotion.net/"
+SRC_URI="http://www.flumotion.net/src/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2" # LICENSE.Flumotion
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ doc? ( dev-python/epydoc )
+ test? ( dev-python/pychecker )"
+
+src_prepare() {
+ rm -f py-compile
+ ln -s $(type -P true) py-compile
+}
+
+src_configure() {
+ append-cflags -fno-strict-aliasing
+
+ econf \
+ --localstatedir=/var \
+ $(use_enable doc docs)
+}
+
+src_compile() {
+ emake -j1 fdpass_so_LINK="$(tc-getCC) ${LDFLAGS} -shared -o fdpass.so" || die
+}
+
+src_install() {
+ emake -j1 DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog NEWS README RELEASE TODO
+
+ dodir /etc/flumotion
+ dodir /etc/flumotion/managers
+ dodir /etc/flumotion/managers/default
+ dodir /etc/flumotion/managers/default/flows
+ dodir /etc/flumotion/workers
+
+ pushd conf
+ insinto /etc/flumotion/managers/default
+ doins managers/default/planet.xml || die
+ insinto /etc/flumotion/workers
+ doins workers/default.xml || die
+ insinto /etc/flumotion
+ doins default.pem || die
+ popd
+
+ keepdir /var/log/flumotion
+ keepdir /var/run/flumotion
+
+ newinitd "${FILESDIR}"/flumotion-init-0.2.0 flumotion
+
+ # /usr/share/hal/fdi/policy/20thirdparty/91-flumotion-device-policy.fdi
+ rm -rf "${D}"/usr/share/hal
+}
+
+pkg_postinst() {
+ if ! enewgroup flumotion || ! enewuser flumotion -1 -1 /usr/share/flumotion flumotion,audio,video,sys; then
+ die "Unable to add flumotion user and flumotion group."
+ fi
+
+ for dir in /usr/share/flumotion /var/log/flumotion /var/run/flumotion; do
+ chown -R flumotion:flumotion "${dir}"
+ chmod -R 755 "${dir}"
+ done
+
+ python_mod_optimize /usr/$(get_libdir)/flumotion/python
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/$(get_libdir)/flumotion/python
+}