summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2012-03-22 21:56:14 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2012-03-22 21:56:14 +0000
commit07ac8c26e25fd1cd81d7edbe82533190941cfc37 (patch)
treea21be291f8b740db7160ed0d7bc568772316c7af /media-video/griffith
parentVersion bump. (diff)
downloadgentoo-2-07ac8c26e25fd1cd81d7edbe82533190941cfc37.tar.gz
gentoo-2-07ac8c26e25fd1cd81d7edbe82533190941cfc37.tar.bz2
gentoo-2-07ac8c26e25fd1cd81d7edbe82533190941cfc37.zip
Version bump. Ebuild clean up. EAPI4
(Portage version: 2.2.0_alpha90/cvs/Linux x86_64)
Diffstat (limited to 'media-video/griffith')
-rw-r--r--media-video/griffith/ChangeLog10
-rw-r--r--media-video/griffith/griffith-0.13.ebuild78
-rw-r--r--media-video/griffith/griffith-9999.ebuild20
3 files changed, 94 insertions, 14 deletions
diff --git a/media-video/griffith/ChangeLog b/media-video/griffith/ChangeLog
index 3ba648f87dfe..6db3d482dd33 100644
--- a/media-video/griffith/ChangeLog
+++ b/media-video/griffith/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-video/griffith
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/griffith/ChangeLog,v 1.57 2011/08/05 09:39:16 hwoarang Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/griffith/ChangeLog,v 1.58 2012/03/22 21:56:14 hwoarang Exp $
+
+*griffith-0.13 (22 Mar 2012)
+
+ 22 Mar 2012; Markos Chandras <hwoarang@gentoo.org> +griffith-0.13.ebuild,
+ griffith-9999.ebuild:
+ Version bump. Ebuild clean up. EAPI4
05 Aug 2011; Markos Chandras <hwoarang@gentoo.org> griffith-9999.ebuild:
Comply with EAPI3 standards
diff --git a/media-video/griffith/griffith-0.13.ebuild b/media-video/griffith/griffith-0.13.ebuild
new file mode 100644
index 000000000000..6f5c17dc1851
--- /dev/null
+++ b/media-video/griffith/griffith-0.13.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/griffith/griffith-0.13.ebuild,v 1.1 2012/03/22 21:56:14 hwoarang Exp $
+
+EAPI="4"
+
+PYTHON_DEPEND="2"
+
+inherit eutils versionator python multilib
+
+ARTWORK_PV="0.9.4"
+
+DESCRIPTION="Movie collection manager"
+HOMEPAGE="http://griffith.berlios.de/"
+SRC_URI="http://launchpad.net/${PN}/trunk/${PV}/+download/${P}.tar.gz
+ mirror://berlios/griffith/${PN}-extra-artwork-${ARTWORK_PV}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+IUSE="doc"
+
+RDEPEND="dev-python/imaging
+ gnome-base/libglade
+ dev-python/pyxml
+ >=dev-python/pygtk-2.6.1:2
+ dev-python/pygobject:2
+ dev-python/pysqlite:2
+ >=dev-python/sqlalchemy-0.5.2
+ >=dev-python/reportlab-1.19"
+DEPEND="${RDEPEND}
+ doc? ( app-text/docbook2X )"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ sed -i \
+ -e 's#/pl/#/pl.UTF-8/#' \
+ "${S}"/docs/pl/Makefile || die "sed failed"
+
+ sed -i \
+ -e 's/ISO-8859-1/UTF-8/' \
+ "${S}"/lib/gconsole.py || die "sed failed"
+ epatch "${FILESDIR}/0.10-fix_lib_path.patch"
+}
+
+src_compile() {
+ # Nothing to compile and default `emake` spews an error message
+ true
+}
+
+src_install() {
+ use doc || { sed -i -e '/docs/d' Makefile || die ; }
+
+ emake \
+ LIBDIR="${D}/usr/$(get_libdir)/griffith" \
+ DESTDIR="${D}" DOC2MAN=docbook2man.pl install
+ dodoc AUTHORS ChangeLog README THANKS TODO NEWS TRANSLATORS
+
+ cd "${WORKDIR}/${PN}-extra-artwork-${ARTWORK_PV}/"
+ emake DESTDIR="${D}" install
+}
+
+pkg_postinst() {
+ python_mod_optimize /usr/$(get_libdir)/${PN}
+ einfo
+ einfo "${PN} can make use of the following optional dependencies"
+ einfo "dev-python/chardet: CSV file encoding detections"
+ einfo "dev-python/mysql-python: Python interface for MySQL connectivity"
+ einfo ">=dev-python/psycopg-2.4: Python interface for PostgreSQL connectivity"
+ einfo
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/$(get_libdir)/${PN}
+}
diff --git a/media-video/griffith/griffith-9999.ebuild b/media-video/griffith/griffith-9999.ebuild
index 83a73f822034..909aa61c7e4f 100644
--- a/media-video/griffith/griffith-9999.ebuild
+++ b/media-video/griffith/griffith-9999.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/griffith/griffith-9999.ebuild,v 1.7 2011/08/05 09:39:16 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/griffith/griffith-9999.ebuild,v 1.8 2012/03/22 21:56:14 hwoarang Exp $
-EAPI="3"
+EAPI="4"
ESVN_REPO_URI="http://svn.berlios.de/svnroot/repos/griffith/trunk"
inherit eutils python multilib subversion
@@ -15,7 +15,7 @@ SRC_URI="mirror://berlios/griffith/${PN}-extra-artwork-${ARTWORK_PV}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS=""
-IUSE="csv doc spell"
+IUSE="doc"
RDEPEND="dev-python/imaging
dev-util/glade:3
@@ -25,9 +25,7 @@ RDEPEND="dev-python/imaging
dev-python/pysqlite:2
>=dev-python/sqlalchemy-0.5.2
>=dev-python/reportlab-1.19
- >=dev-python/sqlalchemy-0.4.6
- csv? ( dev-python/chardet )
- spell? ( dev-python/gtkspell-python )"
+ >=dev-python/sqlalchemy-0.4.6"
DEPEND="${RDEPEND}
doc? ( app-text/docbook2X )"
@@ -38,12 +36,10 @@ pkg_setup() {
}
src_unpack() {
- unpack ${A}
subversion_src_unpack
}
src_prepare() {
- cd "${S}"
sed -i \
-e 's#/pl/#/pl.UTF-8/#' \
docs/pl/Makefile || die "sed failed"
@@ -66,16 +62,16 @@ src_compile() {
}
src_install() {
- use doc || sed -i -e '/docs/d' Makefile
+ use doc || { sed -i -e '/docs/d' Makefile || die ; }
python_version
emake \
LIBDIR="${D}/usr/$(get_libdir)/griffith" \
- DESTDIR="${D}" DOC2MAN=docbook2man.pl install || die "emake install failed"
+ DESTDIR="${D}" DOC2MAN=docbook2man.pl install
dodoc AUTHORS ChangeLog README THANKS TODO NEWS TRANSLATORS
cd "${WORKDIR}/${PN}-extra-artwork-${ARTWORK_PV}/"
- emake DESTDIR="${D}" install || die "emake install artwork failed"
+ emake DESTDIR="${D}" install
}
pkg_postinst() {