summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2004-11-09 22:39:36 +0000
committerMartin Schlemmer <azarah@gentoo.org>2004-11-09 22:39:36 +0000
commit3e458efc8d61cbc5690422b0cbbbd2b7e0a577a2 (patch)
tree4408f93d4842e5980d9c4f2ca90baab6f314175b /media-video/nvidia-kernel/nvidia-kernel-1.0.6629.ebuild
parentinitial ebuild (see bug 38610) (diff)
downloadgentoo-2-3e458efc8d61cbc5690422b0cbbbd2b7e0a577a2.tar.gz
gentoo-2-3e458efc8d61cbc5690422b0cbbbd2b7e0a577a2.tar.bz2
gentoo-2-3e458efc8d61cbc5690422b0cbbbd2b7e0a577a2.zip
Update to work with 2.6.10-rc1-mm3+ (basically add support for the new pml4
stuff from Andi Kleen ... with a bit of help from him). Fix 'using smp_processor_id() in preemptible code' traces. Remove -Wpointer-arith to quiet down build (should really be a flag that they enable for internal debugging).
Diffstat (limited to 'media-video/nvidia-kernel/nvidia-kernel-1.0.6629.ebuild')
-rw-r--r--media-video/nvidia-kernel/nvidia-kernel-1.0.6629.ebuild14
1 files changed, 11 insertions, 3 deletions
diff --git a/media-video/nvidia-kernel/nvidia-kernel-1.0.6629.ebuild b/media-video/nvidia-kernel/nvidia-kernel-1.0.6629.ebuild
index 3db52447f0bd..01b24e58f47e 100644
--- a/media-video/nvidia-kernel/nvidia-kernel-1.0.6629.ebuild
+++ b/media-video/nvidia-kernel/nvidia-kernel-1.0.6629.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/nvidia-kernel/nvidia-kernel-1.0.6629.ebuild,v 1.2 2004/11/07 23:30:45 cyfred Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/nvidia-kernel/nvidia-kernel-1.0.6629.ebuild,v 1.3 2004/11/09 22:39:36 azarah Exp $
inherit eutils kernel-mod
@@ -92,6 +92,12 @@ src_unpack() {
cd ${S}
# Fix the /usr/src/linux/include/asm not existing on koutput issue #58294
epatch ${FILESDIR}/${PV}/conftest_koutput_includes.patch
+ # Fix pgd_offset() -> pml4_pgd_offset() for >=2.6.10-rc1-mm3
+ epatch ${FILESDIR}/${PV}/nv-pgd_offset.patch
+ # Fix calling of smp_processor_id() when preempt is enabled
+ epatch ${FILESDIR}/${PV}/nv-disable-preempt-on-smp_processor_id.patch
+ # Shutup pointer arith warnings
+ epatch ${FILESDIR}/${PV}/nv-shutup-warnings.patch
# if you set this then it's your own fault when stuff breaks :)
[ ! -z "${USE_CRAZY_OPTS}" ] && sed -i "s:-O:${CFLAGS}:" Makefile.*
@@ -169,11 +175,13 @@ pkg_postinst() {
einfo "If you need to load the module automatically on boot up you need"
einfo "to add \"nvidia\" to /etc/modules.autoload.d/kernel-${KV_MAJOR}.${KV_MINOR}"
echo
- einfo "Please note that the driver name is \"nvidia\", not \"NVdriver\""
- echo
einfo "This module will now work correctly under udev, you do not need to"
einfo "manually create the devices anymore."
echo
+ ewarn "If you are using 2.6.10-r1-(bk|mm)[0-9]*, please note that you might have"
+ ewarn "to disable the kernel agp driver, and use NVAGP instead, as there are some"
+ ewarn "unresolved issues with some kernel agp drivers ..."
+ echo
einfo "Checking kernel module dependencies"
test -r "${ROOT}/usr/src/linux/System.map" && \
depmod -ae -F "${ROOT}/usr/src/linux/System.map" -b "${ROOT}" -r ${KV}